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Introduction 
Intended Use of This Product 

The PIAM-100 is a small computer with on-board I/O based on the “Open-Source Arduino 
platform”. This product can be used to solve various control and automation tasks using 
customized programs.
The user community website of PIAM-100 (http://go2adc.com/p1am) is where you 
will find various demo programs and libraries that will allow you to jump right into 
programming and design.
Follow all applicable safety parameters when connecting to external I/O sensors and 
devices.
Any use other: than described in this manual is not permitted, as this may expose the user 
to possible harm and/or damage to the device or connected equipment. 
The P1AM-100 must not be altered or modified. The safety instructions as well as the 
maximum permissible ambient conditions and operating parameters are given in Chapter 
2 “Technical Specifications”.  
The instruction manual is meant to be read thoroughly while being mindful of safe and 
proper operation. It contains important information on mounting, operating and handling 
the P1AM-100. 

CAUTION: The P1AM CPU Base Controller uses pins A3 and A4 so any shield that 
uses these same pins will have a conflict.  The MKR RGB shield is one that has this 
conflict.

http://go2adc.com/p1am
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Purpose of this Manual  
Thank you for purchasing the AutomationDirect ProductivityOpen Arduino compatible 
Controller.  This user manual provides information that will help you install, set up, program, 
troubleshoot, and maintain your ProductivityOpen project.  
The manual includes information that is critical to the safety of the personnel who will install 
and use the controller and to the machinery, processes, and equipment controlled by the 
P1AM-100.
The manual also includes important information about power and signal wiring, mounting 
the CPU and modules, and configuring the system.

Important Online Resources
Access to ADC Community based help for your ProductivityOpen projects is available from 
our website: http://go2adc.com/p1am.
You will need libraries and other files available from our GitHub page at  
https://github.com/facts-engineering/P1AM

The P1AM libraries and Board Support Package and other support files are located on 
Github.
A variety of other useful information about the Productivity1000 I/O modules, as well as 
code for example tasks and more is available at https://facts-engineering.github.io.

The P1AM-100 may be programmed by Arduino IDE which may be downloaded from  
https://www.arduino.cc/en/Main/Software.  A graphical programming tool customized for 
P1AM-100 based on ArduBlock (ProductivityBlocks® )is accessible from the Tools menu in 
the Arduino IDE. 

In addition, the Productivity1000 series power supplies and I/O modules, which work with 
the P1AM-100, include an installation insert.

Use a QR symbol reader or click on graphic icon to see an overview video. 

http://go2adc.com/p1am
https://github.com/facts-engineering/P1AM
http://facts-engineering.github.io
https://www.arduino.cc/en/Main/Software
https://www.automationdirect.com/VID-PA-0001
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Conventions Used

NOTE: When you see the “note pad” icon in the left-hand margin, the paragraph to its immediate 
right will be a special note.  Notes represent information that may make your work quicker or 
more efficient.  The word NOTE in boldface will mark the beginning of the text.

WARNING: When you see the “exclamation point” icon in the left-hand margin, the 
paragraph to its immediate right will be a warning.  This information could prevent 
injury, loss of property, or even death in extreme cases.  Any warning in this manual 
should be regarded as critical information that should be read in its entirety. The 
word WARNING in boldface will mark the beginning of the text.

Key Topics for Each Chapter
The beginning of each chapter will list 
the key topics that can be found in that 
chapter.
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Install Programming Software

NOTE: An active Internet connection is required to download the Arduino IDE and access the 
libraries and board driver.

The P1AM-100 CPU may be programmed with the Arduino IDE. ProductivityBlocks® is an 
optional graphical environment used with the IDE that AutomationDirect has adapted to 
make Productivity1000 I/O modules conveniently accessible as blocks. 

1. Download the latest version of the Arduino IDE software 
from https://www.arduino.cc/en/Main/Software.

2. Library Install: 
a. In the Arduino IDE go to “Sketch -> Include Library -> Manage Libraries…” 
b. Leave the Type and Topic filters as “All” and type “P1AM” in the “Filter your 

search…” box
c. Click on the P1AM by FACTS Engineering that appears
d. Click the Install button
e. Close the Library Manager window
f. Confirm the installation by checking for “File -> Examples -> P1AM-100”. Several 

categories of examples should be present.

CCCC
Blocks

Productivity

https://www.arduino.cc/en/Main/Software
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3. Arduino Board Support Package Install: 
a.  Go to “File->Preferences” and paste the following link into the “Additional Boards 

Manager URLs” field.

NOTE:  Make sure you right click on the link and choose “Copy Link”.

 i.  https://raw.githubusercontent.com/facts-engineering/facts-engineering.github.
io/master/package_productivity-P1AM-boardmanagermodule_index.json

b.  Go to “Tools -> Boards -> Board Manager”.  Type P1AM into the search box at 
the top. Mouse over the result and click install.  The install may take several 
minutes to complete.
c.  If you are on a version of Windows before Windows 10 this is mandatory.  For 

Windows 10 users, this may be run if you want the board to appear as P1AM-
100 (or P1AM-200) in device manager. 

  i. Download the “driver install” file from this link:  
https://github.com/facts-engineering/P1AMCore/raw/master/drivers.zip.

  ii. Extract the file 
  iii. Run the “P1AM-100_install.bat” file to complete the driver installation.
d. If you are having trouble installing the BSP due to network issues such as 

firewall restrictions, you can use the “Arduino SAMD Boards” (specifically the 
MKRZERO) as an alternative. These are present in the board manager 
automatically.

4. Testing installation
a. Attach the modules and/or shields you wish to use. REMEMBER modules/shields 

must not be connected or disconnected while power is applied - either 24V or 
USB.

b. Plug the micro USB cable into the P1AM CPU and computer
  i. If using P1000 I/O modules power the system with 24V

c. Go to “Tools -> Board:” and select the “P1AM-100 or P1AM-200” from the 
dropdown that appears.

d. Go to “Tools -> Port” and select the “P1AM CPU” device that you have plugged in.
e. Go to File -> Examples -> P1AM-100 (or P1AM-200) ->Basic->PrintModules to 

open the Print Modules example. Note that the  PrintModules example is intended 
for a system with Productivity1000 modules connected and powered.

f. Click the right facing arrow button under “Edit” to upload the code to the board.
g. Go to “Tools -> Serial Monitor” and check to see that the name of module(s) you 

have in the base is printing to the terminal.

https://raw.githubusercontent.com/facts-engineering/facts-engineering.github.io/master/package_productivity-P1AM-boardmanagermodule_index.json
https://raw.githubusercontent.com/facts-engineering/facts-engineering.github.io/master/package_productivity-P1AM-boardmanagermodule_index.json
https://github.com/facts-engineering/P1AMCore/raw/master/drivers.zip
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5. Next Steps
a. Start with the “Basic” category of the P1AM CPU Library examples to become 

familiar with the API. 
b. Once you are comfortable with the basic examples you can move on to more 

complex routines included in the P1AM CPU examples.
6. Install ProductivityBlocks®

a. Run the ProductivityBlocks Installer.
b. ProductivityBlocks will be installed in the Documents -> ProductivityBlocks folder. 

The ProductivityBlocks programming environment is accessible from the Tools 
menu in the Arduino IDE.

c. Example ProductivityBlocks programs are also included in this folder.

Blocks
Productivity
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Step One: With latch 
in “locked” position, align 
connectors on the side of 
each module and stack 
by pressing together.  An 
audible click indicates lock is 
engaged.

Step Two: Attach field wiring 
using the removable terminal 
block or ZIPLink wiring system. 

CAUTION!  Ensure all 
latches are secured after 
modules are connected.

Step Three: To unstack 
modules, pull locking latch up into 
the unlocked position and then 
pull modules apart.

Mounting Hardware
Install Shields on the left side of the P1AM CPU and P1 I/O Modules on the right side 
of the P1AM CPU.
The ProductivityOpen Shields and Productivity1000 Input/Output modules are DIN 
rail mountable and designed to snap together to simplify connection.  A system 
may include communications, inputs and outputs. See Chapter 3 of this manual 
and Chapters 4 and 5 of the Productivity1000 manual for more detailed hardware 
installation information.  

WARNING!  Do not add or remove modules with field power applied!
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Power the System
NOTE: Ensure all modules are connected to the system before power is applied. Do not assemble 
or disassemble the system while power is applied. 

Productivity1000 Power Supplies:
1. Connect one of the Productivity1000 power supplies to P1AM CPU.  Should 

you choose Arduino MKR compatible shields instead of or in addition 
to the ProductivityOpen shields, the Productivity1000 power supplies 
cannot be used. In this case an alternative power supply is required (See 
below for information on connecting an external power supply).

P1000 AC input power supplies: 
• P1-01AC: AC Input 85–132 / 170–264 VAC, 16W  

(power for P1AM-100 and up to 8 modules)
• P1-02AC: AC Input 85–132 / 170–264 VAC, 26W  

(power for P1AM-100 and up to 15 modules)
P1000 DC input power supplies: 

• P1-01DC: DC Input 12–24 VDC, 16W  
(power for P1AM-100 and up to 8 modules)

CAUTION: Ensure that only one power supply source is connected to the Arduino 
system.  When a Productivity1000 power supply is connected immediately to the left 
of the CPU module, the bottom Power Connector must be removed before connecting 
P1-01AC Power Supply.  This precludes connection of two separate power supplies. If 
an AutomationDirect shield is connected between a Productivity1000 power supply 
and the CPU module care must be taken to ensure an external power supply is not 
connected to the bottom terminals. 

P1-01DCP1-01AC P1-02AC

P1-01DC

+V

-V

G

LG

12-24V     21W

™

P1-02AC

AC (L)

AC (N)

G

LG

100-240V      74VA
50-60Hz

125VDC, 33W

DC (+V)

DC (-V)

™

P1-01AC

AC (L)

AC (N)

G

LG

100-240V      48VA
50-60Hz

125VDC, 20W

DC (+V)

DC (-V)

®
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Terminal Block Specifications
Part Number PCON-KIT
Number of positions 3 screw terminals
Pitch 3.5 mm

Wire Range 28–16 AWG (0.324 to 3.31 mm²) Solid / Stranded conductor 
1/4 in (6–7 mm) Strip Length

Conductors Use copper conductors, 75°C or equivalent
Screw Driver Width 1/8 in (3.175 mm) Maximum
Screw Size M2
Screw Torque 1.7 lb·in (0.4 N·m)

*Recommended screw driver P/N:  TW-SD-MSL-2

2. OR using an alternative 24VDC external power source connect directly 
to P1AM CPU Optional Power Connector terminals. This option allows 
for the use of Input/Output modules from the Productivity1000 
family as well as all Arduino MKR compatible shields. 

• The LG and minus terminals on the external power supply connection are 
internally shorted.

• Use separate 24VDC supplies, one for the P1AM CPU and another for inductive 
loads to keep the P1AM CPU supply power clean and free of voltage spikes 
caused by switching inductive loads.

Example of Alternative  
24VDC Power Supply

RHINO Power Supply 
P/N PSV24-50s
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3. OR using USB input power, connect to the microB USB port on the 
face of the P1AM CPU.  USB power is intended for programming 
and will not power Productivity1000 Input /output modules.

Micro USB Type B Input Specifications
Port Name Micro USB
Description Standard Micro USB input for programming and monitoring
Port Status LED Green LED is illuminated when a power cable is plugged in. 

Cables
USB Type A to Micro USB Type B:  
    6ft cable part # USB-CBL-AMICB6 
   15ft cable part # USB-CBL-AMICB15
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