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Hardware Maintenance

Standard Maintenance
The Productivity3000 is a low maintenance system requiring only a few periodic checks to
help reduce the risks of problems. Routine maintenance checks should be made regarding two
key items.

• Air quality (cabinet temperature, airflow, etc.)

• CPU battery

Air Quality Maintenance
The quality of the air your system is exposed to can affect system performance. If you have
placed your system in an enclosure, check to see that the ambient temperature is not
exceeding the operating specifications. If there are filters in the enclosure, clean or replace
them as necessary to ensure adequate airflow. A good rule of thumb is to check your system
environment every one to two months. Make sure the Productivity3000 is operating within
the system operating specifications. 

CPU Battery Replacement
A battery is included with the
P3-550 CPU, but is not
installed. The battery can be
installed to retain the Time and
Date along with any Tagname
values that are set up as
retentive. 

The battery is not needed for
program backup. 

Step One:
Press spring lock and swing 
battery compartment away 
from CPU.

Step Two
Insert battery and
close compartment.

Battery (Optional)
D2-BAT-1

Coin type, 3.0V Lithium 

battery, 560mA, battery

number CR2354

_

+



Diagnostics

Diagnostics 
Your Productivity3000 system performs many pre-defined diagnostic routines with every CPU scan.
The diagnostics have been designed to detect various types of failures for the CPU and I/O modules.
There are two primary error classes, critical and non-critical.

Critical Errors
Critical errors are errors the CPU has detected that offer a risk of the system not functioning safely or
properly. If the CPU is in Run Mode when the critical error occurs, the CPU will switch to Stop Mode.
(Remember, in Stop Mode all outputs are turned off.) If the critical error is detected while the CPU is in
Stop Mode, the CPU will not enter Run Mode until the error has been corrected. Here are some
examples of critical errors.

• Base power supply failure

• Parity error or CPU malfunction

• I/O configuration errors

• Certain programming errors

Non-Critical Errors
Non-critical errors are errors that are flagged by the CPU as requiring attention. They can neither
cause the CPU to change from Run Mode to Stop Mode, nor do they prevent the CPU from
entering Run Mode. There are system tags the application program can use to detect if a non-critical
error has occurred. The application program can be used to take the system to an orderly shutdown
or to switch the CPU to Stop Mode if necessary. 

Some examples of non-fatal errors are:

• Backup battery voltage low

• All I/O module errors

• Certain programming errors

Finding Diagnostic Information
The CPU automatically logs critical and non-critical error codes. This information can be
found in the following places marked with a time and date stamp.

• The LCD on the CPU module by scrolling through the menu.

• The PAC Error History window under the Monitor Debug tool of ProductivitySuite lists the 20 
most recent critical and non-critical errors.

Appendix B in this manual has a complete list of error messages sorted by error types.

Error Codes
See Appendix B for Productivity3000 Error Codes.
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CPU Indicators
The Productivity3000 CPU has indicators on the front to help you diagnose problems with
the system. The table below gives a quick reference of potential problems associated with
each status indicator. Following the table will be a detailed analysis of each of these indicator
problems.

Indicator Status Potential Problems

PWR (off) 
1. System voltage incorrect
2. Power supply/CPU is faulty
3. Other component such an I/O module has power supply shorted

RUN (will not come on) 
1. CPU programming error
2. Switch in STOP position

CPU (blink) CPU internal error

CPU Status Indicators
PWR Green LED is illuminated when power is on

RUN Green LED is illuminated when CPU is in

RUN mode

CPU Red LED is illuminated during power on

reset, power down, or watch-dog time-out.

UNLOCK
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PWR Indicator
There are three general reasons for the CPU power status LED (PWR) to be OFF:

1. Power to the base is incorrect or is not applied.

2. Base power supply is faulty.

3. Other component(s) have the power supply shut down.

Incorrect Base Power
If the voltage to the power supply is not correct, the CPU and/or base may not operate
properly or may not operate at all. Use the following guidelines to correct the problem.

WARNING: To minimize the risk of electrical shock, always disconnect the system power before
inspecting the physical wiring.

1. First, disconnect the system power and check all incoming wiring for loose connections.

2. If you are using a separate termination panel, check those connections to make sure the wiring is
connected to the proper location.

3. If the connections are acceptable, reconnect the system power and measure the voltage at the base
terminal strip to insure it is within specification. If the voltage is not correct shut down the system
and correct the problem.

4. If all wiring is connected correctly and the incoming power is within the specifications required,
the base power supply should be returned for repair.

Faulty CPU
There is not a good check to test for a faulty CPU other than substituting a known good one
to see if this corrects the problem. If you have experienced major power surges, it is possible
the CPU and power supply have been damaged. If you suspect this is the cause of the power
supply damage, a line conditioner which removes damaging voltage spikes should be used in
the future. 
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Device or Module Causing the Power Supply to Shutdown
It is possible a faulty module can shut down the power supply. This 5V can be coming from
the base or from the CPU communication ports.

To test for a device causing this problem:
1. Turn off power to the CPU.

2. Disconnect all external devices (i.e., communication cables) from the CPU.

3. Reapply power to the system.

If the power supply operates normally you may have either a shorted device or a shorted
cable. If the power supply does not operate normally then test for a module causing the
problem by following the steps below:

If the PWR LED operates normally the problem could be in one of the modules. To isolate
which module is causing the problem, disconnect the system power and remove one module
at a time until the PWR LED operates normally. Follow the procedure below:

• Turn off power to the base.

• Remove a module from the base.

• Reapply power to the base.

Bent base connector pins on the module can cause this problem. Check to see the connector
is not the problem.
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Run Indicator
If the CPU will not enter the Run mode (the RUN indicator is off ), the problem is usually
in the application program, unless the CPU has a critical error. If a critical error has
occurred, the CPU LED should be on. (You can use a programming device to determine the
cause of the error.)

A complete list of error codes can be found in Appendix B.

CPU Indicator
If the CPU indicator is on, a critical error has occurred in the CPU. Generally, this is not a
programming problem but an actual hardware error. The CPU indicator should blink briefly
and then do an automatic reboot. 

If the error clears, you should monitor the system and determine what caused the problem.
You will find this problem is sometimes caused by high frequency electrical noise introduced
into the CPU from an outside source. Check your system grounding and install electrical
noise filters if the grounding is suspected. If power cycling the system does not reset the
error, or if the problem returns, you should replace the CPU.

Communications Problems
If you cannot establish communications with the CPU, check these items.

• The cable is disconnected.

• The cable has a broken wire or has been wired incorrectly.

• The cable is improperly terminated or grounded.

• The device connected is not operating at the correct baud rate.

• The device connected to the port is sending data incorrectly.

• A grounding difference exists between the two devices.

• Electrical noise is causing intermittent errors.

• The CPU has a bad communication port and the CPU should be replaced.

If an error occurs, the indicator will come on and stay on until a successful communication
has been completed.
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I/O Module Troubleshooting

Things to Check
If you suspect an I/O error, there are several things that could be causing the problem.

• A blown fuse

• A loose terminal block

• The 24 VDC supply has failed

• The module has failed

• The I/O configuration check detects a change in the I/O configuration

Error Codes
See Appendix B for Productivity3000 error code information.

Also, in the Productivity Suite programming software, you can go to:

Tools > PAC Error History, and

Tools > PAC Event History

Next, “Read CPU Error/Event History to get an updated list of critical errors, non-critical
errors and events that should indicate problems or changes to the I/O. This list will give the
“GBS” (group, base, slot numbers).

Some Quick Steps
When troubleshooting the Productity3000 I/O modules there are a few facts you should be
aware of which may assist you in quickly correcting an I/O problem:

• The output modules cannot detect shorted or open output points. If you suspect one or more
points on a output module to be faulty, you should measure the voltage drop from the common to
the suspect point. Remember, when using a Digital Volt Meter, leakage current from an output
device, such as a triac or a transistor, must be considered. A point which is off may appear to be on
if no load is connected to the point.

• The I/O point status indicators on the modules are logic side indicators. This means the LED
which indicates the on or off status reflects the status of the point in respect to the CPU. On an
output module, the status indicators could be operating normally, while the actual output device
(transistor, triac etc.) could be damaged. With an input module, if the indicator LED is on, the
input circuitry should be operating properly. To verify proper functionality, check to see that the
LED goes off when the input signal is removed.

• Leakage current can be a problem when connecting field devices to I/O modules. False input
signals can be generated when the leakage current of an output device is great enough to turn on
the connected input device. To correct this, install a resistor in parallel with the input or output of
the circuit. The value of this resistor will depend on the amount of leakage current and the voltage
applied but usually a 10K to 20K resistor will work. Ensure the wattage rating of the resistor is
correct for your application.

• The easiest method to determine if a module has failed is to replace it if you have a spare. However,
if you suspect another device to have caused the failure in the module, that device may cause the
same failure in the replacement module as well. As a point of caution, you may want to check
devices or power supplies connected to the failed module before replacing it with a spare module.
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Testing Output Points
Output points can be set on or off using the force function to override a point even while
the program is running. However, this is not a recommended method to test the output
points. If you want to do an I/O check independent of the application program, follow this
procedure:

WARNING: Depending on your application, forcing I/O points may cause unpredictable machine
Operation that can result in a risk of personal injury or equipment damage. Make sure you have taken
all appropriate safety precautions prior to testing any I/O points.

The LCD on Analog /O modules displays actual voltage, current, and digital values without
connecting a meter.

Step Action
1 Use ProductivitySuite programming software to communicate online to the PAC.
2 Change to Program Mode.
3 Go to the first rung of the ladder.

4 Insert a rung with an “END” statement. (This will cause program execution to occur only at address 0
and prevent the application program from turning the I/O points on or off).

5 Change to Run Mode.
6 Use the programming device to set (turn) on or off the points you wish to test.
7 When you finish testing I/O points delete the “END” statement at the first rung.
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Noise Troubleshooting

Electrical Noise Problems
Noise is one of the most difficult problems to diagnose. Electrical noise can enter a system in
many different ways and falls into one of two categories, conducted or radiated. It may be
difficult to determine how the noise is entering the system but the corrective actions for
either of the types of noise problems are similar.

• Conducted noise is when the electrical interference is introduced into the system by way of an
attached wire, panel connection, etc. It may enter through an I/O module, a power supply
connection, the communication ground connection, or the chassis ground connection.

• Radiated noise is when the electrical interference is introduced into the system without a direct
electrical connection, much in the same manner as radio waves.

Reducing Electrical Noise
While electrical noise cannot be eliminated it can be reduced to a level that will not affect the
system.

• Most noise problems result from improper grounding of the system. A good earth ground can be
the single most effective way to correct noise problems. If a ground is not available, install a ground
rod as close to the system as possible. Ensure all ground wires are single point grounds and are not
daisy chained from one device to another. Ground metal enclosures around the system. A loose
wire is no more than a large antenna waiting to introduce noise into the system; therefore, you
should tighten all connections in your system. Loose ground wires are more susceptible to noise
than the other wires in your system. Review Chapter 3, Installation and Wiring, if you have
questions regarding how to ground your system.

• Electrical noise can enter the system through the power source for the CPU and I/O. Installing an
isolation transformer for all AC sources can correct this problem. DC power sources should be well
grounded, good quality power supplies. Switching DC power supplies commonly generate more
noise than linear supplies.

• Separate input wiring from output wiring. Never run I/O wiring close to high voltage wiring.
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Run Time vs. Stop Mode Transfer Instruction
Here we describe the actions and differences between Run Time & Stop Mode transfers.

The above dialog is accessed two ways: 

1. From the Transfer to PAC icon on the tool bar, or 

2. From the File menu > Transfer Project > To PAC
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Run Time Transfers
Run Time transfers allow the user to transfer edits to a project back into the CPU without
stopping the CPU scan, therefore not stopping the process. Be aware that a Run Time
transfer will affect the length of your scan time, which should be considered if your process is
susceptible to varying or lengthy scan times. The download time is longer compared to a
Stop Mode transfer. 

During a Run Time transfer, the current project file continues running until the entire
project file is transferred to the CPU. Once downloaded, the ladder logic files swap and
begin executing the new file. The Tag Database is shared between the two project files during
a Run Time transfer, therefore current operating values will not be effected. 

Because the Tag database is shared, any edits to the Tag database will force a Stop Mode
transfer.

Stop Mode Transfers

Stop Mode transfers allows the user to transfer any and all ladder, Tag database and
configuration changes to the CPU. 

Because the CPU is in stop mode, the project transfer is much faster than a Run Time
transfer and also loads all initial values to the tags once the project is switched from Stop to
Run.

There are also conditions that will force the user to perform a Stop Mode transfer. 

1.  Any changes to the hardware configuration, such as:

A.  Adding or removing hardware.

B.  Changing the configuration of a piece of hardware.
•  Ethernet or serial port configuration.

•  Hot swap enable or disable on any module or base.

2.  Adding or changing any Array data type Tags.

3.  Adding or changing any String data type Tags.

Note: Be careful when performing a Stop Mode transfer. The retentive values in your PC
project may not be current and non-retentive data will be cleared (reset to 0) when you
switch your CPU from Stop to Run.



There are steps you can take to ensure that your data is as current as possible before
performing a transfer. 

1.  A Run Time transfer does not load initial values and therefore the best method for keeping data
current. However, a Run Time transfer is not always allowed. (see the preceding list of
conditions that will force a Stop Mode transfer.)

2.  Select “Upload current retentive values and copy to initial values” from the Tools menu >
Options > Project Transfer tab.

With this option selected, you can place the CPU in Stop mode so retentive values are stable,
upload the project, perform your edits, and then transfer the project back to the CPU.
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Forcing I/O Points
Here we are going to describe the actions, expectations and indications when forcing a value
within the Productivity3000 controller. 

Advantages of Forces
Almost all tags can be written to within your software without the use of Forces. However, if
the ladder logic or an external device (Operator interface panel, Modbus device, etc.) is
connected to your controller and writing to those tags, the values you write from a Data View
will be over-written. Conversely, if you write a Force value, this will not be overwritten or
reset until you manually remove the force or reset by means of a Stop to Run mode
transition, Stop mode project transfer, or a controller power cycle.

Enabling Forces
The Productivity3000 is a Tag based controller and forcing a tag begins by identifying any tag
you wish to be “Forceable” within the Tag database. 
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There are three columns within the Tag database that affect the forcing of all tags. 

1. “Forceable” - Checking the box in this column identifies the corresponding tag as being able to
be forced within the system.

2. “Init Forced” - Checking the box in this column identifies that corresponding tag as being forced
as soon as the project is loaded and the processor is switched to Run mode.

3. “Init Force Value”  - The state of the box in this column identifies the initial forced state of the
Boolean tag:

•  A check mark in a box equals a logical “1” or “ON”, and

•  An unchecked box equals a logical ”0” or “OFF”. The value placed in this field for Integer or 
Floating point tags will be written into the tag. 

Forcing Tags in Your System
All forcing of tags is accomplished through the Data View window.
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From the DataView Window, enter the tags you wish to force, or you can view all forceable
tags from the “Forceable Tags” tab automatically created for you when you enable tags as
forceable in the tag database.

From either of these windows you have the option to select the check box in the Force
column. When this box is checked and the row is selected (selected rows show high-lighted
blue) and you select the Send Edit(s) button, the current row(s) will be forced. 

Note: You can select multiple rows by clicking and holding down the left mouse button and dragging up or
down. This selects consecutive rows. If you wish to select various rows, simple hold the “Ctrl” control key
on your keyboard while left mouse clicking the rows.
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Identifying Forced Values
There are two indications that forces are active on your controller. 

1. All active forces will be shown in the Forceable tab of the Data View window as shown in the
previous view.

2. You will also see “PAC Data Forced” in Red in the lower right of the Status bar of your software.

Note: Only Forced tags with an initial force value specified in the Tag database will be retained after a Stop
to Run transition, Stop Mode transfer, or a power cycle. All forced values are retained during a 
Run Time transfer.
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Force Value Timing Chart
You chart below show the varying states of a Digital Output & Input represented in the logic
rung when no edits or forces are applied, when edits are applied and when forces are applied.

Input “Logical” represents the logical value of the digital input.

Input “Edit” represents an edit sent to a digital input from the Data View, but not forced.
This value is written once but then over-written the very next scan by the logical input.

Input “Forced” represents a Force sent to the input from the Data View. At any point when
the Force is active the Input logic is On or High.

Output “logical” represents the logical value of the digital output.

Output “Edit” represents an edit sent to a digital output from the Data View, but not forced.
Unlike the input edits, this is edit will not register is another value is writing to the output,
but will transition the output On or High if there are no other logistic or outside factors. 

Output “Forced” represents a Force sent to the output from the Data View. At any point
when the Force is active the Output logic is On or High.
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Input DI-0.1.1.1
logical

DI-0.1.1.1
0

DI-0.1.3.1
0

Input DI-0.1.1.1
Edit

Input DI-0.1.1.1
Forced

Output DO-0.1.3.1
logical

Output DO-0.1.3.1
Edit

Output DO-0.1.3.1
Forced

OUT
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