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4–2
The Menus and Toolbars

ScreenCreator Menus

The Screen Menu

The Screen menu contains commands for creating a new screen, opening, closing
or deleting screens, as well as printing a screen and editing all screen colors.
If the Screen menu command can also be called by a Standard Toolbar tool, the tool
is shown below the menu command.

The large Screen
menu on the near
right is available
when a screen is
open. The small
Screen menu on the
far right is available if
no screen is open.

creates and opens a new Untitled
screen.

calls the Open Screen dialog
box, allowing you to select
and open a screen.

Selecting Simple Display is
the opposite of Details in
other Windows Open boxes
and only shows the screen
icons.

Screen > New

Screen > Open...
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Clicking Select... brings up
the normal Windows Select
Folder box.

The Preview function can be
very useful for selecting the
right screen. All screens of
the current project are shown.

does just that, closes the selected screen.

simply saves the current screen, with any changes you may have made.

Screen > Open...

Screen > Close

Screen > Save
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4–4
The Menus and Toolbars

calls the Save Screen
dialog box, allowing you to
save the current screen
(under a different name or
under a different
registration number).

Compile When Saving can
be deselected to allow
creating and saving
screens without assigning
PLC addresses to parts. Be
aware, however, that those
screens cannot be
downloaded.

NOTE: When the Compile When Saving option is deselected, the parts on the
screen will not be compiled and therefore the screen cannot be downloaded!

brings up the Select Screen
box (for deleting a screen).

You will probably never use this command, since clicking the X on the upper right
corner of the edited part window is much quicker!

saves the part being edited. Clicking the Save tool does this as well, of course, but
only when a part is being edited and that part window is selected.

Screen > Save As...

Screen > Delete
Screen...

Screen > Close
Edited Part

Screen > Save
Edited Part
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If no part’s contents are being edited, the Screen Colors box appears, below left. If
the contents of a part are being edited, the Part Properties box, below right,
appears, allowing the size and background color of the part to be specified.

Individual colors (identified by number) can be
changed by selecting then moving the
blue/red/green dials. Every occurrence of the
color number in the screen will be changed. To
restore the default color, select the color
number and click Restore the default color.

The size of the part can be
specified precisely above.

When selected, the Print Screen box appears. The command outputs a bitmap
(*.bmp) file and a text (*.txt) file. If “Output to Printer” is selected, it will also print the
files.

Finally, the Exit command, which closes ScreenCreator altogether after prompting
the user to save any screens or components that are being modified. Clicking the X
in the upper right corner of the ScreenCreator window is the same as the Exit
command.

Screen >
Properties of
Screen or Edited
Part...

Screen > Print
Screen...

Screen > Exit



T
he

 M
en

us
 a

nd
To

ol
ba

rs
M

en
us

an
d 

To
ol

ba
rs

4–6
The Menus and Toolbars

The Create Menu

The Create menu contains commands for creating Drawing Objects (or Figures),
Controls and Parts. The tool that duplicates the command is shown in the left-hand
margin below the command.
The Create menu is only available when a screen or part is open.

The Create menu, on the right, features
the Drawing tools first, beginning with the
Select Mode, which returns the pointer
just like clicking the pointer tool below.

For any of the drawing functions below,
click, hold and drag to create the specific
drawing object.

opens the Straight Line box and the
pointer becomes a cross-hair for
drawing a line. Hold down the Shift
key while clicking and drawing to
make the line horizontal or vertical
(based on which direction you move
the pointer after first clicking).
Note: When creating dotted lines,
the line may not appear dotted if the
Zoom is set higher than 100%. Click
Tools > View to see more accurately
what will actually be displayed on the
panel.

The Arrow options determine
position (left/right/both), arrow
angles and length of the arrow(s).

NOTE: Holding down the Shift key while drawing any Figure will cause it to snap to
the grid or to the X or Y axis. It is best to experiment with the various tools to
understand the details of how they work.

Create > Straight
Line
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opens the Arc box and the
pointer becomes a cross-hair for
drawing an Arc. Holding down
the Shift key will cause the initial
Ellipse to be a Circle and the
beginning and end points of the
Arc to fit the X or Y axis.

When the Snap to Grid is ON, holding down the Control Key (Ctrl) during clicking
will cause the center of the circle to snap to the nearest grid point. (See
Circle/Ellipse below.)

opens the Continuous
Straight Line box and the
pointer becomes a
cross-hair for drawing
connected lines. Each
click of the mouse ends
one connected line and
begins another.
Double-click to stop.

NOTE: Both the Continuous Straight Line and the Spline may be done in such a way
that a color could fill a resulting area or areas. Select Fill to experiment.

opens the Spline box
and the pointer
becomes a cross-hair
for drawing a
continuous curved
line. Each click begins
a new curve.
Double-click to stop.

opens the Rectangle box
and the pointer becomes a
cross-hair for drawing a
rectangle by clicking,
holding and dragging. To
create a Square, hold down
the Shift key at anytime
while dragging.

Create > Arc

Create >
Continuous
Straight Line

Create > Spline

Create > Rectangle
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The Menus and Toolbars

opens the Parallelogram
box and the pointer
becomes a cross-hair for
drawing a parallelogram. To
position the figure
horizontal or vertical, hold
the Shift key down while
drawing the first line then
release it after releasing the
left mouse button.

opens the Circle/Ellipse
box and the pointer
becomes a cross-hair for
drawing an ellipse by
clicking, holding and
dragging. To create a
Circle, hold down the Shift
key at anytime while
dragging.

When the Snap to Grid is ON, holding down the
Control Key (Ctrl) during clicking will cause the
center of the circle to snap to the nearest grid point.
(See Arc above.)

opens the Fill box and the
pointer becomes a mouse
symbol for filling any object
or screen with the specified
color. Double-click inside
the object area or screen
you want to fill.

opens the Text box and the
pointer becomes a mouse
symbol for placing any text
entered onto the screen.

Create >
Parallelogram

Create >
Circle/Ellipse

Create > Fill

Create > Text
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opens the Bitmap box and
the pointer becomes a
mouse symbol for placing
any bitmap selected onto
the screen.
Color Convert replaces all
bits which are not black with
the color chosen.
Transparent makes all
black bits transparent, so
any filled color underneath
shows through.

opens the Texture box and
the pointer becomes a
mouse symbol for placing
any texture selected onto
the screen.

opens the Line Scale box for specifying
the number of lines and X or Y direction.
After clicking Create, the Straight Line
box appears and the pointer becomes a
cross-hair for sizing the scale onto the
screen.

opens the Circular Scale box for
specifying the number of lines. After
clicking Create, the Straight Line box
appears and the pointer becomes a
cross-hair for sizing the scale onto the
screen.

Create > Bitmap

Create > Texture

Create > Macros >
Line–shaped
Scale...

Create > Macros >
Circular Scale...
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The Menus and Toolbars

opens the Polygon box for specifying the
number of corners. After pressing
Create, the Continuous Straight Line box
appears and the pointer becomes a
cross-hair for sizing the polygon onto the
screen.

There are four tools in the Drawing Toolbar worth mentioning separately, since they
do not have a corresponding menu command. The first three are used to select
Figures, Parts and Controls, in that order. You may deselect the Select Part tool if
you want to move a figure which is very close by (so the part does not get moved
also). The last tool is the Set Attribute tool, which recalls a closed Create window
when the create tool is still selected. For example, if you were creating multiple text
items and had closed the Text box but wanted to add another piece of text–– click
the Set Attribute tool and the Text box returns. Otherwise, you would have to click
the Selection Mode tool (the pointer) and then click the Text tool again.

The Create > Controls sub-menu list is the same as the Control Toolbar. The
Pushbutton/Switch below serves as an example of how all the other items work, in
opening their respective dialog boxes.

opens the Pushbutton/Switch
dialog box for setting up the
control.

The Create > Parts sub-menu list is the same as the Part Toolbar. The Numerical
Display below serves as an example of how all the other items work in opening
Select Part dialog box, with that specific type of part selected.

Create > Macros >
Polygon...

Drawing Tools not
found in Create
Menu

Create >
Controls...

Create > Controls >
Pushbutton/
Switch...

Create >
Parts...
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opens the Select
Part dialog box
with Numerical
Displays selected.

The Edit Menu

Much like the Create menu, the Edit
menu contains commands for editing
Figures (or Drawing Objects), Controls
and Parts. Some of these commands are
duplicated by a tool in the Standard
Toolbar, shown below.

The Edit menu is only available when a
screen or part is open.

RedoCopy
Cut Undo

Refresh
Screen

Move to
Front

Move to
Back

ProgramPaste

Operation
Parameter

Attribute/
Properties

Edit
Corner

Create > Parts >
Numerical
Displays...
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used to Undo the last operation. This function is effective for the last 16 operations.

used to cancel  the most recent Undo. This function is effective for the last 16 Undo
operations.

used to remove a component from a screen or window and store it in the clipboard.
See Paste.

used to copy a component from a screen or window to the clipboard. See Paste.

Tip: You can copy/cut and paste from one screen to another even if the screens are
in different projects. With one project open in ScreenCreator, launch ScreenCreator
a second time (don’t close the first session!) and open the second project and
screen. Now you can access multiple screens at the same time and cut/copy and
paste as if the parts were on the same screen.

Another Copy Tip: See the discussion below to quickly duplicate Figures.

Select any Figure (drawing
object) that you want to
duplicate. Hold the Control key
down and click the left mouse
button once the four arrow
pointer is shown. Hold the
Control key and the mouse
button both while you move the
pointer to the desired location
for the new copy and release.
Be sure to have the proper grid
settings before duplicating.

used to Paste the contents of the clipboard to a screen or window. See Cut and
Copy.

Edit > Undo

Edit > Redo

Edit > Cut

Edit > Copy

Duplicating
Figures

Edit > Paste
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deletes the selected item. Pressing the Delete key does the same thing.

This is not the same as Cut, since deleted items cannot be brought back by the Paste
function! If You delete accidentally, you can still Undo.

Selects all of the components on the current screen or window, including parts,
textures, text, and drawing objects.

causes the current screen to be re-drawn, restoring any visible distortions.

allows the corners of the selected Continuous Line or Spline to be moved without
moving the entire object.

brings up the Part Properties box if a part is selected or the Attributes box if a
component, figure or texture is selected.
Double-clicking the item does the same thing, but it is not always easy to click an
item without moving it or something near it.

brings up the Editing Part Contents
window on the far right.

This can also be done by holding the
pointer on or near the part name and
double-clicking when the pointer is
as shown on the right.

moves the selected figure or component to the front with respect to other items on
the screen. This does not apply to parts since parts cannot overlap on the screen.

moves the selected figure or component to the back with respect to other items on
the screen. This does not apply to parts.

rotates the selected item clockwise by the degrees chosen.

Edit > Delete

Edit > Select All

Edit > Refresh

Edit > Corner

Edit > Attributes
and Properties...

Edit > Edit
Contents of Part

Edit > Change
Order > Move to
Front

Edit > Change
Order > Move to
Back

Edit > Rotate or
Mirror > Rotate
90/180/270 deg.
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turns the selected item into its mirror
image as shown on the right. The
original item (left) becomes the item
on the right. Both are shown to
illustrate the effect.

turns the selected item into its mirror
image as shown on the right. The
original item (top) becomes the item
on the bottom. Both are shown to
illustrate the effect.

ungroups the drawing objects (lines, squares, etc.) which make up the selected
texture.

ungroups the drawing objects (lines, squares, etc.) which make up background
texture of the part being edited.

opens the
Operation
Parameter
box of the
part whose
contents are
being
edited.

Edit > Rotate or
Mirror > Horizontal
Mirror

Edit > Rotate or
Mirror > Vertical
Mirror

Edit > Texture
Expansion >
Selected Texture

Edit > Texture
Expansion > Part
Background
Texture

Edit > Edit
Operation
Parameter...
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The Library Menu

The Library menu, on the right, has
commands related to Library Parts
and Textures. Some of the
commands are only available when a
library part is open.

opens a New Library Part window and is
ready for any components and controls
to be added.

opens a New Library Texture window and
is ready for any Drawing Objects (or
Figures) to be added.

Library > New >
Part

Library > New >
Texture
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brings up the
Open Part window
for selecting the
Library Part to
edit.

opens the Open Texture
window for selecting the
Library Texture to edit.

closes the selected library part or texture.

Library > Open >
Part...

Library > Open >
Texture...

Library > Close
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brings up the Save Part window or Save Texture window, depending on which is
being edited.

opens either the Properties of Library Part or Texture window for viewing or editing.

brings up either the Print Library Part or Texture dialog box.
In printing a Library Part, the options are as follows:
* Part Background to a Bitmap File
* Information selected to a Text File
* All of the selections to the printer

Library > Save As...

Library >
Properties of
Library Member...

Library > Print
Library Member...
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opens Save Part dialog box (just like Save As... does). In case you forgot to edit a
library part directly, this allows you to save a part that you have edited on the screen.

brings up the Add Part dialog box
allowing you to import into your
ScreenCreator Library folder a part
(*.apt file) from another Library folder.

Click Select and locate the file, then
click Add.

opens the Add Texture dialog box
allowing you to import into your
ScreenCreator Library a texture (*.tex
file) from another Library folder.

Click Select and locate the file, then
click Add.

brings up the Add Bitmap
dialog box allowing you to
import into your
ScreenCreator Library an
existing bitmap (*.bmp file)
from a windows folder.

Click Select and locate the
file, then click Add.

Library > Add Part
from Screen to
Library...

Library > Add from
External File >
Part...

Library > Add from
External File >
Texture...

Library > Add from
External File >
Bitmap...



T
he M

enus and
Toolbars

M
enus

and Toolbars
4–19

The Menus and Toolbars

opens the Maintenance of
Part dialog box for making
changes to Parts and
Classes (like folders of
parts).

brings up the Maintenance of
Texture dialog box for making
changes to Textures and
Classes (like folders of
textures).

opens the Maintenance of Bitmap
dialog box for making changes to
Bitmaps and Classes (like folders of
bitmaps).

Library >
Maintenance >
Part...

Library >
Maintenance >
Texture...

Library >
Maintenance >
Bitmap...
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The Tools Menu

The Tool menu, on the right, accesses
Display, Option, Browse List and View
dialog boxes. View is the only on of the
four that does not have a tool in the
Standard Toolbar.

opens the Display dialog box below.

Toolbar
Choices

Viewing
Options

Zoom

Ruler
for
Screen

brings up the Options dialog box below.

Snap to Grid
Command
Options

Grid Lines

Grid Offset, useful
for creating boxes
inside boxes

Part and Component
Icon Sizes

Tools > Display...

Tools > Options...
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opens the Browse List box below. If an open screen is selected, the list will consist
of only the screen objects. If the window of a part (whose contents are being edited)
is selected, the list will have only the components of that part.

Select Part,
Control, Fig-
ure, Bitmap or
Texture

brings up the View
window on the right for
verifying the proper
DirectTouch panel type.

Tools >
Browse List...

Tools >
View...



T
he

 M
en

us
 a

nd
To

ol
ba

rs
M

en
us

an
d 

To
ol

ba
rs

4–22
The Menus and Toolbars

The Window Menu

The Window menu, on the right,
contains the standard window
commands (Cascade, Vertical Tile and
Horizontal Tile) as well as Size Window
to Screen and Arrange Icons.

Size Window to Screen causes the
window of the selected screen to fit the
screen itself. It is typically used after
zooming from 100% to 150/200% size.
The Arrange Icons command simply
arranges any minimized windows. Last on the Window menu is the

numbered list of currently open
windows, including any parts, screens
or textures. This provides a means of
selecting an open window that may be
hidden behind another.

The Project Menu

The Project menu contains
commands for editing the current
project and creating, opening or
deleting other projects. It has every
menu item selectable when a project
is open. If no project is open, the only
items you can select are: New, Open,
Upload, Restore, Copy and Delete.
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opens the Create New Project Properties dialog box.

calls the Open
Project dialog box,
allowing you to
select and open
another project.

To open more
than one project
at a time, see the
note below.

NOTE: If you want to Open more than one project at the same time, start
ScreenCreator again (launch another session without exiting the first session) and
open another project. This allows you to copy and paste parts, screens, text, etc.

Project > New

Project > Open
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does just that, closes the current project.

opens the Project Properties dialog box, which contains the panel type, PLC
protocol, etc.

opens the Print Project dialog box for choosing various project report data to output
to a printer and/or to a file.

Project > Close

Project >
Properties...

Project > Print
Project...
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opens the Project Register dialog box for viewing the registered screens, text and
textures of the current project. Note: these items cannot be edited from this window.

opens the Download/Build dialog box, which not only provides download and build
functions, but also allows the user to specify future upload edits and re–compiling of
all screens prior to downloading.

Note: If you want to allow the
project to be uploaded from
the panel, check the Upload
Enable box before
downloading.

Watch the status line on the
Upload/Download window to
see the Download process. The
normal status messages are:
Download started, User data is
being deleted, User data is
being transmitted, and User
data transmission finished.
When the download is done,
click End as shown on the right.

Project > Register...

Project >
Download/Build...



T
he

 M
en

us
 a

nd
To

ol
ba

rs
M

en
us

an
d 

To
ol

ba
rs

4–26
The Menus and Toolbars

opens the Upload dialog box for uploading a project into ScreenCreator.

opens the dialog box with the same name. This can only be used when a project has
been uploaded that was previously downloaded to the panel with ’Upload Edit
Enable’.

opens the dialog box with the same name. This works just like normal downloading
except there is nothing to build because the uploaded project has been compiled.

opens the NewText dialog box for entering new text to be registered. It also has the
Open tool for selecting other registered text.

opens the dialog box with the same name. This gives quick access to all PLC
addresses of parts on screens which have been built using the Download/Build
command. If a screen has not been “built”, any PLC addresses on that screen will
not be listed in the Edit Address window.

brings up the Backup Project dialog box and prompts the user to select a folder in
which to store a copy of the current project file (.pro). Only a project which has been
backed up may be later restored.

brings up the Restore Project dialog box and prompts the user to select a project to
restore from a backup file (.pro.). The project restore function rebuilds the project
from the project file and stores the new project in the SC folder. The project to be
restored must have first been backed up.

brings up the Copy Project dialog box and prompts the user to select a project to
copy and a name for the new project. This may be used to create major versions of a
project being developed. Then as changes are abandoned, the user can return to
the previous version of the project.

Project > Upload >
Upload...

Project > Upload >
Restore Uploaded
Project...

Project > Upload >
Download
Uploaded Project...

Project > New
Text...

Project > Edit
Address...

Project > Backup...

Project > Restore...

Project > Copy...
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opens the Delete Project box to select a project to delete. Use this function very
carefully.

The Help Menu

The Window menu, on the right,
contains the Help Index and About
ScreenCreator.

brings up the
standard Windows
Application Help box.

opens the Version
Information box.

Project > Delete...

Help >
Help Index...

Help >
About
ScreenCreator...


