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Manual Revisions
If you contact us in reference to this manual, be sure and include the revision number.

Title: DP–PGMSW ScreenCreator User Manual
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Issue Date Effective Pages Description of Changes

Preliminary 10/98 All Preliminary release for S/W Version 1.0.

Original 10/98 Various pages Original for S/W Version 1.01, with A–B
driver.

Rev. A 11/98 2–2, A–8 Changes to Programming cable pin-out.

Rev. B 01/99 Various pages Changes for S/W Version 1.10.

Rev. C 12/99 Various pages Changes for S/W Version 1.14, which 
includes Think & Do and MODBUS
support.
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Introduction

Manual Overview

This manual shows you how to install and
use ScreenCreator�, the
Windows�–based configuration software
for DirectTouch panels. If you are like
most, you want to get your new
DirectTouch panel out of the box and start
creating screens as quickly as possible to
get an idea of what’s involved and to make
sure it will “talk” to your PLC. This manual
provides you with a Project Tutorial and an
in-depth Reference, so you can get going
quickly, but dig deeply as you continue
using ScreenCreator.

If you understand your PLC (Programmable Logic Controller) and you have a basic
understanding of Microsoft Windows� 95/98 or NT�, this manual will provide all
the information you need to use ScreenCreator software. With this manual, you can
design, build and implement operator interface screens on your DirectTouch panel.

We realize even though we strive to be the best, we may have arranged our
information in such a way you cannot find what you are looking for. If you need
assistance, please call us at 1–770–844–4200 or FAX 1–770–886–3199. Our technical
support group is glad to work with you in answering your questions. They are
available weekdays from 9:00 a.m. to 6:00 p.m. Eastern Standard Time. You can
also contact us on the Internet at:

www.Automationdirect.com 

If you find a problem with any of our products, services, or manuals, please fill out
and return the survey card that came with this manual.

The “note pad” icon in the left–hand margin indicates the paragraph to its immediate
right will be a special note.

The “exclamation mark” icon in the left-hand margin indicates the paragraph to its
immediate right will be a warning or caution. These are very important because the
information may help you prevent serious personal injury or equipment damage.

The “light bulb” icon in the left-hand margin indicates a tip or shortcut.

The Purpose of
this Manual

Who Should Read
this Manual

Technical Support
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How this Manual is Organized
The main contents of this Manual are organized into these six chapters:

Introduction introduces the basic concepts of ScreenCreator and steps
you through installing the software.

Project Tutorial

takes you through the process of creating a simple project,
from start to finish. You’ll learn how to create screens and
place various parts on them and how to download the project
to your DirectTouch panel.

Key Concepts

covers the basic concepts of building screens for the
DirectTouch panel. You will learn about Projects, Screens,
Parts, Textures, Bitmaps and Figures. You will also learn how
to build a new part and store it as a Library Part.

ScreenCreator Menus
and Toolbars

details the specific menus in ScreenCreator with descriptions
of the individual menu commands.

Control Reference provides detailed reference information on each type of
control in ScreenCreator.

Part Reference provides detailed reference information on each type of part
in ScreenCreator.

Additional reference information for ScreenCreator software is available in these
two appendices:

Connecting to a PLC
provides information on how to connect the DirectTouch
panel to a PLC.

ScreenCreator and
DirectTouch panel Error

Codes

lists the Error Codes and Warning Codes for both
ScreenCreator and the DirectTouch panel.

Chapters

1

2

3

4

5
6

Appendices

A

B
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Concept Background

Manual
Flow

Start

Hard–wired physical Operator Interface Panels (OIPs) have been around for many
years, with pushbuttons, panel meters and numerical displays, and so on. But it is
very time-consuming to make changes to an OIP. For instance, to add or remove a
pushbutton or meter requires drilling holes, punching out bigger holes and then
mounting and wiring hardware, etc.
With the introduction of the touch panel all of this changes. A physical OIP can be
replaced by an LCD (Liquid Crystal Display) panel. Better yet, the touch panel (or
touchscreen) can have multiple screens, each screen being like another panel.
Screen parts, text and graphics, even an entire screen, can be added or removed
quickly.

Start Stop

Manual

Auto

Flow

DirectTouch
Panel

Start Stop

Manual

Auto

Flow

Multiple
ScreensPhysical OIP

Process Trends

ScreenCreator Basics

The DirectTouch
Panel is a 320x240
pixel display. Each
touch-cell is a
20-pixel square, and
there are sixteen
horizontally and
twelve vertically
(16x12).

Touch panels: 
The Concept

The DirectTouch
Panel
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The DirectTouch Panel has barely-visible lines and tiny white dots marking the
touch-cells.

In ScreenCreator, a
screen window, on
the right, can be
displayed with or
without grid lines and
with or without the
small dots. The Snap
Grid itself may be
turned ON or OFF
apart from the grid
dots or grid lines, but
the grid lines are the
size of the Snap
Grid.

Ruler (may be ON
or OFF also)

The screens that you build in ScreenCreator are essentially identical to the actual
screens displayed on the DirectTouch panel. In addition to having parts, text and
graphics, screens are usually configured with pushbuttons which bring up other
screens. You can even have a main menu screen with many screen select
pushbuttons, like the homepage on a website. Below is an example of each screen
having a “Next” button to access the next screen and/or a “Back” button to return to
the previous screen.

Multiple Screens

Process Trends

Manual

Auto

Next Back

Next

Operator Buttons

BackStart Stop

Flow

Warning: Be aware that the DirectTouch panel, as with any external device, can
write to PLC registers and bits. You must be careful in using the panel to write to any
PLC address. It is a good idea to use PLC ladder logic to call screens and to
write to PLC outputs based on prescribed conditions.

Grid Lines and
Dots

The Screens
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Installing ScreenCreator�

Before installing ScreenCreator, make sure that you have the following:
� CPU:  486SX or better (A Pentium is recommended)
� RAM:  8MB (16 or more is recommended)
� Windows� 95/98 or NT (will not work under DOS or Windows 3.1)
� 30MB of free disk space
� CD-ROM drive
� Monitor:  VGA 640x480 (800x600 or better is recommended)

Follow these steps to correctly install ScreenCreator:
3. Start Windows 95/98 or NT.
4. Insert the ScreenCreator CD into your CD-ROM drive.
5. Setup will launch automatically.
6. The InstallShield Wizard will guide you through the installation process.
7. Choose Typical, if installing for the first time.
8. The default folder will be C:\SC\. You may choose another folder or click

’Next’.
9. Click ’Next’ again to the installation files listed.
10. The installation will begin. When it is finished, click ’Finish’.
11. Please see the Note below, before launching ScreenCreator!

The Installation Options are: Typical, Compact and Custom....

NOTE: We strongly recommend that you refer to the Project Tutorial (Chapter 2)
before starting ScreenCreator for the first time.

If this is your first time using Windows 95/98 or NT, and you are not familiar with
opening, closing, minimizing, etc., please refer to your Windows documentation.
Once you can find your way around the Windows environment, you’ll be ready to
return to ScreenCreator.

Requirements

Installation
Procedure

Windows�



�
Project Tutorial

�� ���� ��	
��� � � �

� �����	� �������

� ��	�� 	 ��� ������

� ��� 	 ��� �	�

� ��� 	 ��� �����

� ������	� ��� ������

� ��� ����	� ����� 	��  ��	� ������

� �
�� 	� �!�����" �����

� �����	� #�����



P
ro

je
ct

 T
ut

or
ia

l

2–2
Project Tutorial

Tutorial Overview

You probably want to get your new DirectTouch panel out of the box and start
creating screens as quickly as possible to get an idea of what’s involved and to make
sure it will talk to your PLC. This brief Project Tutorial is designed to do just that. It will
guide you through a small project from start to finish, so you’ll be able to get going
quickly on your own application. This tutorial will incorporate a few of the basic
features used in a typical project. You’ve installed ScreenCreator (in Chapter 1) and
are now ready to setup the DirectTouch panel to communicate with your PC.

Starting on the next page you will be guided through the process of creating a small
project for a pulp mill.

Warning: Be aware that the DirectTouch panel, as with any external device, can
write to PLC registers and bits. You must be careful in using the panel to write to any
PLC address. It is a good idea to use PLC ladder logic to call screens and to
write to PLC outputs based on prescribed conditions.

Refer to the DirectTouch User Manual in order to properly set up the panel and
connect it to your PC using the programming cable (DP–PGMCBL). There is no
need to mount the DirectTouch panel in an enclosure for this tutorial! Instead, we
recommend that you set it up on your desk or somewhere near your computer.

Warning: Do not change the DIP switch settings on the back of the
DirectTouch panel. The DIP switches are only used by the manufacturer.

Connect the programming cable (DP–PGMCBL) between the serial port (CH1) of
the DirectTouch panel and the serial port of the personal computer.The figure below
shows programming cable connectors and wiring specifications. Wiring diagrams
refer to the communication ports.

��$��%�& 

��'
��� DirectTouch  Panel

5= 0V
4= DTR
3= Dout
2= Din
1= DCD

9= not used
8= CTS
7= RTS
6= DSR

DB9 DB9

3 3
48
57

5
1

9

Female Male

7

2 2

5 = CTS
4 = RTS
3 = Din
2 = Dout
1 = Ground

9 = not used
8 = not used
7 = 0V
6 = not used

1

9

DB9
Female

DB9
Male

1

shell shell

4

Set up the Panel

Programming
Cable
(DP–PGMCBL)
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Warning: Do not use the PLC’s 24 VDC power supply to power the DirectTouch
panel. We offer a 24 VDC power supply, the FA–24PS, which works well with either
color or monochrome panels.

When you have set up your panel and have connected it to your PC, start
ScreenCreator either from the Start menu (Start > Programs > ScreenCreator), or
from the SC folder in Windows Explorer.

Create a New Project

Once ScreenCreator is
launched, create a new
project by selecting New
under the Project menu
(Project > New...). In the New
Project dialog box, enter
“Pulp” as the name of your
project, since it will be for a
pulp mill. Next, click on the
arrow down button at the right
end of the Panel field. The
panel model number list will
drop down. Select DP–C320*
16 colors Normal if you have a
color panel or select
DP–M320** if you have a
monochrome panel. By the
way, Normal refers to
horizontal mounting versus
vertical mounting. If you were
actually going to mount your
panel vertically, of course, you
would select Vertical.

*Also represents the
DP–C321 panel.
**Also represents the
DP–M321 panel.

Start
ScreenCreator

Create a New
Project
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To choose the PLC which will
connect to the panel, click on
the ’Connect To’ Tab. You will
immediately be asked, “Do
you want to create a new
project folder?” Click Yes.

Now choose the PLC
type/protocol from the list (we
have chosen K–Sequence).
Once you have picked your
PLC protocol, click OK.

Note: ScreenCreator does
not support Allen-Bradley
SLC 5/01 or 5/02 PLCs, but
does support the SLC 5/03
and 5/04 PLCs.

TIP: By the way, you never have to Save the current project. Only the screens in the
project have to be saved.

When you click OK, an ’Untitiled’ local screen appears. Ignore this screen for now,
although what follows could have been done on this local screen as well. Close
’Untitled’ without saving by clicking the X in the upper right corner of the window.

Click on the standard
Windows “New” tool or
select the Screen > New...
menu to create a new
screen. This new screen will
also be a local screen and
will be labeled ’Untitled’.

Now click on the display tool
and select a Zoom size of
200% and click ’New
Default’. This setting will be
used throughout the manual
unless otherwise noted.

Local Screens

Create a New
Screen

Zoom Screen
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You may notice that after changing the Zoom size to 200%, the window is now
smaller than the screen. Click on the Size Window to Screen tool, and the window
now fits the screen size.

TIP: It is a good idea to get used to clicking the the various tools instead of selecting
the function through the menu bar. You’ll save a lot of time!

Add a New Part
A part is an object displayed on the DirectTouch panel which operates like the
physical part it represents. Examples include pushbuttons, lights, meters, etc.

To add a new part to the screen we
select a part from the Part Toolbar. Click
on the Pushbuttons/Switches tool on
the Part Toolbar to open the Select Part
window.

Initially the major heading
“Pushbuttons/Switches”
is highlighted and there
are no members
displayed. Click on the
Pushbutton Icon in the
Class List (the left
column) to view all the
members of that class (in
the right column). Click
the green pushbutton in
the top right corner and
the Part Properties
window is opened.

Size Window to
Screen

Select the Type of
Part

Select the Part
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Let the part have the default
Name B000 for now. Click on
the Address field and with the
cursor blinking, enter ’C3’ as
the single bit PLC address for
this Pushbutton. Enter an
appropriate address if you are
using a different PLC model.
The default Type of
pushbutton is Momentary,
which means it only stays on
while the pushbutton is
pressed. Click the Toggle
button to change to
“maintained operation”. This
will turn the bit ON when the
pushbutton is pressed and
turn it OFF when it is pressed
again. Also be sure to check
Synchronize and BIN as
shown.

Check
Synchronize Check BIN

The purpose of the Synchronize setting above is to confirm PLC to panel
communication. Synchronize sets the pushbutton/switch to read from the PLC bit
address and indicate the status of the bit by the ON or OFF color. If Synchronize is
disabled, the control simply writes to the bit and indicates the ON or OFF color
regardless of the actual state of the bit. (If, for some reason, the bit in the PLC was
never changed, the part would not indicate this.) With Synchronize enabled,
however, the control confirms panel and PLC communication.
The purpose of selecting Binary (BIN) above is because this is the normal data type
for bit level devices, such as pushbuttons or lights.
NOTE: If your PLC has a Run/Terminal switch (or Run/Remote for A–B), make
sure that your PLC is switch set to Terminal (or Remote) mode at this point to
allow the panel to WRITE to the PLC. This is important!

Part Properties

Explanation of
Settings
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Click on ’Arrangement’, to place the
pushbutton anywhere on the screen.
Your pointer will become a mouse as
shown to the right. Press your left mouse
button and the pointer becomes a
cross-hair with the outline of the
pushbutton beneath it.
Move the cross-hair around on the
screen and press the left mouse button
again to place the Part on the screen as
shown. Notice that the pushbutton is
forced to the grid blocks (even if the Snap
Grid were OFF). This is true for any part
that is accessed by touch–– to insure
proper selection on the screen.

Click on the standard Windows
’Save’ tool to save the newly
created screen. Delete
’Untitled’ and type ’Main’ as the
Screen Name. Note: The name
must begin with a letter and
may be 8 alphanumerics total.
Enter 1 as the Reg. No.
(Registration Number) for this
screen. This will cause the
screen Main to be the first
screen displayed when the
DirectTouch panel is powered
ON. Now, click ’Save’ to save
the screen.
If a compilation error for Invalid
Address occurs during the
Save process, double-click the
pushbutton, enter the correct
PLC address and click ’Save’
again.

NOTE: Every project which is downloaded to a DirectTouch panel must have one
local screen with a Registration Number = 1. This number designates the screen as
the first screen displayed when the panel is powered ON.

Place the Part on
the Screen

Save the New
Screen
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Now, we will create a new
screen and add a Screen Select
part to both the new screen and
to Main. This will allow us to go
back and forth between the two
screens. Click on the New
Screen tool (which creates
another Untitled screen). Click
the Screen Select  tool and
choose the Back button as
shown.

Now enter Main as the Next
Screen Name (to be called
when this Screen Select part is
pressed). This will send us back
to the first screen, Main.

Click Arrangement and place
the Screen Select part onto the
new screen just like you did the
first pushbutton.

Save the screen as Pro1, for
Process1, and give it a
Registration Number of 2.

Add a New Screen
and Screen Select
parts
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Repeat the above steps on the
Main screen and use the
Screen Select button labeled
Next, with Pro1 entered as the
Next Screen Name. Click the
Save tool to save the change to
Main. Now we have two
screens and a way to go back
and forth between them.

Screen Pro1 with the Screen
Select button which returns
to screen Main.

Screen Main with the Screen
Select button which calls screen
Pro1.

Click on the X of each of the
two screens to close them, if
you have not done so
already.

Add a New Screen
and Screen Select
parts  (Continued)

Close both
Screens
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Now that we have a local screen registered as number one (1), we can download the
project. If you have not downloaded a project to the panel, the System Mode Main
Menu will be displayed on the DirectTouch panel when it is powered ON. If you have
already downloaded, follow the steps on page 12 of the DirectTouch User Manual to
display the System Mode screen on the panel. Press ’Download/Upload’ on the
panel to display the ’Download/Upload’ screen. At this point the panel is waiting for
ScreenCreator to send it data.

Download the Project

In ScreenCreator, click on the
Download tool or select Project
>  Download/Build... and click
on Build & Transmit. Watch the
Message area for status of the
Build process.
If there is a problem downloading
(a warning box will appear),
check the programming cable
connections on both the PC and
the panel, and try again.
Note: If you want to allow the
project to be uploaded from
the panel, check the Upload
Enable box before
downloading.

Also watch the status line on the
Upload/Download window to see
the progress of the Download
process. The normal status
messages are: Download
started, User data is being
deleted, User data is being
transmitted, and User data
transmission finished.
When the download is
completed, click End as shown
on the right.

After successfully downloading the project to the DirectTouch panel, press ’OK’ on
the panel and then set up the panel’s RS–232C communication according to the
instructions given in Appendix A. Press ’End’ to return to the System Mode Main
Menu.

Press ’User Mode’ to see your pushbuttons displayed on the ’Main’ screen. Press
the green pushbutton a couple of times to see it change states and hear the beep.

Press the Screen Select Pushbutton labeled ’Next’ on the ’Main’ screen and notice
the ’Pro1’ screen is now displayed. Press the Screen Select Pushbutton labeled
’Back’ on the ’Pro1’ screen to return to the ’Main’ screen. Trying these pushbuttons
will give you an idea of how to switch back and forth between different screens.

Prepare to
Download

Set up the Panel to
communicate

The Pushbutton on
the Panel

The Screen Select
Pushbuttons on
the Panel
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The Global Screen and Local Screens

Each project has a single Global Screen, indicated by the icon on the left and having
the same name as the project itself. All other screens are Local Screens. The Global
Screen is used for items that you want to appear regardless of which Local Screen is
being displayed at the time. Examples include: Alarms (or Faults), a clock or keypad,
etc. Any part that is placed on the Global Screen must have selectable Access. This
is discussed in detail elsewhere.

Local screens must be assigned a Registration number in order to be displayed on
the panel.

NOTE: The Global Screen does not have a Registration Number, and is the only
screen that remains unregistered.

Click on the standard Windows
“Open” tool (shown on the left)
or select the Screen > Open...
menu. Notice the three screens
shown: the Global Screen
’Pulp’; and the Local Screens
’Main’ and ’Pro1’, listed in
alphabetical order. To open
’Main’, double click on its icon or
click on it once to select and
then click Ok.

The Global Screen
Icon

The Local Screen
Icon

Open an existing
Screen
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Finally, we will add a Numerical Input Display and a Ten-key pad. The ten-key pad
will be displayed when the input display is pressed on the panel.

First, click on the Numerical
Displays tool on the Part
Toolbar to open the Select Part
window.

Click the first Numerical Input
Display (Word) icon as shown
on the right and click on the one
in the uppper left corner.

Enter a PLC word address for
numerical input display value.

Add a Numerical
Input Display
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Next, select Template 9–16 and
type in “pad” as the Ten-key pad
Name.

Click Arrangement and place
the Numerical Input Display
part onto the screen, as shown.

Now we will add a Ten-key pad for numerical input and give it the name “pad”.

Note:  If you were going to place
the key-pad on the Global
screen (instead of the
same––or Self screen), you
would delete the 1 and type in
the name of the Global screen
under Screen Name with
Ten-key Pad (in the previous
window).
TIP: It is a good idea to place a
single key-pad on the Global
screen, which can then be
accessed from any local
screen.

NOTE: Any Numerical (or Text) Input Display must call a Ten-key pad or Keyboard
with the correct name in order to function correctly.

Add a Numerical
Input Display
(Continued...)
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Click on the Ten-key
pads/Keyboards tool on the
Part Toolbar to open the Select
Part window.

Select the first Ten-key pad as
shown.

Add a Ten-key pad
for the Numerical
Input Display
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Enter “pad” as the Name and
select Closed and Selectable
for the Access.

See the Note below!

Click Arrangement and place
the Ten-key pad onto the
screen, as shown.

Now when the Numerical Input Display is pressed on the panel, the Ten-key
pad will appear on the screen, allowing the user to enter a number to be stored
in the PLC address and be displayed on the Numerical Input Display.

NOTE: A Ten-key pad or Keyboard must be Selectable in order to be placed “on top
of” other screen parts, and must be Closed in order to be invisible until called by a
Numerical (or Text) Input Display!
If a key pad or keyboard part cannot be placed on a screen (by clicking
Arrangement), it must be made Selectable first.

Add a Ten-key pad
for the Numerical
Input Display
(Continued...)
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Tutorial Review

In this brief tutorial, you have learned quite a lot. Here is a review what you have done
so far:

a. Created a new project called ’Pulp’ and selected the DirectTouch panel
model and the PLC protocol.

b. Closed a screen without saving.
c. Created a new screen.
d. Set the Zoom size to 200% as the default.
e. Sized the Window to fit the Screen.
f. Selected a pushbutton, configured it and placed it on the screen.
g. Assigned the pushbutton to a bit address in the PLC.
h. Saved the screen as ’Main’.
i. Learned that the screen with a registration number of 1 is the default

screen displayed by the panel when powered ON.
j. Created a second new screen.
k. Created two Screen Select buttons.
l. Downloaded the project to the DirectTouch panel and used a

pushbutton on the panel.
m. Became acquainted with the Global Screen.
n. Added a Numerical Input Display to a screen.
o. Added a Ten-key pad to a screen for the Numerical Input Display.
p. Opened an existing screen.
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Key Concepts

Projects
A project is the set of screens and data (such as PLC protocol, baud rate and panel
type) managed under a specific project name. Each project can correspond to a
specific application. The Project Tutorial has the example of an application in a pulp
mill, so the project is titled ’Pulp’.

Screens (Global and Local)
In ScreenCreator, a screen is an image of the actual screen displayed on the
DirectTouch panel. There are two types of screens, global and local.
A project must have one, and only one, global screen. The global screen is created
at the same time the project is created and has the same name as the project. The
global screen can be used for displaying faults (alarms), or a clock/calendar. It
functions like a window in front of any screen that is being displayed on the panel. So
when nothing is being displayed on the global screen, it is transparent to the user.
There can be up to 1024 local screen names in any given project. The actual
number of screens you can download to a panel depends on how much
memory the screens use. Local screens each function like a separate Operator
Interface Panel having parts such as pushbuttons, meters and indicator lights, etc.
When nothing is being displayed on the global screen, the current local screen is
fully visible and functional.
Anything that can be placed on a screen may be called a Screen Object, including
Parts, Figures (circles, polygons, lines, etc.), Text, Bitmaps, and Textures. Figures
may also be referred to as Drawing Objects or Patterns. This chapter also discusses
Library Objects (Parts, Textures and Bitmaps in the Library), which are like Originals
from which the Copies (Screen Objects) are made.
Screen Parts are the most important type of Screen Objects. The major classes of
parts are found in the Part Toolbar below.

Text Displays

Numerical
Displays

Lights

Clocks/Calendars

Host CommandKeypads

Pushbuttons/Switches Select Screen
Graphs

Meters Alarms/Faults

Texture Displays

Special User Parts

Access of a part
refers to the way it is
displayed within both
ScreenCreator and
on the panel.
Normal: Displayed on the screen, including any data, and functional.
Frozen: Displayed as normal, but the pushbutton/switch is not functional.
Shaded: Displayed in shaded fashion, with no data or function.
Closed: Not displayed or functioning. (Must also be Selectable.)
Selectable: The access can be changed by a screen or part program.
Before a part has closed access, it must be made Selectable.
A good example of a part made Closed and Selectable is a Ten–key pad
being called by pressing a Numerical Input Display part. The Ten-key pad
is opened by the part program of the display and closed by its own
program once the Ent or Esc buttons are pressed.

The Global Screen

Local Screens

Screen
Objects

Screen Parts

Part Toolbar

Access of a Part
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When you click on any tool
icon in the Part Toolbar, the
Select Part window
appears, with that type of
part selected in the Class
List. If you click on the
Meters Tool, the window to
the right comes up, allowing
you to select one of the
specific meter types below
the ’Meters’ heading. The
Class List is much like a
folder of folders in Windows
95/98 or NT.

When you select the
’Analog Meter’, the window
then contains all the analog
meters stored under that
heading in the library.

The Class (or Heading) and Part Tool labeled ’User Parts’ is reserved for any custom
parts which you create. You may also store custom parts under any other heading if
you prefer but it might not be as convenient. Creating new parts is covered in greater
detail below.
The difference between what are called Screen Parts and what are called Library
Parts is fairly simple. Screen Parts reside on a screen and have particular settings,
like a PLC address referenced, BCD type, or a special color assigned. Whereas,
Library Parts are like templates for creating actual Screen Parts–– they have no
specific PLC address but do have a default type, color and texture, etc. Library Parts
are the Originals and Screen Parts are the Copies.

Adding Parts to a
Screen

User Parts

Screen Parts
versus Library
Parts
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Key Concepts

Library Parts

All Library Parts are contained in the library file of ScreenCreator. Each part in the
library is a template used to create actual parts on the screen. These library parts
can be edited and saved as a new library part or edited and saved under the same
name, overwriting the original part. Below you will find an example of editing and
saving as a new name. Very often, this is how you will create a new library part (you
will use an existing library part, change it and save it under a new name).

To edit a library part, click on
Library > Open > Part... to
bring up the Open Part
window. This window looks
just like the Select Part
window, but the Open Part
window opens the actual
Library Part for editing. Be
careful when opening a
library part, because any
changes you make will affect
all future uses of that library
part.

Remember, the Select Part
window allows you to choose
a Library Part to copy to the
screen, but the Open Part
window allows you to choose
a Library Part to edit.

Like Part
Templates

Editing Library
Parts
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To edit an existing Labeled
Pushbutton w/ Light Part to create
a new one with “CYCLE” on it.
Select the Pushbutton as shown
on the right (any with a label would
do).

The Part window appears as
shown on the right.

Click on the Browse List button to
view the components of this part.
Select the Text item and click
Attributes/Properties to edit the
Text. Remember, we want it to
have “CYCLE” on the pushbutton.

Type “CYCLE” in place of “SET”
and click OK. Notice that the new
text is not centered on the part.
Click and drag the text to center it
(the pointer has four arrows when
moving an object).

Creating a New
Library Part from
an Existing One
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Key Concepts

Click the Save button and the
Save Part window appears with
the original heading “Labeled
Pushbutton w/Light” selected. If
we clicked Save, the changes
would be made to the original
library part: #CLS4002.

Instead, let’s select the User Parts
class, change the name to CYCLE
and click Save.

Finally, click the X to close the new
Part window which is now labeled
CYCLE.

Creating a New
Library Part from
an Existing One
(Continued...)
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What follows below are step-by-step instructions for creating a new library part.

In some cases, you may find it necessary
to build a totally different type of Part. To
create a brand new Library Part, click on
Library > New > Part... and the Part Edit
window appears, on the right. The Select
Control tool is now active on the Drawing
Toolbar and the control tools are colored
and selectable in the Control Toolbar.
This is because we are now editing a
part, which can contain controls, versus a
screen which cannot have controls
alone.

Click the Size Window to Screen tool as
shown above right, and the window
becomes full sized with the dotted-line
frame of the part.

Next, turn on the grid by clicking the
Options tool in the Standard Toolbar. In
the Options window, click to enable the
Snap to Grid and enter 20 as the Grid
Size. After clicking OK, notice the thin
grid lines on the screen.

Click the Meter tool in the Control Toolbar
which opens the Meter window and
select medium for the needle thickness,
then click the Arrangement and Color
tab. Enter all of the settings as shown on
the right and click Arrangement to place it
on the window. The pointer becomes a
mouse. Click the left mouse button and it
becomes a cross–hair. Move the
cross-hair to the upper left corner of the
window and click to place the meter. This
is what you should see.

If you do not see the outline of the meter,
click on the the Display tool and select
“Both” for View of Parts and View of
Controls.

If the Controls Toolbar is not already
open, select it from Tools > Display, and
click New Default.

Creating a New
Library Part from
Scratch
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Now that the meter control has been
built, we will create a Figure of 10 meter
lines for the meter face. Click on the
Circular Scale tool, enter 10 and click
Create.

The cross-hair appears again. This time
bring the inside circle to the center grid
block as shown, and click.

The cross-hair appears again. Click on
the upper left corner as before and move
the pointer to the bottom left until the
white circle fits the meter, then click again
and the outside diameter is set in place.

Creating a New
Library Part from
Scratch
(Continued...)
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Now, carefully move the cross-hair
to the bottom left line of the meter
and click when the cursor line
matches the meter line. Do the
same for the bottom right line of the
meter. The meter is finished now,
but the cross–hair remains (in
case you want to do another
circular scale), so click the
Selection Mode tool (pointer) to
get the normal pointer back.

Finally, click the Save tool or
Library > Save As... and save the
meter as shown on the right. The
meter icon can be found by clicking
Select Icon. Enter ’MTR1’ as the
Name of this new part. Now the
meter will appear in the User Parts
class and can be added to screens
like any other part.

At this point we could move all of
the straight lines and the meter to
the middle of the part boundary
and add numbers (in text) around
the meter face, but that’s left for
you to do later if you choose.

Lastly,press Shift + X which sizes
the part boundary to the part.
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Inside a Part

Each Screen Part may have one or more Control component, and may have a Part
Program (see the next page) and a Background (made up of Figures, Textures and
colors).

Numerical Input Display Part

34.62

Figure (Text & Lines, etc.)

Background Texture

Background Color

Displays data from the PLC

Writes data to the PLC

if...
endif

endevent

event

Part Background

Part Program

The components of a Part can be thought of as layers
of lenses: some clear and some with Figures, colors,
text or symbols.

PLC

Control Color

Control Texture

Control

The Control component of
a part reads data from, and
may write data to, the PLC
address. In the Part
Properties box, shown on
the right, controls
associated with a part are
listed under Operation
Parameter. The Operation
Parameter settings for
each control are found in
the small box to the right of
the list, when the specific
control is selected. For the
part shown on the right,
there is only one control, a
Pushbutton/Switch.

Control
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The settings for a control may be accessed and edited by clicking on ’Edit
Details’. This brings up the box below, with the three tabs: Settings, Arrangement
and Color, and Operation Parameter. These settings are discussed in detail in
Chapter 5.

The Part Background is made up of any Figures (Text, lines, etc.), Textures, and
Colors that have been built into the Part.

Control Texture
and Color

Part Background
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To view the various Control(s), Figure(s) and Texture(s) of a given part,
double–click the part on the screen and then click ’Edit Contents’. Now the part is
displayed again in the editing window, click the Browse List tool and the Browse List
box will appear. Figures and Text are denoted by a square and triangle icon and
Controls are denoted by a C icon. The ten–key pad List, shown here, is an example
with Figures, Text and Controls.

Click on a component, then click Attributes/Properties to edit it or
click Select to identify it.

Viewing and
Editing Part
Components:
Browse List
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The diagram below will help you understand the elements of a Part.

Numerical Input Display Part

34.62

Figures (Text & Lines, etc.)

Background Texture

Background Color

Control Color

Control Texture
Any data from the PLC is
displayed by the Control.

The Texture and Color for ON
and OFF are specified here.

The Part Background Texture and
Color.

Control

How the
Components of a
Part fit together
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This is a very important point to understand for using any parts that change color
depending on the state of a bit (either ON or OFF). As an example we will use the
pushbutton we created in the Project Tutorial.
The key is to know that when the bit is ON, the Control “ON Color” replaces
anything that has the “OFF Color” (whether it is in a figure, like a circle or
rectangle, or the part Background Color itself), and the “OFF Color” remains
when the bit is OFF.

Double-click on the pushbutton
and the Part Properties window
pops up.

Click on Edit Details, select the
Arrangement and Color tab and
move the Pushbutton/Switch
window to the left as shown. This
allows you to see both the Part
Background Color and the OFF
Color at the same time.

Notice the Part Background Color.

Notice that the Part Background
Color is the same as the OFF
Color. If it were different, the
pushbutton color would not work
(that is, it would not change from
dark green to light green when it
went from OFF to ON).
Also, the Image (ON/OFF)
specifies which color to show on
the part in ScreenCreator only, not
on the panel itself.

For Example 2, add the
pushbutton shown on the right to a
screen, Edit Contents, then
Browse List, select the second
Circle and click
Attributes/Properties. In this case,
the part background color is gray
(the frame of the button) and not
the same as the OFF color.
Notice that the line and fill colors
are the same as the OFF Color.
See the Index for information on
the Fore and Back Colors (Tile).

Consider the two examples below, which illustrate this concept.

Example 1: Part Background
Color is the OFF Color.

Example 2: Another compoent is
the OFF Color. (Locate the
component with the OFF Color .)

How ON/OFF
Colors work in a
Part
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The Project Register:  Screens, Registered Text and Textures

Every Project has a Register, containing Screens,  Registered Text and Registered
Textures.

opens the Register to Project dialog box for viewing the registered screens, text
and textures of the current project. Note: these items cannot be edited from this
window.

Screens, covered at the beginning of this chapter, must have both a unique name
and a unique Registration number (except the Global screen, which is not
registered).

Click the Register to display
Screens in order of
Registration number.

Project > Register...

Screens
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Screens, covered at the beginning of this chapter, must have both a unique name
and a unique Registration number (except the Global screen, which is not
registered).

With the New Text window
open, you can begin typing
in the new text to be
registered. Then click the
save tool to save and assign
a registration number.

Use the Open tool to open
existing registered text, or to
view all registered text.

Registered text is used in
Registered Text Displays
and Warning Displays to
display text messages
which correspond to the
value in a PLC address (bit
or word).

Select Project > New
Text... to open the New Text
window.

Registered
Text

Creating or editing
Registered Text
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Registered Textures are different from both Screens and Registered Text, in that they exist in
the Library and may be registered as shown below.

Select Project > Register... to
open the Register to Project
window. Select a Texture and click
Reference...

Select a Texture and then click the
Cancel button.

The Texture is now registered and
may be used in the Registered
Texture Display part.

Registered
Textures
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Textures are made up of lines, circles, rectangles and so on, grouped together as a
single object. Often Textures are used as components of Parts, providing a visual
image of some physical device such as a pushbutton or switch. Textures may also be
placed on a screen directly, similar to Parts, but are typically only found inside a part.
Textures are essentially identical to Parts (see the ’Screen Part versus Library Part’
discussion above), except a texture may be placed in a part or on a Screen. The
Library Texture are still the Originals and Screen or Part Textures are the Copies.

When a screen or part is
open, the Texture tool is
active. After clicking it, the
Texture dialog box appears;
click Select to view and
select from the Library. Use
the Repeat in X or Y to
duplicate the Texture
horizontally or vertically.

The ISO 7000 Textures may
be used as symbols on
screens or in building new
parts. Click on the different
classes and scroll down to
see all of the members of
each class.

The General Parts Class
List of Textures are those
textures used already in the
built-in Library Parts.

Click on the Texture that you
want and place it on a
screen or part as you would
any Figure or object.

For help with adding
Textures, see the Library >
Add from External File >
Texture... section in the
Menus chapter

Textures

Screen (or Part)
Textures versus
Library Textures

Adding Textures to
a Screen or Part
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Bitmaps

Bitmaps may be used in a variety of ways including screen or part background,
importing a company logo onto a screen or simply displaying a picture.

When a screen or part is
open, the Bitmap tool is
selectable. After clicking it,
the Bitmap dialog box
appears; click Select to view
and select from the Library.

There are no bitmaps
provided in ScreenCreator,
since these tend to be
custom images. So, when
you open the Select Bitmap
it will be empty (unless you
have added bitmaps before
this). For help with adding
bitmaps, see the Library >
Add from External File >
Bitmap... section in the
Menus chapter.

Transparent makes all Black portions
of the Bitmap transparent.

Converts all colors (except black) to this color.

Adding Bitmaps to
a Screen or Part
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Figures (Drawing Objects)

Any Drawing Object (line or lines, ellipse/circle, rectangle, text, etc.) is referred to as
a Figure since it may be used as a component in a Part.

When a screen or a part is open, the Drawing tools are selectable. The individual
tools are covered in greater detail in the Menus chapter. Two attributes common to
many of the Drawing Objects are Line and Fill (Tile), shown below.

The Line of the object has a color (default is usually white) and a style (thin, dotted,
and thick).

The Fill feature involves two colors “tiled” together by the selected Tile pattern. The
white represents Tile Back color and the black represents Tile Fore color. One
color is never actually in front or back of the other, but Fore and Back is just a
means of distinguishing between the two. The default is usually as shown above,
with Tile Back alone chosen (set as Transparent) and Tile Fore being white. By the
way, since there is no Tile Fore in the mix, it could be any color. We recommend
experimenting with lots of Tile Fill combinations to get a feel for how it works.

Adding Figures to
a Screen or Part

Tile Color (Fill)
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ScreenCreator has toolbars that give quick access to various menu items. The Standard
Toolbar has the typical Windows tools (Cut/Paste/Undo etc.) along with Move to Front/Back,
display and download options. The drawing, part and control toolbars have all of the tools
associated with specific functions. There is also a Reference and a Status bar at the bottom of
the window for programming and compiling. Note: The drawing toolbar is shown both
anchored and floating to show both options. You can drag and drop the toolbars into place
and move them around the desktop as needed or anchor them in any location around the
application window, either horizontal or vertical.

Standard Toolbar

Drawing Toolbar
Part Toolbar

Control Toolbar

Reference Bar

Status Bar

Current Project – Screen

The Toolbars
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Key Concepts

A Quick Reference for the Toolbars

Selection Mode

Select Figure

Select Part

Select Control

Straight Line

Arc

Spline

Line-shaped Scale

Continuous Straight Line

Polygon

Set Attribute

Parallelogram

Rectangle

Fill

Circle/Ellipse

Text

Texture

Bitmap

Circular Scale

Drawing
Toolbar

Part
Toolbar

Lights

Pushbuttons/ Switches

Ten-Key Pads/ Keyboards

Screen Select Parts

Meters

Text Displays

Numerical Displays

Clocks/Calendars

Host Command Commu-
nication Parts

Graphs

Alarms (Errors/Faults/Warnings)

Texture Displays

Special Parts

User Parts

Figure Display

Pushbutton/ Switch

Clock Display

Plot

Bar

Text Display

Numerical Display

Band

Meter

Dotted Line

Circle

Free

Slider

Light

Selector Switch

Pipe

Control
Toolbar

Like most Windows  programs, ScreenCreator has a standard toolbar with the
normal tools and additional graphical and screen tools.

New
Screen

Open Screen

Save
Redo

Operation Parameter

Copy
Cut Undo

Attributes/Properties

Refresh

Move to
Front

Move to
Back Program

Option

Display

Snap to Grid

Browse List

Cascade Vertical
Tile

Horizontal
Tile

Size Window to
Screen

Download/BuildPaste

Edit Corner

Standard Toolbar
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Key Concepts

The Drawing Toolbar has the standard drawing tools and provides separate
selection for Drawing Objects (called Figures), Parts and Controls.

Selection
Mode

Select
Drawing
Object

Select
Part

Select Control

Straight
Line

Arc

Spline
L-shaped Scale

Continuous
Straight Line

PolygonSet Attribute
Parallelogram

Rectangle
Fill

Circle/Ellipse Text
Texture

Bitmap

Circle
Scale

The Part Toolbar, shown below horizontally , selects the various types of parts to be
added to a screen.

Text Displays

Numerical
Displays

Indicator Lights

Clocks/Calendars

Host CommandKeypads

Pushbuttons/
Switches

Select Screen
Graphs

Meters Alarms/Faults

Texture Displays

Special User Parts

The Control Toolbar contains the controls which operate within a part. The controls
can only be used when editing a library part (new or existing) or editing the contents
of an existing screen part.

Figure Display

Pushbutton/
Switch Clock Display Plot

BarText Display

Numerical Display Band Meter

Dotted Line Circle

Free

Slider
Light

Selector Switch

Pipe

TIP: This is another reminder to get in the habit of using the various tools instead of
selecting the functions through the menu bar. We promise you’ll save a lot of time!

Drawing Toolbar

Part Toolbar

Control Toolbar
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4–2
The Menus and Toolbars

ScreenCreator Menus

The Screen Menu

The Screen menu contains commands for creating a new screen, opening, closing
or deleting screens, as well as printing a screen and editing all screen colors.
If the Screen menu command can also be called by a Standard Toolbar tool, the tool
is shown below the menu command.

The large Screen
menu on the near
right is available
when a screen is
open. The small
Screen menu on the
far right is available if
no screen is open.

creates and opens a new Untitled
screen.

calls the Open Screen dialog
box, allowing you to select
and open a screen.

Selecting Simple Display is
the opposite of Details in
other Windows Open boxes
and only shows the screen
icons.

Screen > New

Screen > Open...
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The Menus and Toolbars

Clicking Select... brings up
the normal Windows Select
Folder box.

The Preview function can be
very useful for selecting the
right screen. All screens of
the current project are shown.

does just that, closes the selected screen.

simply saves the current screen, with any changes you may have made.

Screen > Open...

Screen > Close

Screen > Save
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4–4
The Menus and Toolbars

calls the Save Screen
dialog box, allowing you to
save the current screen
(under a different name or
under a different
registration number).

Compile When Saving can
be deselected to allow
creating and saving
screens without assigning
PLC addresses to parts. Be
aware, however, that those
screens cannot be
downloaded.

NOTE: When the Compile When Saving option is deselected, the parts on the
screen will not be compiled and therefore the screen cannot be downloaded!

brings up the Select Screen
box (for deleting a screen).

You will probably never use this command, since clicking the X on the upper right
corner of the edited part window is much quicker!

saves the part being edited. Clicking the Save tool does this as well, of course, but
only when a part is being edited and that part window is selected.

Screen > Save As...

Screen > Delete
Screen...

Screen > Close
Edited Part

Screen > Save
Edited Part
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The Menus and Toolbars

If no part’s contents are being edited, the Screen Colors box appears, below left. If
the contents of a part are being edited, the Part Properties box, below right,
appears, allowing the size and background color of the part to be specified.

Individual colors (identified by number) can be
changed by selecting then moving the
blue/red/green dials. Every occurrence of the
color number in the screen will be changed. To
restore the default color, select the color
number and click Restore the default color.

The size of the part can be
specified precisely above.

When selected, the Print Screen box appears. The command outputs a bitmap
(*.bmp) file and a text (*.txt) file. If “Output to Printer” is selected, it will also print the
files.

Finally, the Exit command, which closes ScreenCreator altogether after prompting
the user to save any screens or components that are being modified. Clicking the X
in the upper right corner of the ScreenCreator window is the same as the Exit
command.

Screen >
Properties of
Screen or Edited
Part...

Screen > Print
Screen...

Screen > Exit
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4–6
The Menus and Toolbars

The Create Menu

The Create menu contains commands for creating Drawing Objects (or Figures),
Controls and Parts. The tool that duplicates the command is shown in the left-hand
margin below the command.
The Create menu is only available when a screen or part is open.

The Create menu, on the right, features
the Drawing tools first, beginning with the
Select Mode, which returns the pointer
just like clicking the pointer tool below.

For any of the drawing functions below,
click, hold and drag to create the specific
drawing object.

opens the Straight Line box and the
pointer becomes a cross-hair for
drawing a line. Hold down the Shift
key while clicking and drawing to
make the line horizontal or vertical
(based on which direction you move
the pointer after first clicking).
Note: When creating dotted lines,
the line may not appear dotted if the
Zoom is set higher than 100%. Click
Tools > View to see more accurately
what will actually be displayed on the
panel.

The Arrow options determine
position (left/right/both), arrow
angles and length of the arrow(s).

NOTE: Holding down the Shift key while drawing any Figure will cause it to snap to
the grid or to the X or Y axis. It is best to experiment with the various tools to
understand the details of how they work.

Create > Straight
Line
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The Menus and Toolbars

opens the Arc box and the
pointer becomes a cross-hair for
drawing an Arc. Holding down
the Shift key will cause the initial
Ellipse to be a Circle and the
beginning and end points of the
Arc to fit the X or Y axis.

When the Snap to Grid is ON, holding down the Control Key (Ctrl) during clicking
will cause the center of the circle to snap to the nearest grid point. (See
Circle/Ellipse below.)

opens the Continuous
Straight Line box and the
pointer becomes a
cross-hair for drawing
connected lines. Each
click of the mouse ends
one connected line and
begins another.
Double-click to stop.

NOTE: Both the Continuous Straight Line and the Spline may be done in such a way
that a color could fill a resulting area or areas. Select Fill to experiment.

opens the Spline box
and the pointer
becomes a cross-hair
for drawing a
continuous curved
line. Each click begins
a new curve.
Double-click to stop.

opens the Rectangle box
and the pointer becomes a
cross-hair for drawing a
rectangle by clicking,
holding and dragging. To
create a Square, hold down
the Shift key at anytime
while dragging.

Create > Arc

Create >
Continuous
Straight Line

Create > Spline

Create > Rectangle
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4–8
The Menus and Toolbars

opens the Parallelogram
box and the pointer
becomes a cross-hair for
drawing a parallelogram. To
position the figure
horizontal or vertical, hold
the Shift key down while
drawing the first line then
release it after releasing the
left mouse button.

opens the Circle/Ellipse
box and the pointer
becomes a cross-hair for
drawing an ellipse by
clicking, holding and
dragging. To create a
Circle, hold down the Shift
key at anytime while
dragging.

When the Snap to Grid is ON, holding down the
Control Key (Ctrl) during clicking will cause the
center of the circle to snap to the nearest grid point.
(See Arc above.)

opens the Fill box and the
pointer becomes a mouse
symbol for filling any object
or screen with the specified
color. Double-click inside
the object area or screen
you want to fill.

opens the Text box and the
pointer becomes a mouse
symbol for placing any text
entered onto the screen.

Create >
Parallelogram

Create >
Circle/Ellipse

Create > Fill

Create > Text
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The Menus and Toolbars

opens the Bitmap box and
the pointer becomes a
mouse symbol for placing
any bitmap selected onto
the screen.
Color Convert replaces all
bits which are not black with
the color chosen.
Transparent makes all
black bits transparent, so
any filled color underneath
shows through.

opens the Texture box and
the pointer becomes a
mouse symbol for placing
any texture selected onto
the screen.

opens the Line Scale box for specifying
the number of lines and X or Y direction.
After clicking Create, the Straight Line
box appears and the pointer becomes a
cross-hair for sizing the scale onto the
screen.

opens the Circular Scale box for
specifying the number of lines. After
clicking Create, the Straight Line box
appears and the pointer becomes a
cross-hair for sizing the scale onto the
screen.

Create > Bitmap

Create > Texture

Create > Macros >
Line–shaped
Scale...

Create > Macros >
Circular Scale...
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4–10
The Menus and Toolbars

opens the Polygon box for specifying the
number of corners. After pressing
Create, the Continuous Straight Line box
appears and the pointer becomes a
cross-hair for sizing the polygon onto the
screen.

There are four tools in the Drawing Toolbar worth mentioning separately, since they
do not have a corresponding menu command. The first three are used to select
Figures, Parts and Controls, in that order. You may deselect the Select Part tool if
you want to move a figure which is very close by (so the part does not get moved
also). The last tool is the Set Attribute tool, which recalls a closed Create window
when the create tool is still selected. For example, if you were creating multiple text
items and had closed the Text box but wanted to add another piece of text–– click
the Set Attribute tool and the Text box returns. Otherwise, you would have to click
the Selection Mode tool (the pointer) and then click the Text tool again.

The Create > Controls sub-menu list is the same as the Control Toolbar. The
Pushbutton/Switch below serves as an example of how all the other items work, in
opening their respective dialog boxes.

opens the Pushbutton/Switch
dialog box for setting up the
control.

The Create > Parts sub-menu list is the same as the Part Toolbar. The Numerical
Display below serves as an example of how all the other items work in opening
Select Part dialog box, with that specific type of part selected.

Create > Macros >
Polygon...

Drawing Tools not
found in Create
Menu

Create >
Controls...

Create > Controls >
Pushbutton/
Switch...

Create >
Parts...
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opens the Select
Part dialog box
with Numerical
Displays selected.

The Edit Menu

Much like the Create menu, the Edit
menu contains commands for editing
Figures (or Drawing Objects), Controls
and Parts. Some of these commands are
duplicated by a tool in the Standard
Toolbar, shown below.

The Edit menu is only available when a
screen or part is open.

RedoCopy
Cut Undo

Refresh
Screen

Move to
Front

Move to
Back

ProgramPaste

Operation
Parameter

Attribute/
Properties

Edit
Corner

Create > Parts >
Numerical
Displays...
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4–12
The Menus and Toolbars

used to Undo the last operation. This function is effective for the last 16 operations.

used to cancel  the most recent Undo. This function is effective for the last 16 Undo
operations.

used to remove a component from a screen or window and store it in the clipboard.
See Paste.

used to copy a component from a screen or window to the clipboard. See Paste.

Tip: You can copy/cut and paste from one screen to another even if the screens are
in different projects. With one project open in ScreenCreator, launch ScreenCreator
a second time (don’t close the first session!) and open the second project and
screen. Now you can access multiple screens at the same time and cut/copy and
paste as if the parts were on the same screen.

Another Copy Tip: See the discussion below to quickly duplicate Figures.

Select any Figure (drawing
object) that you want to
duplicate. Hold the Control key
down and click the left mouse
button once the four arrow
pointer is shown. Hold the
Control key and the mouse
button both while you move the
pointer to the desired location
for the new copy and release.
Be sure to have the proper grid
settings before duplicating.

used to Paste the contents of the clipboard to a screen or window. See Cut and
Copy.

Edit > Undo

Edit > Redo

Edit > Cut

Edit > Copy

Duplicating
Figures

Edit > Paste
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deletes the selected item. Pressing the Delete key does the same thing.

This is not the same as Cut, since deleted items cannot be brought back by the Paste
function! If You delete accidentally, you can still Undo.

Selects all of the components on the current screen or window, including parts,
textures, text, and drawing objects.

causes the current screen to be re-drawn, restoring any visible distortions.

allows the corners of the selected Continuous Line or Spline to be moved without
moving the entire object.

brings up the Part Properties box if a part is selected or the Attributes box if a
component, figure or texture is selected.
Double-clicking the item does the same thing, but it is not always easy to click an
item without moving it or something near it.

brings up the Editing Part Contents
window on the far right.

This can also be done by holding the
pointer on or near the part name and
double-clicking when the pointer is
as shown on the right.

moves the selected figure or component to the front with respect to other items on
the screen. This does not apply to parts since parts cannot overlap on the screen.

moves the selected figure or component to the back with respect to other items on
the screen. This does not apply to parts.

rotates the selected item clockwise by the degrees chosen.

Edit > Delete

Edit > Select All

Edit > Refresh

Edit > Corner

Edit > Attributes
and Properties...

Edit > Edit
Contents of Part

Edit > Change
Order > Move to
Front

Edit > Change
Order > Move to
Back

Edit > Rotate or
Mirror > Rotate
90/180/270 deg.
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4–14
The Menus and Toolbars

turns the selected item into its mirror
image as shown on the right. The
original item (left) becomes the item
on the right. Both are shown to
illustrate the effect.

turns the selected item into its mirror
image as shown on the right. The
original item (top) becomes the item
on the bottom. Both are shown to
illustrate the effect.

ungroups the drawing objects (lines, squares, etc.) which make up the selected
texture.

ungroups the drawing objects (lines, squares, etc.) which make up background
texture of the part being edited.

opens the
Operation
Parameter
box of the
part whose
contents are
being
edited.

Edit > Rotate or
Mirror > Horizontal
Mirror

Edit > Rotate or
Mirror > Vertical
Mirror

Edit > Texture
Expansion >
Selected Texture

Edit > Texture
Expansion > Part
Background
Texture

Edit > Edit
Operation
Parameter...
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The Library Menu

The Library menu, on the right, has
commands related to Library Parts
and Textures. Some of the
commands are only available when a
library part is open.

opens a New Library Part window and is
ready for any components and controls
to be added.

opens a New Library Texture window and
is ready for any Drawing Objects (or
Figures) to be added.

Library > New >
Part

Library > New >
Texture
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4–16
The Menus and Toolbars

brings up the
Open Part window
for selecting the
Library Part to
edit.

opens the Open Texture
window for selecting the
Library Texture to edit.

closes the selected library part or texture.

Library > Open >
Part...

Library > Open >
Texture...

Library > Close
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brings up the Save Part window or Save Texture window, depending on which is
being edited.

opens either the Properties of Library Part or Texture window for viewing or editing.

brings up either the Print Library Part or Texture dialog box.
In printing a Library Part, the options are as follows:
* Part Background to a Bitmap File
* Information selected to a Text File
* All of the selections to the printer

Library > Save As...

Library >
Properties of
Library Member...

Library > Print
Library Member...
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4–18
The Menus and Toolbars

opens Save Part dialog box (just like Save As... does). In case you forgot to edit a
library part directly, this allows you to save a part that you have edited on the screen.

brings up the Add Part dialog box
allowing you to import into your
ScreenCreator Library folder a part
(*.apt file) from another Library folder.

Click Select and locate the file, then
click Add.

opens the Add Texture dialog box
allowing you to import into your
ScreenCreator Library a texture (*.tex
file) from another Library folder.

Click Select and locate the file, then
click Add.

brings up the Add Bitmap
dialog box allowing you to
import into your
ScreenCreator Library an
existing bitmap (*.bmp file)
from a windows folder.

Click Select and locate the
file, then click Add.

Library > Add Part
from Screen to
Library...

Library > Add from
External File >
Part...

Library > Add from
External File >
Texture...

Library > Add from
External File >
Bitmap...
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opens the Maintenance of
Part dialog box for making
changes to Parts and
Classes (like folders of
parts).

brings up the Maintenance of
Texture dialog box for making
changes to Textures and
Classes (like folders of
textures).

opens the Maintenance of Bitmap
dialog box for making changes to
Bitmaps and Classes (like folders of
bitmaps).

Library >
Maintenance >
Part...

Library >
Maintenance >
Texture...

Library >
Maintenance >
Bitmap...
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4–20
The Menus and Toolbars

The Tools Menu

The Tool menu, on the right, accesses
Display, Option, Browse List and View
dialog boxes. View is the only on of the
four that does not have a tool in the
Standard Toolbar.

opens the Display dialog box below.

Toolbar
Choices

Viewing
Options

Zoom

Ruler
for
Screen

brings up the Options dialog box below.

Snap to Grid
Command
Options

Grid Lines

Grid Offset, useful
for creating boxes
inside boxes

Part and Component
Icon Sizes

Tools > Display...

Tools > Options...
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opens the Browse List box below. If an open screen is selected, the list will consist
of only the screen objects. If the window of a part (whose contents are being edited)
is selected, the list will have only the components of that part.

Select Part,
Control, Fig-
ure, Bitmap or
Texture

brings up the View
window on the right for
verifying the proper
DirectTouch panel type.

Tools >
Browse List...

Tools >
View...
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4–22
The Menus and Toolbars

The Window Menu

The Window menu, on the right,
contains the standard window
commands (Cascade, Vertical Tile and
Horizontal Tile) as well as Size Window
to Screen and Arrange Icons.

Size Window to Screen causes the
window of the selected screen to fit the
screen itself. It is typically used after
zooming from 100% to 150/200% size.
The Arrange Icons command simply
arranges any minimized windows. Last on the Window menu is the

numbered list of currently open
windows, including any parts, screens
or textures. This provides a means of
selecting an open window that may be
hidden behind another.

The Project Menu

The Project menu contains
commands for editing the current
project and creating, opening or
deleting other projects. It has every
menu item selectable when a project
is open. If no project is open, the only
items you can select are: New, Open,
Upload, Restore, Copy and Delete.
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opens the Create New Project Properties dialog box.

calls the Open
Project dialog box,
allowing you to
select and open
another project.

To open more
than one project
at a time, see the
note below.

NOTE: If you want to Open more than one project at the same time, start
ScreenCreator again (launch another session without exiting the first session) and
open another project. This allows you to copy and paste parts, screens, text, etc.

Project > New

Project > Open
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4–24
The Menus and Toolbars

does just that, closes the current project.

opens the Project Properties dialog box, which contains the panel type, PLC
protocol, etc.

opens the Print Project dialog box for choosing various project report data to output
to a printer and/or to a file.

Project > Close

Project >
Properties...

Project > Print
Project...



T
he M

enus and
Toolbars

M
enus

and Toolbars
4–25
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opens the Project Register dialog box for viewing the registered screens, text and
textures of the current project. Note: these items cannot be edited from this window.

opens the Download/Build dialog box, which not only provides download and build
functions, but also allows the user to specify future upload edits and re–compiling of
all screens prior to downloading.

Note: If you want to allow the
project to be uploaded from
the panel, check the Upload
Enable box before
downloading.

Watch the status line on the
Upload/Download window to
see the Download process. The
normal status messages are:
Download started, User data is
being deleted, User data is
being transmitted, and User
data transmission finished.
When the download is done,
click End as shown on the right.

Project > Register...

Project >
Download/Build...
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4–26
The Menus and Toolbars

opens the Upload dialog box for uploading a project into ScreenCreator.

opens the dialog box with the same name. This can only be used when a project has
been uploaded that was previously downloaded to the panel with ’Upload Edit
Enable’.

opens the dialog box with the same name. This works just like normal downloading
except there is nothing to build because the uploaded project has been compiled.

opens the NewText dialog box for entering new text to be registered. It also has the
Open tool for selecting other registered text.

opens the dialog box with the same name. This gives quick access to all PLC
addresses of parts on screens which have been built using the Download/Build
command. If a screen has not been “built”, any PLC addresses on that screen will
not be listed in the Edit Address window.

brings up the Backup Project dialog box and prompts the user to select a folder in
which to store a copy of the current project file (.pro). Only a project which has been
backed up may be later restored.

brings up the Restore Project dialog box and prompts the user to select a project to
restore from a backup file (.pro.). The project restore function rebuilds the project
from the project file and stores the new project in the SC folder. The project to be
restored must have first been backed up.

brings up the Copy Project dialog box and prompts the user to select a project to
copy and a name for the new project. This may be used to create major versions of a
project being developed. Then as changes are abandoned, the user can return to
the previous version of the project.

Project > Upload >
Upload...

Project > Upload >
Restore Uploaded
Project...

Project > Upload >
Download
Uploaded Project...

Project > New
Text...

Project > Edit
Address...

Project > Backup...

Project > Restore...

Project > Copy...



T
he M

enus and
Toolbars

M
enus

and Toolbars
4–27
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opens the Delete Project box to select a project to delete. Use this function very
carefully.

The Help Menu

The Window menu, on the right,
contains the Help Index and About
ScreenCreator.

brings up the
standard Windows
Application Help box.

opens the Version
Information box.

Project > Delete...

Help >
Help Index...

Help >
About
ScreenCreator...
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5–2
Control Reference

Control Definition

Controls are the functional components of the parts which contain them. A control is
called by either the Operation Parameter (must be enabled) or by a program. If the
Operation Parameter is enabled, the control name will be listed under the ’Operation
Parameter’ heading in the Part Properties window. If there is a part program, a
Template name will be listed under the ’Operation Parameter’ heading in the Part
Properties window.

Control Function

Pushbutton/Switch Operates as a pushbutton or switch, turning ON/OFF a bit in the PLC.

Selector Switch Operates multiple switches, only one of which can be ON at a time.

Numerical Display Displays the numerical value of a specified PLC address(es).

Text Display Displays the text in a specified PLC address(es) or registered text.

Clock Display Displays the time of the DirectTouch panel’s internal clock.

Texture Display Displays the registered text according to the number in the PLC address.

Plot Plots 2 data points on a graph in X-Y coordinate values.

Bar Displays PLC data as a bar graph.

Line Displays PLC data as a line graph.

Band Displays PLC data as a divided color band.

Circle Displays PLC data as a divided color circle chart.

Free Displays PLC data as an area of color. (Example tank fill level.)

Slider Displays PLC data as a meter with a slide indicator.

Meter Displays PLC data as a circular meter with a needle indicator.

Light Indicates PLC bit state On/OFF by changing color.

Pipe Special light control to represent flow in a pipe or valve.
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Control Reference

Pushbutton/Switch

The
Pushbutton/Switch
control functions as
a pushbutton or
switch and can be a
minimum of 20x20
dots (pixels) in size.
This is the size of a
single touch cell,
keeping all parts
separate when
being selected by
touch.

� Name
The name must begin with a letter and may be 8 alphanumerics total. The control
name identifies the type of control and is particularly useful in parts having multiple
controls. Be careful when changing the name of a control since the part program
may refer to the name specifically and will not work if the name is changed!

� Type
* Momentary means that it is only ON when the switch/pushbutton is pressed and is
OFF when not pressed.

* Toggle means that the pushbutton/switch alternates between ON and OFF each
time it is pressed. This is sometimes called Maintained or Alternate.

* Auto Repeat works similarly to Momentary except it repeatedly sends the ON state
while the pushbutton/switch is pressed.

� Reverse when ON
This causes the ON colors of the part (including any textures) to be replaced by the
opposite color number. For instance, the yellow (15) becomes transparent (0); the
light green (14) becomes dark blue (1) and the light red (13) becomes dark red (2),
and so on.

� Buzz
sets the switch to make the buzz sound when pressed, but only if the System Setup >
Pushbutton Setup (on the panel itself) has the Touch Sound ON.

Pushbutton/Switch
Settings Tab
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5–4
Control Reference

� Initial State
sets the initial state of the switch/pushbutton ON/OFF when the screen is displayed.
For example, if the initial state is ON and the type is toggle, a value of 1 would be
written to the bit assigned as soon as the screen was displayed.

� Access
* Normal allows full operation of the control.

* Frozen means the control is turned off.

* Shaded means the control is turned off and is shaded in color.

This is the access of the Control, not the Part itself, so be careful when using this
setting with a duplicated control (see below). Although the part works like more than
one switch, the access applies to all addresses since it has only one control.

� PIO
Not Applicable. This is for a parallel IO module.

� Duplicate
is only selectable when editing the contents of the part. It creates multiple
pushbuttons/switches in the direction(s) chosen. The additional buttons reference
the PLC bit addresses following the bit address of the control and go from left to right
then top to bottom. When duplicating, you must size the part border big enough for
the duplicates: use Shift+x.

If a pushbutton or switch has a
duplication of 2 in X and 2 in Y, and the
bit address of the control was C2, then
the bit addresses of the others would be
as shown on the right.

C2 C3

C4 C5
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Control Reference

� Arrangement Information
is only selectable when editing the contents of the part. This determines the size of
the control by the location of the LeftTop and RightBottom corners (in X and Y
coordinates).

� Background (Texture and Color)
is used to set the textures and/or colors which will be displayed within the control
area. It works as if the control looks for every occurrence of the Color (and Texture)
when OFF and replaces it with the Color (and Texture) when ON. Make sure that the
background color (or the color of the circle or rectangle inside) of the Part itself is the
same as the Color when OFF, so the color of the part will change properly.

� Image
specifies which state (ON or OFF) the control will have on the screen in
ScreenCreator alone. This does not affect the state of the PLC bit address or what is
displayed on the panel itself.

Pushbutton/Switch
Arrangement and
Color Tab
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5–6
Control Reference

� Enable
is only selectable when editing the contents of the part. This enables the Operation
Parameter to operate the control (as opposed to the part program doing so). When
enabled, the control is listed under Operation Parameter in the Part Properties box
and Details Edit is selectable, which opens the Control dialog box above (with the
three tabs). If not enabled, the part must have a program in order to operate properly.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01.

� Address
refers to the single bit address of the PLC of which the control writes to and/or reads
from.

� Synchronize
sets the pushbutton/switch to read from the PLC bit address and indicate the status
of the bit by the ON or OFF color. If Synchronize is disabled, the control simply writes
to the bit and indicates the ON or OFF color regardless of the actual state of the bit.
(If, for some reason, the bit in the PLC was never changed, the part would not
indicate this.) With Synchronize enabled, however, the control checks the state of
the bit and displays the color accordingly. The difference is really only noticeable
when the switch type is Toggle.

� Write when ON/OFF
sets either a 1 or a 0 to be written to the PLC bit address when the control is ON or
OFF. Be sure to consult your PLC manual if you are uncertain here and never set
both to the same value!

� Data Type
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

Pushbutton/Switch
Operation
Parameter Tab
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5–7
Control Reference

Selector Switch

The Selector Switch control is a special version of the Pushbutton/Switch control. It
is used in standard library parts which have three duplicate pushbuttons. A part
program operates the three so that only one can be ON at a time. See the detailed
description in Chapter 6...

Numerical Display

The
Numerical
Display
control
displays a
numerical
value
stored in
the PLC
memory.

� Name
The name must begin with a letter and may be 8 alphanumerics total. The control
name identifies the type of control and is particularly useful in parts having multiple
controls. Be careful when changing the name of a control since the part program
may refer to the name specifically and will not work if the name is changed!

� Action
Action specifies how the display appears on the screen.

* Normal is the default, displaying the number in the Number Color.

* Rev replaces the Number color with the Tile Fore color.

* Flash alternates between Normal and Rev in 1 second intervals.

* Blink flashes the number ON/OFF (in Normal color) in 1 second intervals.

Numerical Display
Attributes Tab
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5–8
Control Reference

� Decimal Place
This specifies the placement of the decimal.

* Fixed adds zeroes (specified by Places to Right of Decimal below) to the right of the
decimal, or drops extra digits, as needed.

* Float displays the actual number, allowing any decimal place location.

* Fixed 2 maintains the specified places to the right of the decimal by locating the
decimal into the number (rather than adding zeroes).

� Places to Right of Decimal
determines the number of decimal places (to the right) displayed.

� No Zero Suppression
refers to zeroes to the left of the number displayed, excluding the first to the left of the
decimal if the value is less than one. The default is no zero suppression selected.

� Format Displayed Number
This specifies the number format displayed.

* BIN is binary, or base 2.

* OCT is octal, or base 8.

* DEC is decimal, or base 10, with a sign.

* HEX is hexadecimal, or base 16.

� Test Value / Display
This feature allows you to test the number format displayed. You can change the
Places to Right of Decimal, the Decimal Place (Fixed, Float or Fixed 2) and enter
different numbers to see how the number will be displayed.

� Duplicate
is only selectable when editing the contents of the part. It creates a display matrix in
the direction(s) chosen. The additional displays reference the PLC word addresses
following the initial address of the part and go from left to right then top to bottom.
When duplicating, you must size the part border big enough for the duplicates: use
Shift+x.

If a numerical display has a duplication
of 2 in X and 2 in Y, and the word
address of the part is V2000, the word
addresses of the others would be as
shown on the right.

V2000 V2001

V2002 V2003

NOTE: Do not use the Duplicate feature with either Numerical Input Displays or Text
Input Displays.
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5–9
Control Reference

� Arrangement Information
is only selectable when editing the contents of the part.
* Base Point is the top-left reference point of the display.
* Length and Interval specifies the number of numeric characters (text) and the
space (dot) between them horizontally.
* Size is the character size in both X and Y dimensions.
* Rotation specifies a clockwise rotation angle (None, 90, 180, or 270 degrees).

� Number Color and Background
is used to set the color of the numbers displayed and the background color (based on
the Tile choice and Fore/Back colors).

� Image
specifies a number for the control to display in ScreenCreator alone. The format of
the number displayed in ScreenCreator does not match that which is displayed on
the panel. Also, this does not affect the state of the PLC address or what is displayed
on the panel itself.

� Enable
is only selectable when editing the contents of the part. This enables the Operation
Parameter to operate the control (as opposed to the part program doing so). When
enabled, the control is listed under Operation Parameter in the Part Properties box
and Details Edit is selectable, which opens the Control dialog box above (with the
three tabs). If not enabled, the part must have a program in order to operate properly.

Numerical Display
Arrangement and
Color Tab

Numerical Display
Operation
Parameter Tab
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5–10
Control Reference

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01.

� Address
refers to the beginning word address of the PLC of which the control writes to and/or
reads from.

� Type
specifies the address type as either Word (single 16 bit) or Double Word (double 16
bit).

� Word Order
If double word, sets the byte order as either MSB (most significant byte) first or LSB
(least significant byte).

� Data Type
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC.
* BIN is binary, or base 2.
* SignBIN is signed binary, or base 2 with the 2s complement.
* BCD is binary-coded decimal.

� Scale
allows the value from the PLC (represented by ’X’) to be scaled by a formula. All
numbers (0–9), the following symbols : *, /, +, –, (, ), and the decimal point may be
used in the calculation. The result from the calculation becomes the new value
displayed.

Example:  To multiply the value by 20 and add 1, use this formula:  X*20+1.
Be sure to test the formula before using the result number. This may be done by
assigning a Numerical Input Display part to the same address.
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5–11
Control Reference

Text Display

The Text
Display
control
displays
either
registered
text (from
the panel)
or ASCII
text (from
the PLC).

� Name
The name must begin with a letter and may be 8 alphanumerics total. The control
name identifies the type of control and is particularly useful in parts having multiple
controls. Be careful when changing the name of a control since the part program
may refer to the name specifically and will not work if the name is changed!

Text Display
Attributes Tab
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5–12
Control Reference

� Action
Action specifies how the display appears on the screen.

* Normal is the default, displaying the text in the Text Color.

* Rev replaces the Text color with the Tile Fore color.

* Flash alternates between Normal and Rev in 1 second intervals.

* Blink flashes the number ON/OFF (in Normal color) in 1 second intervals.

� Orientation
* Horizontal

* Vertical

� Format
This specifies the location of the text in the display.

* Left is left justified.

* Center is centered in the control.

* Right is right justified.

� Duplicate
is only selectable when editing the contents of the part. It creates a display matrix in
the direction(s) chosen. The additional displays reference the PLC word addresses
following the initial address of the part and go from left to right then top to bottom.
When duplicating, you must size the part border big enough for the duplicates: use
Shift+x.

If a text display has a duplication of 2 in
X and 2 in Y, and the word address of
the part is V2000, the word addresses
of the others would be as shown on the
right.

V2000 V2001

V2002 V2003

NOTE: Do not use the Duplicate feature with either Numerical Input Displays or Text
Input Displays.
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5–13
Control Reference

� Arrangement Information
is only selectable when editing the contents of the part.

* Base Point is the top-left reference point of the display.

* Length and Interval X specifies the number of characters (char) and the space
(dot) between them horizontally.

* Length and Interval Y specifies the number of characters (char) and the space
(dot) between them vertically.

* Size is the character size in both X and Y dimensions.

* Rotation specifies a clockwise rotation angle (None, 90, 180, or 270 degrees).

� Text Color and Background
is used to set the color of the text displayed and the background color (based on the
Tile choice and Fore/Back colors).

� Image/Get length
specifies text for the control to display in ScreenCreator alone. The Get length
function automatically changes the Length and Interval X based on the text entered.

Text Display
Arrangement and
Color Tab
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5–14
Control Reference

� Enable
is only selectable when editing the contents of the part. This enables the Operation
Parameter to operate the control (as opposed to the part program doing so). When
enabled, the control is listed under Operation Parameter in the Part Properties box
and Details Edit is selectable, which opens the Control dialog box above (with the
three tabs). If not enabled, the part must have a program in order to operate properly.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01.

� Address
refers to the single (or first if more than one) PLC address assigned to the control.
The address may be either bit or word, but if it is a bit address, it may only display the
first registered text.

� Continuous Addresses
specifies the number of consecutive addresses (either bit or word) which determine
which registered text will be displayed.

* 1  If the Continuous Addresses value is 1 (the default), then the registered text is
simply the value contained in the word (or bit) address plus one.

* 2 or more  If the Continuous Addresses value is more than 1, then the registered
text is determined by the priority explained below.

Text Display
Operation
Parameter Tab
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Control Reference

Example A:  The text display has 4
continuous addresses with the first
address being V2500 and the registered
text number being 1. Since V2500 is the
starting address, it corresponds to
registered text number 1. V2501 goes with
text number 2, and so on. The registered
text displayed will be that of the first
address having a value greater than zero
(beginning with V2500). So, if V2500 has a
value of 2 and all the rest have a value of 5,
then Registered text 1 will be displayed.
Example B: The text display has 3
continuous addresses with the first
address being C0 and the registered text
number being 10. If C0 is OFF, but C1 and
C2 are ON, the registered text number 11
would be displayed.

V2500

V2501

V2502

V2503

Reg. Text 1

Reg. Text 2

Reg. Text 3

Reg. Text 4

C0

C1

C2

Reg. Text 10

Reg. Text 11

Reg. Text 12

NOTE: Example A above is not the best way to use word level addressing with a Text
Display. Please see Registered Text Displays in Chapter 6 for the best approach.

� Data Type
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

� Text Reg. No.
specifies the first registered text number to be displayed by the control.

Clock Display

The Clock
Display control
displays the
DirectTouch
panel internal
time in hour,
minutes and
seconds.

� Name
The name must begin with a letter and may be 8 alphanumerics total. The control
name identifies the type of control and is particularly useful in parts having multiple
controls. Be careful when changing the name of a control since the part program
may refer to the name specifically and will not work if the name is changed!

Clock Display
Attributes Tab
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5–16
Control Reference

� Action
Action specifies how the display appears on the screen.

* Normal is the default, displaying the text in the Text Color.

* Rev replaces the original background color with the reverse color (15–original).

* Flash alternates between Normal and Rev in 1 second intervals.

* Blink flashes the number ON/OFF (in Normal color) in 1 second intervals.

� Format has a pull-down list of several time formats to choose from (12 hour and
24 hour).

� Arrangement Information
is only selectable when editing the contents of the part.

* Base Point is the top-left reference point of the display.

* Interval specifies the space (dot) between the clock numbers horizontally.

* Size is the number size in both X and Y dimensions.

* Rotation specifies a clockwise rotation angle (None, 90, 180, or 270 degrees).

� Text Color and Background
is used to set the color of the text displayed and the background color (based on the
Tile choice and Fore/Back colors).

Clock Display
Arrangement and
Color Tab
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Control Reference

Figure (Texture) Display

The Texture
Display
control
displays a
registered
texture
according to
its number.

� Name
The name must begin with a letter and may be 8 alphanumerics total. The control
name identifies the type of control and is particularly useful in parts having multiple
controls. Be careful when changing the name of a control since the part program
may refer to the name specifically and will not work if the name is changed!

� Action
Action specifies how the display appears on the screen.

* Normal is the default, displaying the text in the Text Color.

* Rev replaces the original background color with the reverse color (15–original).

* Flash alternates between Normal and Rev in 1 second intervals.

* Blink flashes the number ON/OFF (in Normal color) in 1 second intervals.

� Fit Control Frame causes the texture to size proportionally with the control
frame. If not selected, the texture will stay its original size when the control size is
changed.

� Internal Rotation specifies a clockwise rotation angle of the displayed texture
(None, 90, 180, or 270 degrees).

Figure (Texture)
Display Attributes
Tab



P
ar

ts
 R

ef
er

en
ce

C
on

tr
ol

 R
ef

er
en

ce

5–18
Control Reference

� Duplicate
is only selectable when editing the contents of the part. It creates a display matrix in
the direction(s) chosen. The additional displays reference the PLC word addresses
following the initial address of the part and go from left to right then top to bottom.
When duplicating, you must size the part border big enough for the duplicates: use
Shift+x.

If a texture display has a duplication of 2
in X and 2 in Y, and the word address of
the part is V2300, the word addresses
of the others would be as shown on the
right.

V2300 V2301

V2302 V2303

� Arrangement Information
is only selectable when editing the contents of the part. This determines the size of
the control by the location of the LeftTop and RightBottom corners (in X and Y
coordinates).

� Background
is used to set the background color (based on the Tile choice and Fore/Back colors).

� Image
specifies a texture for the control to display in ScreenCreator alone. Click on Select
to choose from existing textures.

Texture Display
Arrangement and
Color Tab
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5–19
Control Reference

� Enable
is only selectable when editing the contents of the part. This enables the Operation
Parameter to operate the control (as opposed to the part program doing so). When
enabled, the control is listed under Operation Parameter in the Part Properties box
and Details Edit is selectable, which opens the Control dialog box above (with the
three tabs). If not enabled, the part must have a program in order to operate properly.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01.

� Address
refers to the single (or first if more than one) PLC address assigned to the control.
The address may be either bit or word, but if it is a bit address, it may only display the
first registered texture.

� Continuous Addresses
specifies the number of consecutive addresses (either bit or word) which determine
which registered texture will be displayed.

* 1  If the Continuous Addresses value is 1 (the default), then the registered texture is
simply the value contained in the word (or bit) address plus one.

* 2 or more  If the Continuous Addresses value is more than 1, then the registered
texture is determined by the priority explained below.

Figure (Texture)
Display Operation
Parameter Tab
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5–20
Control Reference

Example A:  The texture display has 4
continuous addresses with the first
address being V2600 and the registered
texture number being 1. Since V2600 is
the starting address, it corresponds to
registered texture number 1. V2601 goes
with texture number 2, and so on. The
registered texture displayed will be that of
the first address having a value greater
than zero (beginning with V2600). So, if
V2600 has a value of 2 and all the rest
have a value of 5, then Reg. Texture 1 will
be displayed..
Example B: The texture display has 3
continuous addresses with the first
address being C0 and the registered
texture number being 10. If C0 is OFF, but
C1 and C2 are ON, the registered texture
number 11 would be displayed.

V2600

V2601

V2602

V2603

Reg. Texture 1

Reg. Texture 2

Reg. Texture 3

Reg. Texture 4

C0

C1

C2

Reg. Texture 10

Reg. Texture 11

Reg. Texture 12

� Data Type
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

� Text Reg. No.
specifies the first registered texture number to be displayed by the control.
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Control Reference

Plot

The Plot control
plots the value of
two consecutive
PLC word
addresses in X,
Y coordinates.
Note: There are
no standard
parts in
ScreenCreator
which have the
plot control.

� Name
The name must begin with a letter and may be 8 alphanumerics total. The control
name identifies the type of control and is particularly useful in parts having multiple
controls. Be careful when changing the name of a control since the part program
may refer to the name specifically and will not work if the name is changed!

� Action
Action specifies how the display appears on the screen.

* Normal is the default, displaying the text in the Text Color.

* Rev replaces the original background color with the reverse color (15–original).

* Flash alternates between Normal and Rev in 1 second intervals.

* Blink flashes the number ON/OFF (in Normal color) in 1 second intervals.

� Calculation Format is used if a scaling formula is used (see X & Y Axis Scale
under Plot Operation Parameter Tab, below). Integer is faster than Float (Floating
Point), but is less accurate.

� Point Size specifies the size of the points plotted in Small, Medium, or Large.
� Maximum Plots specifies the number of points plotted.
� Range of X Axis determines the minimum and maximum values of the X axis.
� Range of Y Axis determines the minimum and maximum values of the Y axis.
� Internal Rotation specifies a clockwise rotation angle of the displayed plot

(None, 90, 180, or 270 degrees).

Plot Attributes Tab
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5–22
Control Reference

� Arrangement Information
is only selectable when editing the contents of the part. This determines the size of
the control by the location of the LeftTop and RightBottom corners (in X and Y
coordinates).

� Background
is used to set the color of the Point(s) and the background color (based on the Tile
choice and Fore/Back colors).

� Enable
is only selectable when editing the contents of the part. This enables the Operation
Parameter to operate the control (as opposed to the part program doing so). When
enabled, the control is listed under Operation Parameter in the Part Properties box
and Details Edit is selectable, which opens the Control dialog box above (with the
three tabs). If not enabled, the part must have a program in order to operate properly.

Plot Arrangement
and Color Tab

Plot Operation
Parameter Tab
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5–23
Control Reference

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01.

� Address
refers to the single PLC word address assigned to the control. The address becomes
the X axis value, the address immediately after becomes the Y axis value. For
example, if the address is V2400, then X is the value in V2400 and Y is the value in
V2401.

� Data Type
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

� Use Sampling
if enabled, specifies the sampling rate in seconds (by multiplying the number
entered by 0.5 seconds).

� X Axis Scale
allows the X value from the PLC (represented by ’X’) to be scaled by a formula. All
numbers (0–9), the following symbols : *, /, +, –, (, ), and the decimal point may be
used in the calculation. The value resulting from the calculation becomes the X
coordinate of the point displayed.

Example:  To multiply the value by 40 and subtract 3, use this formula:  X*40–3.

Be sure to test the formula before using the result number. This may be done by
assigning a Numerical Input Display part to the same address.

� Y Axis Scale
allows the Y value from the PLC (represented by ’X’) to be scaled by a formula. All
numbers (0–9), the following symbols : *, /, +, –, (, ), and the decimal point may be
used in the calculation. The value resulting from the calculation becomes the Y
coordinate of the point displayed.

Example:  To multiply the value by 13 and add 2, use this formula:  X*13+2.

Be sure to test the formula before using the result number. This may be done by
assigning a Numerical Input Display part to the same address.

NOTE: Both X axis and Y axis use ’X’ as the input to their respective scale formulas.
See the discussion of Scale for Numerical Displays earlier in this chapter.
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5–24
Control Reference

Bar Graph

The Bar Graph
control plots the value
of one or more PLC
word addresses in a
bar graph.

� Name
The name must begin with a letter and may be 8 alphanumerics total. The control
name identifies the type of control and is particularly useful in parts having multiple
controls. Be careful when changing the name of a control since the part program
may refer to the name specifically and will not work if the name is changed!

� Action
Action specifies how the display appears on the screen.

* Normal is the default, displaying the text in the Text Color.

* Rev replaces the original background color with the reverse color (15–original).

* Flash alternates between Normal and Rev in 1 second intervals.

* Blink flashes the number ON/OFF (in Normal color) in 1 second intervals.

� Calculation Format is used if a scaling formula is used (see Scale under the
Operation Parameter Tab, below). Integer is faster than Float (Floating Point), but
is less accurate.

� Bars specifies the number of bars to be displayed.
� Bar Width specifies the width of each bar in dots (or pixels).
� Range determines the minimum and maximum values of the bars.
� Level of Base Line specifies a value for the bottom reference line.
� Level of Line1 specifies a a value for the middle reference line.
� Level of Line2 specifies a value for the top reference line.
� Internal Rotation specifies a clockwise rotation angle of the displayed plot

(None, 90, 180, or 270 degrees).

Bar Graph
Attributes Tab
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5–25
Control Reference

� Arrangement Information
is only selectable when editing the contents of the part. This determines the size of
the control by the location of the LeftTop and RightBottom corners (in X and Y
coordinates).

� Base Line(Color,Style) the color and style of the Base Line.
� Line1(Color,Style) the color and style of the Line1.
� Line2(Color,Style) the color and style of the Line2.
� Background

is used to set the color of the background (based on the Tile choice and Fore/Back
colors).

� Color of each Bar
is used to set the color of each bar (based on the Tile choice and Fore/Back colors).

Bar Graph
Arrangement and
Color Tab
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5–26
Control Reference

� Enable
is only selectable when editing the contents of the part. This enables the Operation
Parameter to operate the control (as opposed to the part program doing so). When
enabled, the control is listed under Operation Parameter in the Part Properties box
and Details Edit is selectable, which opens the Control dialog box above (with the
three tabs). If not enabled, the part must have a program in order to operate properly.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01.

� Address
refers to the single (or first, if not sampling) PLC word address assigned to the
control. If no sampling is used, the value of the address becomes the first bar
displayed, the values of the addresses following the first become the second bar,
third bar and so on.

� Data Type
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

� Use Sampling
if enabled, specifies the sampling rate in seconds (by multiplying the number
entered by 0.5 seconds). If sampling is used, the only value displayed is that of the
single address (see above), with each bar being the value at that sample time. A new
bar appears on the left side of the graph for each new sample and all existing bars
are moved to the right.

� Scale
allows the value from the PLC address (represented by ’X’) to be scaled by a
formula. All numbers (0–9), the following symbols : *, /, +, –, (, ), and the decimal point
may be used in the calculation. The value resulting from the calculation is then
displayed as a bar. See Scale under Numerical Display earlier in this chapter.

Bar Graph
Operation
Parameter Tab
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Control Reference

Line Graph (Trend Graph)

 

The Line Graph
control plots the
value of one or more
PLC word address in
a line (or trend)
graph.

� Name
The name must begin with a letter and may be 8 alphanumerics total. The control
name identifies the type of control and is particularly useful in parts having multiple
controls. Be careful when changing the name of a control since the part program
may refer to the name specifically and will not work if the name is changed!

� Action
Action specifies how the display appears on the screen.

* Normal is the default, displaying the text in the Text Color.

* Rev replaces the original background color with the reverse color (15–original).

* Flash alternates between Normal and Rev in 1 second intervals.

* Blink flashes the number ON/OFF (in Normal color) in 1 second intervals.

� Calculation Format is used if a scaling formula is used (see Scale under the
Operation Parameter Tab, below). Integer is faster than Float (Floating Point), but
is less accurate.

� Number of Lines determines the number of sequential PLC address to plot.
� Number of Points determines the number of points that each line will have on

the graph.
� Range determines the minimum and maximum values of the points.
� Level of Line1 specifies a horizontal reference line on the graph. (Make

transparent if not wanted.)
� Level of Line2 specifies a second horizontal reference line on the graph. (Make

transparent if not wanted.)

Line Graph
Attributes Tab
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5–28
Control Reference

� Internal Rotation specifies a clockwise rotation angle of the displayed plot
(None, 90, 180, or 270 degrees).

� Arrangement Information
is only selectable when editing the contents of the part. This determines the size of
the control by the location of the LeftTop and RightBottom corners (in X and Y
coordinates).

� Line1(Color,Style) the color and style of the Line1.
� Line2(Color,Style) the color and style of the Line2.
� Background

is used to set the color of the background (based on the Tile choice and Fore/Back
colors).

� Line Color and Type
is used to set the color and type of each line.

Line Graph
Arrangement and
Color Tab
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Control Reference

� Enable
is only selectable when editing the contents of the part. This enables the Operation
Parameter to operate the control (as opposed to the part program doing so). When
enabled, the control is listed under Operation Parameter in the Part Properties box
and Details Edit is selectable, which opens the Control dialog box above (with the
three tabs). If not enabled, the part must have a program in order to operate properly.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01.

� Address
refers to the single (or first, if not sampling) PLC word address assigned to the
control. If no sampling is used, the value of the address becomes the first point
displayed, the values of the addresses following the first become the second point,
third point and so on.

� Data Type
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

� Sampling Time
specifies the sampling rate in seconds (by multiplying the number entered by 0.5
seconds).

� Flowing direction
is the direction of the plotted line(s). The arrow pointing to the right is left to right and
the arrow pointing to the left is right to left.

� Scale
allows the value from the PLC address (represented by ’X’) to be scaled by a
formula. All numbers (0–9), the following symbols : *, /, +, –, (, ), and the decimal point
may be used in the calculation. The value resulting from the calculation is then
displayed as a point.  See Scale under Numerical Display earlier in this chapter.

Line Graph
Operation
Parameter Tab
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5–30
Control Reference

Band

The Band control
indicates the value
of two or more PLC
word addresses as
a band of colors in a
given rectangle
shape.

� Name
The name must begin with a letter and may be 8 alphanumerics total. The control
name identifies the type of control and is particularly useful in parts having multiple
controls. Be careful when changing the name of a control since the part program
may refer to the name specifically and will not work if the name is changed!

� Action
Action specifies how the display appears on the screen.

* Normal is the default, displaying the text in the Text Color.

* Rev replaces the original background color with the reverse color (15–original).

* Flash alternates between Normal and Rev in 1 second intervals.

* Blink flashes the number ON/OFF (in Normal color) in 1 second intervals.

� Calculation Format is used if a scaling formula is used (see Scale under the
Operation Parameter Tab, below). Integer is faster than Float (Floating Point), but
is less accurate.

� Number of Zones determines the number of sequential PLC addresses to plot.
� Internal Rotation specifies a clockwise rotation angle of the band (None, 90,

180, or 270 degrees).

Band Attributes
Tab
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5–31
Control Reference

� Arrangement Information
is only selectable when editing the contents of the part. This determines the size of
the control by the location of the LeftTop and RightBottom corners (in X and Y
coordinates).

� Color of each Zone
is used to set the color of each zone (based on the Tile choice and Fore/Back colors).

� Enable
is only selectable when editing the contents of the part. This enables the Operation
Parameter to operate the control (as opposed to the part program doing so). When
enabled, the control is listed under Operation Parameter in the Part Properties box
and Details Edit is selectable, which opens the Control dialog box above (with the
three tabs). If not enabled, the part must have a program in order to operate properly.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01.

Band Arrangement
and Color Tab

Band Operation
Parameter Tab
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5–32
Control Reference

� Address
refers to the single (or first, if not sampling) PLC word address assigned to the
control. If no sampling is used, the value of the address becomes the first zone
displayed, the values of the addresses following the first become the second zone,
third zone and so on.

� Data Type
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

Circle
The Circle
control indicates
the value of two
or more PLC
word addresses
as a Circle of
colors (like a
Pie–chart).

� Name
The name must begin with a letter and may be 8 alphanumerics total. The control
name identifies the type of control and is particularly useful in parts having multiple
controls. Be careful when changing the name of a control since the part program
may refer to the name specifically and will not work if the name is changed!

� Action
Action specifies how the display appears on the screen.

* Normal is the default, displaying the text in the Text Color.

* Rev replaces the original background color with the reverse color (15–original).

* Flash alternates between Normal and Rev in 1 second intervals.

* Blink flashes the number ON/OFF (in Normal color) in 1 second intervals.

� Calculation Format is used if a scaling formula is used (see Scale under the
Operation Parameter Tab, below). Integer is faster than Float (Floating Point), but
is less accurate.

� Number of Zones determines the number of sequential PLC addresses to plot.
� Start Angle specifies starting clockwise angle of the circle chart (None, 90, 180,

or 270 degrees) where None is vertical.

Circle Attributes
Tab
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5–33
Control Reference

� Arrangement Information
is only selectable when editing the contents of the part. This determines the size of
the control by the location of the LeftTop corner and Diameter (Dot) in X and Y
coordinates.

� Color of each Zone
is used to set the color of each zone (based on the Tile choice and Fore/Back colors).

� Enable
is only selectable when editing the contents of the part. This enables the Operation
Parameter to operate the control (as opposed to the part program doing so). When
enabled, the control is listed under Operation Parameter in the Part Properties box
and Details Edit is selectable, which opens the Control dialog box above (with the
three tabs). If not enabled, the part must have a program in order to operate properly.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01.

Circle Arrangement
and Color Tab

Circle Operation
Parameter Tab
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5–34
Control Reference

� Address
refers to the single (or first, if not sampling) PLC word address assigned to the
control. If no sampling is used, the value of the address becomes the first zone
displayed, the values of the addresses following the first become the second zone,
third zone and so on.

� Data Type
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

Free

The Free control
displays the value
of one PLC word
address as an
area with color in
a given shape. An
example would
be the shape of a
tank filling up as
the value
approaches the
maximum.

� Name
The name must begin with a letter and may be 8 alphanumerics total. The control
name identifies the type of control and is particularly useful in parts having multiple
controls. Be careful when changing the name of a control since the part program
may refer to the name specifically and will not work if the name is changed!

� Action
Action specifies how the display appears on the screen.

* Normal is the default, displaying the text in the Text Color.

* Rev replaces the original background color with the reverse color (15–original).

* Flash alternates between Normal and Rev in 1 second intervals.

* Blink flashes the number ON/OFF (in Normal color) in 1 second intervals.

� Calculation Format is used if a scaling formula is used (see Scale under the
Operation Parameter Tab, below). Integer is faster than Float (Floating Point), but
is less accurate.

� Range specifies the minimum and maximum values displayed.
� Internal Rotation specifies a clockwise rotation angle of the figure (None, 90,

180, or 270 degrees).

Free Attributes Tab
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5–35
Control Reference

� Arrangement Information

is only selectable when editing the contents of the part. This determines the size of
the control by the location of the LeftTop and RightBottom corners (in X and Y
coordinates).

� Color of each Zone

is used to set the color of each zone (based on the Tile choice and Fore/Back colors).
The first area is the Zone itself, representing the value displayed; and the second
area, labeled Not zone is the remaining area inside the control.

� Image specifies the value displayed in ScreenCreator only. If the Range, above,
was 100 and the image was 50, the free part on the screen would display one
half of the height.

Free Arrangement
and Color Tab

Free Operation
Parameter Tab
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5–36
Control Reference

� Enable
is only selectable when editing the contents of the part. This enables the Operation
Parameter to operate the control (as opposed to the part program doing so). When
enabled, the control is listed under Operation Parameter in the Part Properties box
and Details Edit is selectable, which opens the Control dialog box above (with the
three tabs). If not enabled, the part must have a program in order to operate properly.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01.

� Address
refers to the single PLC word address assigned to the control. The free control then
indicates the value of the address.

� Data Type
specifies the data type of the PLC address. This must be correct for the proper value
to be displayed by the numerical display.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

� Scale
allows the value from the PLC address (represented by ’X’) to be scaled by a
formula. All numbers (0–9), the following symbols : *, /, +, –, (, ), and the decimal point
may be used in the calculation. The value resulting from the calculation is then
displayed as a zone. See Scale under Numerical Display earlier in this chapter.

Slider

The Slider
control
displays the
value of one
PLC word
address as a
meter with a
sliding pointer.

Slider Attributes
Tab
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5–37
Control Reference

� Name
The name must begin with a letter and may be 8 alphanumerics total. The control
name identifies the type of control and is particularly useful in parts having multiple
controls. Be careful when changing the name of a control since the part program
may refer to the name specifically and will not work if the name is changed!

� Action
Action specifies how the display appears on the screen.

* Normal is the default, displaying the text in the Text Color.

* Rev replaces the original background color with the reverse color (15–original).

* Flash alternates between Normal and Rev in 1 second intervals.

* Blink flashes the number ON/OFF (in Normal color) in 1 second intervals.

� Calculation Format is used if a scaling formula is used (see Scale under the
Operation Parameter Tab, below). Integer is faster than Float (Floating Point), but
is less accurate.

� Range specifies the minimum and maximum values displayed.
� Pointer Texture specifies the existing texture to be displayed as the pointer.
� Internal Rotation specifies a clockwise rotation angle of the figure (None, 90,

180, or 270 degrees).

� Arrangement Information
is only selectable when editing the contents of the part. This determines the size of
the control by the location of the LeftTop and RightBottom corners (in X and Y
coordinates).

� Image specifies the value displayed in ScreenCreator only. If the Range, above,
was 100 and the image was 75, the pointer on the screen would indicate three
quarters of the maximum.

Slider Arrangement
and Color Tab
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5–38
Control Reference

� Enable
is only selectable when editing the contents of the part. This enables the Operation
Parameter to operate the control (as opposed to the part program doing so). When
enabled, the control is listed under Operation Parameter in the Part Properties box
and Details Edit is selectable, which opens the Control dialog box above (with the
three tabs). If not enabled, the part must have a program in order to operate properly.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01.

� Address
refers to the single PLC word address assigned to the control. The slider then
indicates the value in the address by position.

� Data Type
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

� Scale
allows the value from the PLC address (represented by ’X’) to be scaled by a
formula. All numbers (0–9), the following symbols : *, /, +, –, (, ), and the decimal point
may be used in the calculation. The value resulting from the calculation is then
displayed as a position. See Scale under Numerical Display earlier in this chapter.

Slider Operation
Parameter Tab
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5–39
Control Reference

Meter

The Meter
control
displays the
value of only
one PLC word
address as a
circular meter
with a rotating
needle.

� Name
The name must begin with a letter and may be 8 alphanumerics total. The control
name identifies the type of control and is particularly useful in parts having multiple
controls. Be careful when changing the name of a control since the part program
may refer to the name specifically and will not work if the name is changed!

� Action
Action specifies how the display appears on the screen.

* Normal is the default, displaying the text in the Text Color.

* Rev replaces the original background color with the reverse color (15–original).

* Flash alternates between Normal and Rev in 1 second intervals.

* Blink flashes the number ON/OFF (in Normal color) in 1 second intervals.

� Calculation Format is used if a scaling formula is used (see Scale under the
Operation Parameter Tab, below). Integer is faster than Float (Floating Point), but
is less accurate.

� Range specifies the minimum and maximum values displayed.
� Needle Thickness specifies the thickness of the indicating needle: Thin,

Medium, or Thick.

Meter Attributes
Tab



P
ar

ts
 R

ef
er

en
ce

C
on

tr
ol

 R
ef

er
en

ce

5–40
Control Reference

� Arrangement Information
is only selectable when editing the contents of the part. This determines the size of
the control by the location of the LeftTop corner and Inside and Outside Diameters in
X and Y coordinates.

* LeftTop is the top left corner of the meter control.

* Outside Diameter is the outside diameter of the meter.

* Inside Diameter is the inside diameter of the meter.

* Start Angle is the reference angle (in degrees) for the needle showing the
minimum value (from Range above). An angle of zero degrees is vertical.

* End Angle is the reference angle (in degrees) for the needle showing the
maximum value (from Range above). An angle of zero degrees is vertical.

� Needle Color specifies the color of the needle.
� Image specifies the value displayed in ScreenCreator only. If the Range, above,

was 100 and the image was 75, the pointer on the screen would indicate three
quarters of the maximum.

Meter Arrangement
and Color Tab
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5–41
Control Reference

� Enable
is only selectable when editing the contents of the part. This enables the Operation
Parameter to operate the control (as opposed to the part program doing so). When
enabled, the control is listed under Operation Parameter in the Part Properties box
and Details Edit is selectable, which opens the Control dialog box above (with the
three tabs). If not enabled, the part must have a program in order to operate properly.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01.

� Address
refers to the single PLC word address assigned to the control. The meter then
indicates the value in the address.

� Data Type
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

� Scale
allows the value from the PLC address (represented by ’X’) to be scaled by a
formula. All numbers (0–9), the following symbols : *, /, +, –, (, ), and the decimal point
may be used in the calculation. The value resulting from the calculation is then
displayed as the angle of the needle. See Scale under Numerical Display earlier in
this chapter.

Meter Operation
Parameter Tab
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5–42
Control Reference

Light

The Light control is
the most simple of
all controls in
ScreenCreator. It
acts as an ON/OFF
indicator just like a
physical panel light
does.

� Name
The name must begin with a letter and may be 8 alphanumerics total. The control
name identifies the type of control and is particularly useful in parts having multiple
controls. Be careful when changing the name of a control since the part program
may refer to the name specifically and will not work if the name is changed!

� Action
Action specifies how the display appears on the screen.

* Normal is the default, displaying the text in the Text Color.

* Rev replaces the original background color with the reverse color (15–original).

* Flash alternates between Normal and Rev in 1 second intervals.

* Blink flashes the number ON/OFF (in Normal color) in 1 second intervals.

� Shape
* Rectangle specifies the shape of the light as being that of a rectangle (or square).

* Ellipse specifies the shape of the light as being that of an ellipse (or circle).

� Initial State
sets the initial state of the part (ON/OFF) when the screen is displayed on the panel.

Light Attributes
Tab
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5–43
Control Reference

� Duplicate
is only selectable when editing the contents of the part. It creates multiple Lights in
the direction(s) chosen. The additional lights reference the PLC bit addresses
following the bit address of the control and go from left to right then top to bottom.
When duplicating, you must size the part border big enough for the duplicates: use
Shift+x.

If a light has a duplication of 2 in X and 2
in Y, and the bit address of the control
was C2, then the bit addresses of the
others would be as shown on the right.

C2 C3

C4 C5

� Arrangement Information
is only selectable when editing the contents of the part. This determines the size of
the control by the location of the LeftTop and RightBottom corners (in X and Y
coordinates).

� Color
is used to set the colors which will be displayed within the control area. It works as if
the control looks for every occurrence of the Color (and Texture) when OFF and
replaces it with the Color (and Texture) when ON. Make sure that the background
color (or the color of the circle or rectangle inside) of the part itself is the same as the
Color when OFF, so the color of the part will change properly.

� Image
specifies which state (ON or OFF) the control will have on the screen in
ScreenCreator alone. This does not affect the state of the PLC bit address or what is
displayed on the panel itself.

Light Arrangement
and Color Tab
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5–44
Control Reference

� Enable
is only selectable when editing the contents of the part. This enables the Operation
Parameter to operate the control (as opposed to the part program doing so). When
enabled, the control is listed under Operation Parameter in the Part Properties box
and Details Edit is selectable, which opens the Control dialog box above (with the
three tabs). If not enabled, the part must have a program in order to operate properly.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01.

� Address
refers to the single (or starting if duplicate) bit address of the PLC of which the control
reads from and indicates the status of.

There is no option of Synchronize for a light, since it is synchronized by definition. It
displays the current state of the bit address in the PLC.

� Data Type
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

Light Operation
Parameter Tab
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Control Reference

Pipe

The Pipe control is basically a
special type of light control. It
acts as an ON/OFF indicator,
much like the light control,
with two ON states (ON1 and
ON2) and an OFF state. The
state is determined by the
number contained in the PLC
address.
For example, if the address
was V2000 and V2000 held 0
the state would be OFF.

V2000

0

1

2 or more

Color (Inside Pipe)

Green

Red

Blue

� Name
The name must begin with a letter and may be 8 alphanumerics total. The control
name identifies the type of control and is particularly useful in parts having multiple
controls. Be careful when changing the name of a control since the part program
may refer to the name specifically and will not work if the name is changed!

� Action
Action specifies how the display appears on the screen.

* Normal is the default, displaying the text in the Text Color.

* Rev replaces the original background color with the reverse color (15–original).

* Flash alternates between Normal and Rev in 1 second intervals.

* Blink flashes the number ON/OFF (in Normal color) in 1 second intervals.

� Pipe Thickness in pixels or dots: 1, 3, 5 or 7.
� Initial State

sets the initial state of the part ON1/ON2/OFF when the screen is displayed on the
panel.

Pipe Attributes Tab
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5–46
Control Reference

� Arrangement Information
is only selectable when editing the contents of the part. This determines the size of
the control by the number of passed points and location of each point (in X and Y
coordinates).

� Pipe Color
specifies the color of the pipe outline itself.

� Internal Color of Pipe
is used to set the colors which will be displayed within the control area for each state.
It works as if the control looks for every occurrence of the Color (and Texture) when
OFF and replaces it with the Color (and Texture) when ON1 or ON2. Make sure that
the background color (or the color of the circle or rectangle inside) of the part itself is
the same as the Color when OFF, so the color of the part will change properly.

� Image
specifies which state (ON1, ON2 or OFF) the control will have on the screen in
ScreenCreator alone. This does not affect the state of the PLC bit address or what is
displayed on the panel itself.

Pipe Arrangement
and Color Tab
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5–47
Control Reference

� Enable
is only selectable when editing the contents of the part. This enables the Operation
Parameter to operate the control (as opposed to the part program doing so). When
enabled, the control is listed under Operation Parameter in the Part Properties box
and Details Edit is selectable, which opens the Control dialog box above (with the
three tabs). If not enabled, the part must have a program in order to operate properly.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01.

� Address
refers to the single register address (example: V2000 for DirectLOGIC and N7:0 for
Allen–Bradley) of the PLC of which the control reads from and indicates the status of.

There is no option of Synchronize for a pipe, since it is synchronized by definition. It
displays the current state of the bit address in the PLC.

� Data Type
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

Pipe Operation
Parameter Tab
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6–2
Part Reference

Parts
A thorough description of the elements of a part is given in Chapter 3. This chapter
provides detailed reference information for parts which operate from a part program
(with Operation Parameter not enabled and one or more templates listed under
Operation Parameter). The templates contain variables used by the program.

Numerical Input Displays (Word)

A Numerical Input
Display (Word)
part calls a
specified ten-key
pad allowing the
user to input a
number to the
PLC word
address.

Template 1–8
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6–3
Part Reference

� Station #
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Address
refers to the word address of the PLC of which the control writes to and/or reads
from.

� Decimal Places
specifies the number of places to the right of the decimal. The default format is Fixed
2.

� BIN:1, SignBIN:2, BCD:3 (Data Type)
specifies the data type of the PLC address. This must be correct for the panel to
display the correct value. Enter 1 for BIN, 2 for SignBIN, and 3 for BCD.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

� Next Part Name
Enter the next part name to which the cursor is to be moved. Leave blank if not
needed.

� Input Min. Value
Enter the lower limit value acceptable as input to the display.

� Input Max. Value
Enter the upper limit value acceptable as input to the display.

� ScreenName with Ten-key Pad
Enter the screen name (if one other than the current screen) which has the ten-key
pad. See Self screen below.

When Template 9–16
is selected it appears
in place of Template
1–8 above.

� Ten-key Pad Name
Enter the name of the ten-key pad to be used.

� Self Screen: 1, Global Screen: None
If the ten-key pad is located on the same screen as the Numerical Input Display part
itself, enter 1. If it is on the Global Screen, enter nothing. The default is 1.

Template 9–16
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6–4
Part Reference

Numerical Input Displays (Double Word)

A Numerical
Input Display
(Double Word)
part calls a
specified
ten-key pad
allowing the
user to input a
number to the
PLC double
word address
(two
consecutive 16
bit words,
beginning with
the address
specified).

� Station #
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Address
refers to the first word address of the PLC of which the control writes to and/or reads
from.

Template 1–8
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6–5
Part Reference

� Decimal Places
specifies the places to the right of the decimal. The default format is Fixed 2 (Use the
Test Value feature in the Numerical Display Attributes Tab to see the result.)

� Data Order
specifies the byte order: 1 is for the LSB (Least Significant Byte) first, and 2 is for
MSB (Most Significant Byte) first. The default is 1.

� BIN:1, SignBIN:2, BCD:3 (Data Type)
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC. Enter 1 for BIN, 2 for SignBIN, and 3 for BCD.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

� Next Part Name
Enter the next part name to which the cursor is to be moved. Leave blank if not
needed.

� Input Min. Value
Enter the lower limit value acceptable as input to the display.

� Input Max. Value
Enter the upper limit value acceptable as input to the display.

When Template 9–16
is selected it appears
in place of Template
1–8 above.

� ScreenName with Ten-key Pad
Enter the the Global Screen name if it has the ten-key pad. See Self Screen below.

� Ten-key Pad Name
Enter the name of the ten-key pad to be used.

� Self Screen: 1, Global Screen: None
If the ten-key pad is located on the same screen as the Numerical Input Display part
itself, enter 1. If it is on the Global Screen, enter nothing. The default is 1.

Template 9–16
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6–6
Part Reference

ASCII Text Displays

ASCII Text Display
parts display ASCII
text as specified
below.

� Station #
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� First Address
refers to the word address of the PLC which contains the first of the number of
consecutive characters.

� Number of Characters (Full Size)
specifies the number of consecutive word addresses in the PLC which contain the
ASCII characters.

Template 1–8
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6–7
Part Reference

� Data Order
specifies the byte order: 1 is for the Lower, or LSB (Least Significant Byte) first, and 2
is for the Upper, or MSB (Most Significant Byte) first. The default is 1.

Text Input Displays

A Text Input Display
part calls a specified
keyboard allowing
the user to input text
to the PLC word
address(s).

� Station #
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Address
refers to the first word address of the PLC of which the control writes to and/or reads
from.

Note: Text Displays
display messages
from a text table.
See Registered
Text in the Index.

Template 1–8
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6–8
Part Reference

� Number of Characters (Full Size)
specifies the number of consecutive word addresses in the PLC which contain the
ASCII characters.

� Data Order
specifies the byte order: 1 is for the LSB (Least Significant Byte) first, and 2 is for
MSB (Most Significant Byte) first. The default is 1.

� Display Mode Normal: 1, Fast: 2
specifies the speed of displaying text. Normal (1) confirms the PLC’s value before
displaying it, much like Synchronize, while Fast (2) does not confirm. The default is
1.

� Next Part Name
Enter the next part name to which the cursor is to be moved. Leave blank if not
needed.

� ScreenName with Keyboard
Enter the the Global Screen name if it has the keyboard. See Self Screen below.

� Keyboard Name
Enter the name of the ten-key pad to be used.

When Template 9–16
is selected it appears
in place of Template
1–8 above.

� Self Screen: 1, Global Screen: None
If the keyboard is located on the same screen as the Numerical Input Display part
itself, enter 1. If it is on the Global Screen, enter nothing. The default is 1.

Template 9–16
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6–9
Part Reference

Registered Text Displays

The Registered Text Display part
provides a message display for
registered text. First, the Registered
Text is created using the Project >
New Text... menu. Then, the
Registered Text Display part can be
created and placed on a screen. The
part itself will display the registered
text desired based on either a bit (for
bit-level addressing) or the value in a
register (word-level addressing).

Creating/Editing Registered Text
Follow the steps below to create or edit Registered Text.

With the New Text window
open, you can begin typing
in the new text to be
registered. Then click the
save tool (floppy disk icon)
to save and assign a
registration number.

Use the Open tool to open
and edit existing registered
text, or to view all registered
text.

Notice the Open text
window initially shows
Name in alphabetical order.

Click on the Register Tab, as
shown on the right, to list the
text by Registration number.

Select Project > New
Text... to open the New Text
window.

Creating or editing
Registered Text
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6–10
Part Reference

The two ways of addressing in Registered Text Displays

There are two ways to access text in a Registered Text Display. The first is
referenced as  a PLC bit address (Bit-Level) and the second is as a PLC register or
word (Word-Level).

For bit-level addressing, enter
the PLC bit address and set
Continuous Addresses to the
number of bits you need. For
example, if you enter C0 as the
address and 5 as Continuous
Addresses, the display part will
monitor bits C0 through C4. But
if Continuous Addresses is set
to 16, the display part will
monitor bits C0 through C7 and
C10 through C17 (since there is
no C8 or C9 in octal
addressing).
Normally, you will enter 1 for the
Starting Text Reg. No. (This
refers to the Text displayed
when the bit address is OFF.)

NOTE: The default settings
for the Registered Text
Display are those for
Word-Level Addressing,
shown on the right.
Continuous Addresses is set
to 1 and is not selectable.
When a bit address is entered
in the Address field, the
Continuous Addresses field
becomes selectable and the
Text Reg. No. Offset becomes
Starting Text Reg. No.

The Starting Text Reg. No. allows you to begin with a higher Registered Text
Number. For example, if you set the address to C21 and Starting Text Reg.
No. to 21, the Text with Registration number 21 will display when C21 is OFF
and the Text with Registration number 22 will display when C21 is ON.
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6–11
Part Reference

For word-level addressing (V
memory with DirectLOGIC
PLCs or 16 bit words with
Allen–Bradley PLCs), enter
the PLC word address, set Data
Type to BCD for DirectLOGIC
and BIN for Allen–Bradley, and
enter 0 for the Text Reg. No.
Offset.

The Text Reg. Offset No. causes
the part to display the registered
text that equals the value in the
PLC register address plus the
offset.
For examle, if you wanted
Registered Text No. 30 to
display when the value 10 is
entered in the PLC register, you
would set the Offset to 20, since
10 plus 20 is 30.

NOTE: To avoid confusion, we recommend leaving the Text Reg. No. Offset as 0
unless it is absolutely necessary to offset the text referenced.
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6–12
Part Reference

Creating the Registered Text Display for Bit-Level Addressing
After you have created or edited Registered Text, you can create a Registered Text
Display part on a screen, which will then display the text based on a bit selected or
the value in a register.

Set up the the part as shown
for bit–level addressing,
with C1 as the address
and 1 as the Starting Text
Reg. No.
Click Arrangement and
place the part on the screen.

Next, create two pushbutton
parts on the screen, with
addresses C1 and C2, so
you can enter the number
for the Registered Text that
you wish to display.

In this example, we click on
the Registered Text Display
tool, choose the top right
part. Note: any display that
is A–J is a ten character
display.

Note:  It is best to do this
example on an existing
screen.

Now, when you press the C1
button on the panel, the
Registered Text with Reg.
Number 1 is displayed on
the Text Display. When you
press the C2 button, the
Registered Text with Reg.
Number 2 is displayed.

Creating a
Registered Text
Display part on a
screen
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6–13
Part Reference

Creating the Registered Text Display for Word-Level Addressing
After you have created or edited Registered Text, you can create a Registered Text
Display part on a screen, which will then display the text based on a bit selected or
the value in a register.

Set up the the part as shown
for word-level addressing,
with the Address set to
V2204 and the Text Reg.
No. Offset as 0.
Click Arrangement and
place the part on the screen.

Next, create a Numerical
Input Display part on the
screen and give it the same
address, V2204, so you can
enter the number for the
Registered Text that you
wish to display.
See Numerical Input
Displays earlier in this
chapter for help in setting up
the display with a ten key
pad, etc.

In this example, we click on
the Registered Text Display
tool, choose the top right
part. Note: any display that
is A–J is a ten character
display.

Note:  It is best to do this
example on an existing
screen.

Now, when you press the
Numerical Input part on the
panel and enter 1 on the ten
key pad, the Registered
Text (with Reg. Number 1) is
displayed on the Text
Display.

Creating a
Registered Text
Display part on a
screen
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6–14
Part Reference

Lights (For Each Bit of a Word Address)

These lights
(whether Indicator,
Symbol, or Name
Plate) all display the
ON/OFF status of
the specified bit of
the 16 bit word
address.

� Station #
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Address (Word)
refers to the word address of the PLC which contains the single bit position, below.

� Bit Position
specifies the status bit (0 to 15). Note: this part will not work correctly unless the
bit is from 0 to 15.

Template 1–8
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6–15
Part Reference

Toggle Switches

Please change the two
pushbutton/switch controls
in the Toggle Switch (by
editing details/ Browse List
from Part Properties).
Each Toggle Switch has
one switch for when the bit
is ON and one for when the
bith is OFF.

Toggle Switch
parts all have a
two-position
indicator for ON
and OFF, and
function just like
the other
pushbutton w/ light
parts.

� Station #
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Light Address
refers to the bit address of the PLC which indicates ON/OFF status.

� Pushbutton/Switch Address
refers to the bit address of the PLC which is turned ON/OFF by touching the switch.

Note:  All switches
in ScreenCreator
are Momentary (not
Toggle) as default!

Template 1–8
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6–16
Part Reference

Selector Switch 1 (#CLS5101)

The Selector Switch 1
has three pushbuttons,
of which one, and only
one, must be ON. When
the first one is pressed
(labeled Setup1), a value
of 1 is written to the PLC
address, when the
second (labeled
Setup2), a 2, and so on.
If the value of the
address is changed by
some other means, the
switch will indicate the
change only if the new
value is 1, 2 or 3.

� Station #
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Pushbutton/Switch Address
refers to the word address of the PLC to which a value (of 1,2 or 3) is written by
pressing one of the three pushbuttons.

Note:  All switches
in ScreenCreator
are Momentary (not
Toggle) as default!

Template 1–8
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6–17
Part Reference

Selector Switch 2 (#CLS5102)

The Selector Switch 2
has three pushbuttons,
of which only one may
be ON at a time. When
the first one is pressed
(labeled Setup1), a
value of 1 is written to
the PLC address, when
the second (labeled
Setup2), a 2, and so on.
To turn all buttons OFF,
press the one that is ON
a second time.
If the value of the
address is changed by
some other means, the
switch will indicate the
change only if the new
value is 0,1, 2 or 3.

� Station #
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Pushbutton/Switch Address
refers to the word address of the PLC to which a value (of 0,1,2 or 3) is written by
deselecting all or pressing one of the three pushbuttons.

Operation
Parameter
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6–18
Part Reference

� Synchronize
sets the switch to read from the PLC bit addresses and indicate the status of the bits
by the ON or OFF color. If Synchronize is disabled, the control simply writes to the bit
and indicates the ON or OFF color regardless of the actual state of the bit. (If, for
some reason, the bit in the PLC was never changed, the part would not indicate this.)
With Synchronize enabled, however, the control checks the state of the bit and
displays the color accordingly. The difference is really only noticeable when the
switch type is Toggle.

Ten-key Pads (For Numerical Input)

These ten-key pads are
called by Numerical
Input Display parts for
entering a number into
the PLC word address
of the Numerical Input
Display.

NOTE: Key pads must be Closed and Selectable to be visible only when called by
pressing the Numerical Input Display. The same is true for keyboards.
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6–19
Part Reference

Key Operation

� ENT (ENTER) writes the value to the PLC address(es).
� ESC (ESCAPE) stops and closes the ten-key pad.
� CLR (CLEAR) clears the current value displayed.
� SKIP stops input to the current input display part and skips to the next part specified

in the current input display part.

Keyboards (For Text Input)

These keyboards are called by Text Input Display parts for entering text into the PLC
word address of the Text Input Display. They must be Closed and Selectable to be
visible only when called by pressing the Text Input Display.

Key Operation

� SPC (SPACE) adds a space to the text.
� BS (BACK SPACE) removes the last character or space.
� CAPS works like “Caps Lock” on a physical keyboard.
� SHIFT causes each key pressed to produce its number or symbol.
� SKIP stops input to the current input display part and skips to the next part specified

in the current input display part.
� ESC (ESCAPE) stops and closes the ten-key pad.
� ENT (ENTER) writes the text to the PLC address(es).

NOTE: Keyboards must be Closed and Selectable to be visible only when called by
pressing the Text Input Display. The same is true for key pads.
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6–20
Part Reference

Ten-key Pad/Volume (Direct-write)

Direct–write  (#CLT3001)

This ten-key pad is a combination
ten-key pad and numerical display.

� Station #
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Address
refers to the first word address of the PLC of which the control writes to and reads
from.

� BIN:1, Signed BIN:2, BCD:3 (Data Type)
specifies the data type of the PLC address. This must be correct for the panel to
display the correct value. Enter 1 for BIN, 2 for SignBIN, and 3 for BCD.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

Key Operation

� ENT (ENTER) writes the value to the PLC address(es).
� CLR (CLEAR) clears the current value displayed.

Template 1–8
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6–21
Part Reference

Volume  (#CLT3002)

This “volume key pad” increments
the value written to the PLC
address.
Note: if correction coefficients
(other than the defaults) are used,
the number displayed is not the
value written to the PLC address!

� Station #
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Address
refers to the first word address of the PLC of which the control writes to and reads
from.

� Input Min. Value
Enter the lower limit value acceptable as input to the display.

� Input Max. Value
Enter the upper limit value acceptable as input to the display.

� Increment Value
Enter number to add or subtract for each touch of the increase/decrease button.

� BIN:1, Signed BIN:2, BCD:3 (Data Type)
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC. Enter 1 for BIN, 2 for SignBIN, and 3 for BCD.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

� Correction Coefficient A (Default 1)
� Correction Coefficient B (Default 0)

Enter the values for the scaling equation:  new value written to the PLC address =
number displayed – B/A.

Key Operation

� ENT (ENTER) writes the value to the PLC address(es).

Template 1–8
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6–22
Part Reference

Screen Select Parts

All of the Screen Select Parts below cause the panel to display a new screen based
on the operation of the part.

Screen Select Pushbuttons  (#CAB1001–#CAB1020)

� Next Screen Name
specifies the screen to display (or go to) when pressed.

Screen Select Pushbuttons (Notice Type)  (#CAB2001–#CAB2020)

writes the new screen’s registration number to the PLC.

� Next Screen Name
specifies the screen to display (or go to) when pressed.
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6–23
Part Reference

� BIN:1, Signed BIN:2, BCD:3 (Data Type)
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC. Enter 1 for BIN, 2 for SignBIN, and 3 for BCD.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

� Station #
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Address
refers to the word address of the PLC of which the control writes the registration
number of the Next Screen Name to.

� Control Part Usage Yes:1/ No:0
If No (default), then the part calls the Next Screen selected and writes its registration
number to the address above. If Yes, it only writes the registration number of the Next
Screen Name to the address above. This part is normally used in the default
setting (No:0).

Screen Select Control Parts  (#CLB3001–#CLB3101)

Screen Select Control Part  (#CLB3001)

changes screens based on the new screen’s registration number read from the
specified PLC word address. This part must be placed on the Global Screen, Closed
and Selectable, in order to work properly.

NOTE: It is best to only use this method of changing screens if you want the PLC to
be “in charge”, and only use other screen select parts if you want the panel to change
screens based solely on the user’s choice.
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6–24
Part Reference

� Station #
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Address
refers to the word address of the PLC to which the control writes the registration
number of the Next Screen Name.

� BIN:1, Signed BIN:2, BCD:3 (Data Type)
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC. Enter 1 for BIN, 2 for SignBIN, and 3 for BCD.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

Screen Select part with PIN (#CAB3101) See note in left margin.
goes to the specified screen only after the correct code, or PIN, is entered.

� PIN (or code)
the passcode which must be entered by the user to change to the Next Screen
Name.

� Next Screen Name
specifies the screen to display (or go to) when the PIN is entered.

Key Operation

� CLR (CLEAR) clears the current value displayed.
� ENT (ENTER) writes the value to the PLC address(es).

Screen Select part with PIN (#CLB3101) See note in left margin.

goes to the Next Screen Name when the user enters the PIN, found in the Address.
� Station #

is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Address
the PLC word address containing the PIN. Example: V2000 containing 3456. The
user must enter 3456 in order to display the Next Screen Name.

� BIN:1, Signed BIN:2, BCD:3 (Data Type)
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC. Enter 1 for BIN, 2 for SignBIN, and 3 for BCD.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

� Next Screen Name
specifies the screen to display (or go to) when the PIN is entered by the user.

Screen Select
Parts with PINs
must be made
Closed and
Selectable and
must be called
by a Special
Part called
Parts Control.
See Parts
Control in
Index.
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6–25
Part Reference

Trend Graphs (Data Storing)

The Trend Graphs below are identical to their counterpart graphs, with the addition
of a template for storing trend data.

� Enable
is only selectable when editing the contents of the part. This enables the Operation
Parameter to operate the control (as opposed to the part program doing so). When
enabled, the control is listed under Operation Parameter in the Part Properties box
and Details Edit is selectable, which opens the Control dialog box above (with the
three tabs). If not enabled, the part must have a program in order to operate properly.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Address
refers to the single (or first, if not sampling) PLC word address assigned to the
control. If no sampling is used, the value of the address becomes the first bar
displayed, the values of the addresses following the first become the second bar,
third bar and so on.

� Data Type
specifies the data type of the PLC address. This must be correct for the panel to
display the correct value.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

� Sampling Time
specifies the sampling rate in seconds (by multiplying the number entered by 0.5
seconds).

Line Graph
Operation
Parameter Tab
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6–26
Part Reference

� Flowing direction
is the direction of the plotted line(s). The arrow pointing to the right is left to right and
the arrow pointing to the left is right to left.

� Scale
allows the value from the PLC address (represented by ’X’) to be scaled by a
formula. All numbers (0–9), the following symbols : *, /, +, –, (, ), and the decimal point
may be used in the calculation. The value resulting from the calculation is then
displayed as a bar.

� Number of Lines
specifies the number of sequential PLC addresses to plot as lines.

� Number of Points
specifies the number of points (or readings) each line will have on the graph.

The template specifies the storing
settings for the graph.

� Number of Data Items (Data Points Stored)
Enter the number of data points to be stored. Only the last point of this number is
actually stored.

� Upper Limit Value
Enter the upper limit of data points before resetting to zero. It is important to know
that the current number of data points (COUNT below) does not stop, but gets reset
to 0 when the limit is reached.

� Number of Plots (Points)
Enter the number of sampled data points displayed on each graph. This number
must be the same as the Points above.

Key, Number and Button Operation

� NEW  displays the current value(s) as sampled data points connected in a line.
� Rec. (Recorded) displays the most recent stored data points.
� Fwd/Fast Fwd The right arrow and double right arrow buttons move “back in time”

if the flow direction is left to right.
� Rew/Fast Rew The left arrow and double left arrow buttons move “ahead in time”

if the flow direction is left to right.
� COUNT is the total number of sampled data points. This number never stops

increasing by 1 for each sample, but is reset to 0 when the Upper Limit Value is
reached.

� Bottom Left Number is the number of the data point on the left of the graph. If NEW
is selected, this number will always equal the COUNT and will be the current data
point. If Rec. is selected, this number varies as the graph is moved foward or
backward in viewing stored data. Note: The difference between the bottom left and
right numbers will always be one less than the number of points.

� Bottom Right Number is the number of the data point on the right of the graph. If
NEW is selected, this number will always equal the current COUNT minus the
number of points. If Rec. is selected, this number varies as the graph is moved
foward or backward in viewing stored data.

Template 1–8
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Part Reference

External Clocks and Calendars (for both DirectLOGIC and A–B)

The external clocks and calendars below are numerical displays that display the
PLC’s current time and date.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Address of Hour
refers to the single PLC word address for the hour.

� Address of Minute
refers to the single PLC word address for the minute.

� Address of Second
refers to the single PLC word address for the second.

� Data Type
specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

NOTE: Use a two digit format for the year (YY) on an Allen–Bradley PLC, although it
supports four digits (YYYY). The reason for this is that all clock parts in
ScreenCreator use a two digit format.
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Part Reference

External Clock/Calendar Setup Parts for DirectLOGIC PLCs

Clock/Calendar Setup (External PLC Direct)  (#CLK3002)

Part #CLK3002 (when placed on the Global Screen) synchronizes the Panel’s
Internal Clock/Calendar to the PLC’s current time and date. The next time the
Screen containing the internal clock or calendar is displayed, the internal clock or
calendar will be updated.

� Station, Address of Hour/Minute/Second/Month/Day/Year and Data Type are
standard.

� Screen Name with Calendar
refers to the Screen Name which displays the Internal Clock.

� Calendar Part Name
refers to the Internal Calendar Part Name.
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Part Reference

External Clock/Calendar Setup Parts for Allen–Bradley PLCs

Clock/Calendar Setup (External A–B)  (#CLK3003)

Part #CLK3003 (when placed on the Global Screen) synchronizes the Panel’s
Internal Clock/Calendar to the Allen–Bradley PLC’s current time and date. The next
time the Screen containing the internal clock or calendar is displayed, the internal
clock or calendar will be updated.

� Station, Address of Hour/Minute/Second/Month/Day/Year and Data Type are
standard.

� Screen Name with Calendar
refers to the Screen Name which displays the Internal Clock.

� Calendar Part Name
refers to the Internal Calendar Part Name.

NOTE: Use a two digit format for the year (YY) on an Allen–Bradley PLC, although it
supports four digits (YYYY). The reason for this is that all clock parts in
ScreenCreator use a two digit format.
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6–30
Part Reference

The Error Display
The Error Display is created automatically on the Global Screen of a new project,
and notifies the user of Alarm or Fault conditions occurring in the PLC program.

WARNING: Do not use the panel backlight off timer (System Setup > Display Control
> Display OFF Time) with any of the Alarm parts, unless you also use the Backlight
Control below.

Error Display (ERRPTS)  (#CAA1002)

This Error Display is created automatically on the Global Screen of a new project.

NOTE: This Error Display may be displayed one of two ways. On the DirectTouch
panel, use System Setup > Error Disp Setup to select either the bottom of the screen
(Screen Bottom) or full screen (Window Display).

The template specifies the settings for detecting the errors below.

� Clock operation error mask
0: Detects errors, 1: Does Not Detect errors.

� Battery voltage drop error mask (Low Battery error)
0: Detects errors, 1: Does Not Detect errors.

� Serial communication error mask
0: Detects errors, 1: Does Not Detect errors.

Error Display

Template 1–8
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Part Reference

Alarms (Warning Displays)
Warning Displays notify the user of Alarm or Fault conditions based on the
status of bits in the PLC. Warning Displays simply display Registered Text
chosen by the user. (Warning Displays operate similar to Registered Text
Displays. See page 6–9 for details on how Registered Text works in
Registered Text Displays.)

Creating/Editing Registered Text
Follow the steps below to create or edit Registered Text.

With the New Text window
open, you can begin typing
in the new text to be
registered. Then click the
save tool (floppy disk icon)
to save and assign a
registration number.

Use the Open tool to open
and edit existing registered
text, or to view all registered
text.

Notice the Open text
window initially shows
Name in alphabetical order.

Click on the Register Tab, as
shown on the right, to list the
text by Registration number.

Select Project > New
Text... to open the New Text
window.

Warning Displays

Creating or editing
Registered Text
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6–32
Part Reference

Double-click the Warning
Display part B001. Notice
C0 is the First Bit Address
and the Total Number of
Warning Bits monitored is
10–– which means C0–C7,
C10 and C11. Since the
First Registered Text No. is
11, the Registered Text with
a registration number of 11
will be displayed when C0 is
ON. The Registered Text
with a registration number
of 12 will be displayed when
C1 is ON, and so on.

The Warn1 screen from the
train project is shown on the
right. This project is
available from our website
at Automationdirect.com >
Technical Support >
Resources (Software
Upgrades) >
ScreenCreator, and is
called train.exe
(trainab.exe for
Allen–Bradley PLCs).
The pushbuttons at the top
are assigned to bits C0, C1,
C2, C4, C5 and C6.

Try this project out on your PLC to gain an understanding of how Warning
Displays work. There are other Warning screens with more Warning Displays to
try out, including one with a Clear Bit feature and one with a Record Type display.

NOTE: The Warning Displays which follow in this chapter have various features and
functions. Some have a Close button. Some show Time and Date stamp, etc.

Warning Display
Examples
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Part Reference

Warning Displays (Bit Addresses)  (#CLA2001–2201)

(#CLA2011 and #CLA2021 have
Historical logging, with time and date.)

These Warning Displays are mapped to consecutive bit addresses in the PLC.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� First Bit Address
refers to the first in a line of consecutive PLC bit addresses which trigger
corresponding registered text to display when ON. The First Bit Address is mapped
to the First Registered Text Number below.

� Total Number of Warning Bits
is the total number of PLC bit address (including the first above) which cause the
corresponding registered text to display.

� First Registered Text No.
refers to the registered text number mapped to the first bit address. The text with this
registration number will be displayed when the first bit address is ON. Be sure to
register the proper text for each warning bit.

Number and Button Operation

� COUNT is the total number of alarm messages.
� Scroll Up/Down The up and down arrow buttons scroll up and down on the warning

display
� CLOSE closes the display, if the access is Closed and Selectable.
� Clear the warning clears the selected warning.
� Clear all warnings clears all warnings.

In order to display an alarm condition, the #CLA2011 requires the PLC to latch (or
set) the alarm bit, while #CLA2021 does not require PLC latching.

WARNING:  For #CLA2011, when a warning is cleared, the latched PLC bit is
also un-latched (or reset). So, the ladder program does not require a reset coil.
Note: The #CLA2011 cannot latch X inputs!!

Note: Warning
Displays display
messages from
Registered Text.
See page 6–9 and
Registered Text in
the Index.



P
ar

t 
R

ef
er

en
ce

P
ar

t 
R

ef
er

en
ce

6–34
Part Reference

Warning Scroll Display (Bit Addresses)  (#CLA2101)

This Warning Display works like a scrolling marque, moving the warning text across
the screen from right to left.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� First Bit Address
refers to the first in a line of consecutive PLC bit addresses which trigger
corresponding registered text to display when ON. The First Bit Address is mapped
to the First Registered Text Number below.

� Total Number of Warning Bits
is the total number of PLC bit address (including the first above) which cause the
corresponding registered text to display.

� Number of Characters to Display
is the total number of characters of text across the screen. For DP–320 (and
DP–321) panels, this number is 40.

� Scrolling Speed The scrolling speed increases as this number decreases.
� Number of Characters to Move

is the number of characters to move each time the text is scrolled.

� Display Type (0/1)
specifies when the display is active–– 0: only when any warning bit is ON, 1: when
text is visibly scrolling on the screen (even if no bits are ON at that moment). When 1
is selected, the bits must all be OFF long enough for all text to scroll across the
screen.

� First Registered Text No.
refers to the registered text number mapped to the first bit address. The text with this
registration number will be displayed when the first bit address is ON. Be sure to
register the proper text for each warning bit.

Note: Warning
Displays display
messages from
Registered Text.
See page 6–9 and
Registered Text in
the Index.
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Part Reference

Warning Display (Record Type) (Bit Addresses)  (#CLA2201)

This Warning Display stores and displays the date and time that any warning bit
turned ON (or back OFF) with the registered text.

NOTE: To use this warning display, select a printer (Project > Properties > Connect
to), even though a printer might not be used.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� First Bit Address
refers to the first in a line of consecutive PLC bit addresses which trigger
corresponding registered text to display when ON. The First Bit Address is mapped
to the First Registered Text Number below.

� Total Number of Warning Bits
is the total number of PLC bit address (including the first above) which cause the
corresponding registered text to display.

� Number of Records
is the total number of warning lines to store.

� First Registered Text No.
refers to the registered text number mapped to the first bit address. The text with this
registration number will be displayed when the first bit address is ON. Be sure to
register the proper text for each warning bit.

� Auto Printing (1:YES, 0:NO)
specifies the printing each warning automatically, when detected or reset.

Number and Button Operation

� CLOSE closes the display, if the access is Closed and Selectable.
� PRINT sends the data to any printer connected.
� Warning display moves to the top of the recorded data.
� Scroll Up/Down The up and down arrow buttons scroll up and down on the warning

display

Note: Warning
Displays display
messages from
Registered Text.
See page 6–9 and
Registered Text in
the Index.
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6–36
Part Reference

Special Parts

Parts Control  (#CAZ2001 and #CLZ2001)

The part control parts open/close the specified part either by pressing the
pushbutton (#CAZ2001) or when the value of the word address is 1/0 (#CLZ2001).

� Station (#CLZ2001 only)
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Address  (#CLZ2001 only)
refers to the single PLC word address for the hour.

� Screen Name with Object Part
specifies the screen location of the part to be controlled (if not the same screen or the
global screen). If a screen name is entered here, it overrides the Sef/Global Screen
below.

� Object Part Name
specifies the name of the part to be controlled.

� Self-Screen: 1/ Global Screen: None
specifies the screen location of the part to be controlled. The Self-Screen is the same
screen as the control part itself.
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Part Reference

Brightness Adjustment  (#CAZ3001)

adjusts the brightness of the display (just like on the panel: System Setup > Display
Control).
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6–38
Part Reference

Back-light Controls  (#CLZ4001–#CLZ4002)

Back-light Control  (#CLZ4001)

This Back-light control part turns the panel back-light ON or OFF when the value is
1/0.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Address
refers to the single PLC word address controlling the back-light. A value of 1 turns
the back-light ON; a value of 0 turns it OFF.
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Part Reference

Back-light Control  (Continuous ON) (#CLZ4002)

This Back-light control part resets the display control time when the value is 1.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Address
refers to the single PLC word address controlling the back-light. A value of 1 resets
the display control time; a value of 0 allows the display control time to proceed.

Interlock Controls (#CAZ5001–#CAZ5002)

Interlock Control  (2 point push) (#CAZ5001)

This part prevents the System Mode Screen from being accessed (normally done by
pressing the upper left and lower right corners of the panel). To reset the interlock,
press the right side while holding down the left side.

WARNING: This Interlock Control prevents access to any System Mode functions
(including downloading), unless the user knows where this part is and how to use it.
DO NOT FORGET WHERE THIS PART IS PLACED ON THE SCREEN!

Interlock Control  (Reset Time Setting) (#CAZ5002)

This part resets the interlock for the specified time and then turns the interlock back
on. During the wait time, the System Mode may be called by pressing the upper left
and lower right corners of the panel.

� Wait Time (sec)
specifies the time in seconds to wait before interlocking the panel.
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6–40
Part Reference

PID  (#CLZ6001)

This part functions as a PID (Proportional-Integral-Derivative) control and display. It
has a bar graph and numerical display for PV and a bar graph for SP. Also, a ten-key
pad must be assigned for entering the SP.

PV (Process Variable): the actual measured value.

SP (Setpoint): the value desired.

The template specifies the settings for
detecting the errors below.

� Station
is used for applications where more than one PLC is connected to the panel. The
default is 01. The station # must match the PLC port address.

� Address (SP)
refers to the PLC word address assigned to the SP. This must be the same as that of
the Bar graph BAR_SP.

� Decimal Places
� Data Type

specifies the data type of the PLC address. This must be correct for the panel to
communicate with the PLC.

* BIN is binary, or base 2.

* SignBIN is signed binary, or base 2 with the 2s complement.

* BCD is binary-coded decimal.

� Next Part Name
Enter the next part name to which the cursor is to be moved. Leave blank if not
needed.

� Input Min. Value
Enter the lower limit value acceptable as input to the display.

Template 1–8
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Part Reference

� Input Max. Value
Enter the upper limit value acceptable as input to the display.

� ScreenName with Ten-key Pad
Enter the screen name (if one other than the current screen) which has the ten-key
pad. See Self screen below.

� Ten-key Pad Name
Enter the name of the ten-key pad to be used.

� Self Screen: 1, Global Screen: None
If the ten-key pad is located on the same screen as the Numerical Input Display part
itself, enter 1. If it is on the Global Screen, enter nothing. The default is 1.

Template 9–16
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Connecting to a PLC

In This Appendix. . . .
— Connecting to DirectLOGIC PLCs
— Connecting to Allen–Bradley (A–B) PLCs
— Connecting to a WinPLC
— The Programming Cable (DP–PGMCBL)
— DirectTouch Cable pin-outs
— DirectTouch Panel Specifications
— Panel Dimensions and Installation
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Connecting to a PLC
A–2

Connecting to DirectLOGIC PLCs

Warning: Be aware that the DirectTouch panel, as with any external device, can
write to PLC registers and bits. You must be careful in using the panel to write to any
PLC address. It is a good idea to use PLC ladder logic to call screens and to
write to PLC outputs based on prescribed conditions.

1.  Choose either RS–232 or RS–422 for panel/PLC communication.
If you are using a PLC which has RS–422 (like the D2–250, D3–350 and D4–450),
the most efficient way is shown in the figure below. This keeps you from constantly
having to swap back and forth between PC and PLC when designing screens and
ladder logic.

2.  Set up panel/PLC communications (RS–232 or RS–422). Press the upper
left and lower right corners of the panel screen to bring up the System Mode
Main Menu screen below and press System Setup.

If RS–422 is used for panel/PLC connection, set the communication settings
(baud rate–– in bps, parity, stop bit, and data length) the same on the panel as
the PLC.
In this case the RS–232 is used for panel/PC connection. The panel RS–232
settings may be ignored since the panel will adjust to the PC settings for
downloads and uploads.

Press the upper left and lower right corners of the panel screen to
bring up the System Mode Main Menu screen below and press System Setup.

System Mode Main Menu

System Setup

System Check

Up/Download

User Mode

Step 1
1

Step 2
2

RS–422
(panel/PLC)

DirectTouch Setup
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System Setup

RS232C
Setup

RS422/485
Setup

Host Command
Setup

Clock
Setup

Pushbutton
Setup

Display
Control

Display
Direction

Error Disp
Setup

Printer
Setup

RAM File

End

 Setup

NOTE: Initially, the panel is set to Not Used on both RS232C and RS422/485.

Press the RS232C Setup button first, then the Connected Device
button and select PLC (and ENT).  Press enter (ENT) again for the change to
take effect.

Connected
Device

9600Communication
Rate

Parity Check

ESC

ODD

1

8

Stop Bit

Data Length

bps
RS232C

RS422/485

Not Used

ENTDetail

PLC

RS232C

Not Used

RS–232C Setup
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NOTE: Initially, the panel is set to Not Used on both RS232C and RS422/485.

Press the RS422/485 Setup button, then the Connected Device
button and select PLC (and ENT). Press enter (ENT) again for the change to
take effect.

Connected
Device

9600Communication
Rate

Parity Check

ESC

ODD

1

8

Stop Bit

Data Length

bps
RS232C

RS422/485

Not Used

ENTDetail

RS422/485
PLC

Not Used

If using RS–422, the PLC and panel can remain connected while
both may be configured/programmed by the PC using a switch.

RS–422
(CH3)

RS–232
(CH1)

Data Switch

A B

During configuration/programming, we found this setup very helpful for the D2–250:

DirectTouch panel

D2–250

Programming Cable
DP–PGMCBL

Pig-tail Cable
D2–DSCBL–2
(for RS–422)

RS–422
(CH3)

FG

SG

RD–

RD+

SD–

SD+

Black/White

Yellow/White

Yellow

Orange

Orange/White

D2–DSCBL–2 Wiring Instructions:
Connect the colored wires as shown.
Tie Blue/White to Green/White and
Blue to Green. (This ties RTS to
CTS.) Tape all unused wires and tied
wires so they cannot touch each other.

D2–DSCBL

Serial Cable
(Straight through)

RS–422 Setup
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If RS–232C is used for panel/PLC connection, follow the same steps above, only
set RS–232C as the PLC and RS–422 as Not Used.

3.  Connect the PLC to the panel through the proper cable below. For cable
pinouts, see page A–15.

DirectTouch Cables

PLCFamily PLC
(or other device)

Port Cable

DirectLOGIC�

DL05
D0–05xx Port1 or Port2 DP–2CBL

DirectLOGIC�

DL105
F1–130 Only one DP–2CBL

DirectLOGIC� D2–230 Only one DP–2CBL
DL205

D2–240 Top port DP–2CBL

Bottom port DP–2CBL

D2–250 Top port
Bottom port
Bottom port (RS–422)

DP–2CBL
DP–2CBL–1
D2–DSCBL–2

D2–DCM Only one DP–3CBL–2

DirectLOGIC� D3–340 Top port DP–3CBL
DL305

Bottom port DP–3CBL

D3–350 Top port (Phone Jack) DP–2CBL

Bottom port
Bottom port (RS–422)

DP–3CBL–2
D2–DSCBL–2

D3–DCM or 330/340 DCU Only one DP–3CBL–2

DirectLOGIC� D4–430 Top port (15-pin) DP–4CBL
DL405

Bottom port (25-pin) DP–3CBL–2

D4–440 Top port (15-pin) DP–4CBL

Bottom port (25-pin) DP–3CBL–2

D4–450 Phone Jack DP–2CBL

Top port (15-pin)
Top port (RS–422)

DP–4CBL
D2–DSCBL–2

Bottom port (25-pin) DP–3CBL–2

D4–DCM Only one DP–3CBL–2

Allen-Bradley�
SLC 500

5/03 & 5/04 Bottom port DP–ABCBL–1

WinPLC WinPLC Top port or Serial I/O
Top port (RS–422)

DP–2CBL
Belden 9729
(or equal)

Allen-Bradley�
MicroLogix�

1000 & 1500 Only one DP–ABCBL–2

See page A–15 for information regarding the DirectTouch panel programming
cable (DP–PGMCBL).

RS–232C
(panel/PLC)

Step 3
3

Programming
Cable
(DP–PGMCBL)
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Connecting to Allen–Bradley (A–B) PLCs

Warning: Be aware that the DirectTouch panel, as with any external device, can
write to PLC registers and bits. You must be careful in using the panel to write to any
PLC address. It is a good idea to use PLC ladder logic to call screens and to
write to PLC outputs based on prescribed conditions.

Press the upper left and lower right corners of the panel screen to
bring up the System Mode Main Menu screen below and press System Setup.

System Mode Main Menu

System Setup

System Check

Up/Download

User Mode

System Setup

RS232C
Setup

RS422/485
Setup

Host Command
Setup

Clock
Setup

Pushbutton
Setup

Display
Control

Display
Direction

Error Disp
Setup

Printer
Setup

RAM File

End

 Setup

DirectTouch Setup
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NOTE: Initially, the panel is set to Not Used on both RS232C and RS422/485.

Press the RS232C Setup button first, then the Connected Device
button and select PLC (and ENT).  Press enter (ENT) again for the change to
take effect.

Connected
Device

9600Communication
Rate

Parity Check

ESC

EVEN

1

8

Stop Bit

Data Length

bps
RS232C

RS422/485

Not Used

ENTDetail

PLC

RS232C

Not Used

Since RS–232C must be used for panel/PLC connection on A–B PLCs set
RS–232C as the PLC and RS–422 as Not Used.

1.  Setup Channel 0 as shown below for panel/PLC communication. The
window below is for SLCs. 
The Micrologix 1500 has only Chan. 0–System, but is configured the same as
below–– except Error Detection must be CRC.
The Micrologix 1000 is factory set to Parity: NONE (and cannot be changed). The
Baud Rate should be set to 9600.

Micrologix 1500 Setup

RS–232C Setup

RS–232C
(panel/PLC)

Step 1
Channel 0
(RS–232C) Setup

1
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2.  Setup Channel 1 as shown below, for PC/PLC communication. (Micrologix
PLCs do not have Channel 1.)

RS–232
(CH1)

Unfortunately, there is no easy way to configure/program
the A–B PLCs at the same time as the DirectTouch panel.

SLC 5/03
or 5/04

Programming Cable
DP–PGMCBL

Data
Switch

Suggested Setup for programming the panel for an A–B PLC.
The optional (user provided) data switch can be used to switch between panel/PC and
panel/PLC.

Serial Cable
(Straight through)

DP–ABCBL–1 Cable
(DP–ABCBL–2 for
Micrologix)

A B

DirectTouch panel

NOTE: Use two different PC comm ports, for Allen–Bradley, one to the panel and
one for programming the PLC. Using a single port for both causes conflicts.

3.  For SLCs: Connect the A–B PLC (bottom port) to the DirectTouch panel through
the DP–ABCBL–1 cable.
3.  For Micrologix: Connect the A–B PLC (only port) to the DirectTouch panel
through the DP–ABCBL–2 cable.

NOTE: For Micrologix PLCs, set the Error Detection to CRC!

2
Step 2
Chan. 1 (DH 485)
Setup

Step 3
3
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Allen–Bradley SLC 5/03 or 5/04: Data Addressing
Bit level addressing is available for all file types below.
The only usable 16 bit word addresses are those in the Bit, Integer and Floating
Point data files, for example N7:0 or B9:3. These word addresses may be used
for Numerical Displays, Text Displays or for any other part requiring a word
address. Status, Integer and Binary files are defined with e for element instead of
w, for word. But for these files, e is actually a 16 bit word!

Allen–Bradley Data Files

File Type File Element Range Element Value Bit RangeFile Type
file (f)

File
Number

Element Range
element (e), word (w)

Element Value
Range

Bit Range
bit (b)

Status (Sf:e/b) 2 0–255 –32768 to 32767 0–15

Binary (Bf:e/b or Bf/b) 3, 9–255 0–255 –32768 to 32767 0–15

Timer (Tf:e.w/b) 4, 9–255 e: 0–255, w: 0–2 * –32768 to 32767 0–15 *

Counter (Cf:e.w/b) 5, 9–255 e: 0–255, w: 0–2 * –32768 to 32767 0–15 *

Control (Rf:e.w/b) 6, 9–255 e: 0–255, w: 0–2 * –32768 to 32767 0–15 *

Integer (Nf:e/b) 7, 9–255 0–255 –32768 to 32767 0–15

Floating Point (Ff:e/b) 8, 9–255 0–255 1.1754944e–38 to
3.40282347e+38

0–15

* See the Rockwell (or Allen–Bradley) manual for details of elements/words.

In order to indicate the status of, or write to, Input/Output bits, a single Bit address
must be assigned to each Input/Output bit in a ladder logic rung (by an Output
Energize Coil).

Allen–Bradley Micrologix (1000 and 1500): Data Addressing
Bit level addressing is available for all file types below.
The only usable 16 bit word addresses are those in the Bit and Integer data files,
for example N7:0 or B9:3. These word addresses may be used for Numerical
Displays, Text Displays or for any other part requiring a word address. Status,
Integer and Binary files are defined with e for element instead of w, for word. But
for these files, e is actually a 16 bit word!

Allen–Bradley Data Files

File Type File Element Range Element Value Bit RangeFile Type
file (f)

File
Number

Element Range
element (e), word (w)

Element Value
Range

Bit Range
bit (b)

Status (Sf:e/b) 2 0–255 –32768 to 32767 0–15

Binary (Bf:e/b or Bf/b) 3, 9–255 0–255 –32768 to 32767 0–15

Timer (Tf:e.w/b) 4, 9–255 e: 0–255, w: 0–2 * –32768 to 32767 0–15 *

Counter (Cf:e.w/b) 5, 9–255 e: 0–255, w: 0–2 * –32768 to 32767 0–15 *

Control (Rf:e.w/b) 6, 9–255 e: 0–255, w: 0–2 * –32768 to 32767 0–15 *

Integer (Nf:e/b) 7, 9–255 0–255 –32768 to 32767 0–15

* See the Rockwell (or Allen–Bradley) manual for details of elements/words.

In order to indicate the status of, or write to, Input/Output bits, a single Bit address
must be assigned to each Input/Output bit in a ladder logic rung (by an Output
Energize Coil).

Bit Addresses
Word Addresses

Input and Output
Bits

Bit Addresses
Word Addresses

Input and Output
Bits
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Allen–Bradley PLCs:  Communications
The dialogs below are provided as a starting point for communication
troubleshooting. If you are having communication problems between the PC and
PLC, check the Controller Properties to make sure the Driver is the same as that
which RSLinx (or WINTelligent Linx) is set for.  If you are having communication
problems between the PLC and the DirectTouch panel, double-check the setup
steps on the previous pages for both the PLC and the panel.
The Controller Properties for both Micrologix  and SLC models is shown below.

Connecting to PLCs running the Modbus protocol
The DirectTouch panel now supports the Standard Modbus protocol. The Standard
Modbus protocol is also known as Modbus RTU. Please refer to your PLC User
Manual for details on the Modbus protocol and data ranges.

Controller
Properties

Modbus
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Connecting to the WinPLC
The following products and versions are required to connect a WinPLC to the
DirectTouch panel:

� WinPLC, Revision Code 4D or later
� Think & Do Software, V5.2 or higher
� ScreenCreator, V1.14 or higher

Press the upper left and lower right corners of the panel screen to
bring up the System Mode Main Menu screen below and press System Setup.

System Mode Main Menu

System Setup

System Check

Up/Download

User Mode

System Setup

RS232C
Setup

RS422/485
Setup

Host Command
Setup

Clock
Setup

Pushbutton
Setup

Display
Control

Display
Direction

Error Disp
Setup

Printer
Setup

RAM File

End

 Setup

Requirements

DirectTouch Setup
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NOTE: Initially, the panel is set to Not Used on both RS232C and RS422/485.

Press the RS232C Setup button first, then the Connected Device
button and select PLC (and ENT).  Press enter (ENT) again for the change to
take effect.
Make sure at this point to set the Communication Rate (Baud rate) and Parity
Check the same as that of the WinPLC.

Connected
Device

9600Communication
Rate

Parity Check

ESC

EVEN

1

8

Stop Bit

Data Length

bps
RS232C

RS422/485

Not Used

ENTDetail

PLC

RS232C

Not Used

RS–422
(CH3)

RS–232
(CH1)

During configuration/programming, we found this setup very helpful for the WinPLC:

DirectTouch panel

WinPLC in a
DL205 Base

Programming Cable
DP–PGMCBL

FA–UNICON or FA–
ISONET (RS–232 to
RS–422 converter)

Ethernet 10BaseT
Cable

Cable for
RS–422 (Bel-
den 9729 or
equal)

NOTE: You do not have to use the setup shown above. You can program the panel
and WinPLC separately and connect them together by RS–232 (Cable DP–2CBL) if
you choose.

RS–232C Setup
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Select Project > New... to create
your ScreenCreator project for a
WinPLC application.
Type in the Project Name and
select the panel model.

Click on the Connect to tab, as
shown on the right and select
Think & Do (MODBUS) as the
PLC.

If you already have a Think & Do
Project for the WinPLC, you can
select the Map File (from your
Think & Do project) by clicking
the Select... button.
This will import all of the
Tagnames into the project.

Creating a New
Project for a
WinPLC
Application
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See the Think & Do Software website (www.thinkanddo.com) for details on Think &
Do Software (Version 5.2 or higher), which is required to connect the WinPLC to the
DirectTouch panel.

Launch the Think & Do I/O View
and open the project CEHeat, as
shown.

Set the Access Type to Modbus
Slave.

Be sure to set the other Port
Settings to match those of the
DirectTouch panel (Baud Rate,
etc.)

Additional information about the
WinPLC can be found in the
Think & Do Software online Help
system.

The following is only a quick
reference for a WinPLC Think &
Do  project. Refer to the WinPLC
Installation and Operation
Manual (H2–WPLC–M) for
details.

The Think &
Do/WinPLC Project
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DirectTouch Panel
Regardless of which PLC is used with the panel, the programming cable
(DP–PGMCBL) is used to connect the panel to the personal computer.
Connect the programming cable (DP–PGMCBL) between the serial port (CH1) of
the DirectTouch panel and the serial port of the personal computer.The figure below
shows programming cable connectors and wiring specifications. Wiring diagrams
refer to the communication ports.

���������

�	
���� DirectTouch  Panel

5= 0V
4= DTR
3= Dout
2= Din
1= DCD

9= not used
8= CTS
7= RTS
6= DSR

DB9 DB9

3 3
48
57

5
1

9

Female Male

7

2 2

5 = CTS
4 = RTS
3 = Din
2 = Dout
1 = Ground

9 = not used
8 = not used
7 = 0V
6 = not used

1

9

DB9
Female

DB9
Male

1

shell shell

4

PLCPanel

DB9 RJ–12

3 4
4
5
7

Phone jackMale

6

2 3

DP–2CBL

PLCPanel

DB9 VGA 15

3 2
4
5
7

15–pin VGA MaleMale

7

2 3

DP–2CBL–1

4
5

PLCPanel

DB9 DB15

3 2

4
5

15–pin Dsub MaleMale

2 3

DP–4CBL

1
7

7 4, 13, 14, 15

PLCPanel

DB9 25–pin

3 2
4
5
7

25–pin MaleMale

7

2 3

DP–3CBL–2

4
5

PLCPanel

DB9 DB9

3 3

4

9–pin FemaleMale

2 2

DP–ABCBL–1

7
8

7 5

5

8

PLCPanel

DB9 Mini DIN

3 7

4

8–pin MaleMale

2 4

DP–ABCBL–2

3
6

7 2

5

The Programming
Cable
(DP–PGMCBL)

DirectTouch Cable
Pin-outs
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DirectTouch Panel Specifications

Specification Rating

Display Type Backlit LCD

Display Colors 16/256 (Color)/Blue & Gray (Mono

Display Size 5.7”diagonal

Resolution 320Hx240W, 16x12 cells

Screen Type Resistive

Number of screens 1024 (limited by memory)

Screen Data Memory 1 MB

System Memory 512 KB

Alarms/Faults Yes

Clock/Calendar Yes, both internal and PLC (external)

Password  Protection Yes

PLCs Supported DL 105/205/305/405 
A–B SLC 5/03 & 5/04

Warranty 12 Months

Storage Temperature –10°C to 60°C (14°F to 140°F)

Operating Temperature 0° to 50°C (32°F to 122°F)

Humidity 15% to 85% relative humidity (Non–condensing)

Vibration JIS–C0911 (5 to 55 Hz, 2G)

Shock JIS–C0912 (10G 12mS or less)

Voltage 20.5 to 28.8 VDC

Power 14W max (Mono), 24W max (Color)

Inrush Current 2.8 A

Humidity 15% to 85% relative humidity (Non–condensing)

Vibration JIS–C0911 (5 to 55 Hz, 2G)

Communications 1–RS-232C  and 1–RS-422 (only on some DirectLOGIC PLCs)

Maximum Distance 50 feet (RS-232C) and 4000 feet (RS-422)

Noise immunity (Power) 1000Vpp, pulse width 100 to 1000 ns in common mode

Noise immunity (Comm) 500Vpp, pulse width 100 to 1000 ns in capacity coupling

Withstand Voltage 1.0kVDC (1 min.) from Power Input to FG

NEMA Rating IEC IP65F (Compares to NEMA 4)

Agency Approval Pending UL, CUL and CE

Atmosphere No corrosive gases
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DP–C320
S/N 020023

D
C

 24V
 

+  –  F
G

R
S

232C

FG
SG
RD–

SD–

RD+

SD+

(188 mm)
7.402”

7.677”
(195mm)

5.630”
5.906”

(143mm)
(150 mm)

0.275”
7.0mm)

1.85”
(47.0mm)

Back

Top

Cable Connector

O
verall D

im
ension

Overall Dimension

Side

Cable Connector

(188.5 �0.3mm)

7.421�0.012”

5.65�0.012”

(143.5 �0.3mm)

Panel Cut–out
Dimensions

1.575”
(40.0mm)

2.25”
(57.1mm)

0.275”
(7.0mm)

DirectTouch Panel Dimensions and Installation
It is important to understand the installation requirements for our operator interfaces. Sometimes the size
alone can dictate your choice of unit. This is especially true with respect to the depth of the unit. Please make
sure you consider the space required for proper access to cables, power wiring, etc. Also, you may need to
consider the environmental requirements, agency approvals, etc. for your particular application.

2.25”
(57.1mm)

NOTE: For monochrome panels (DP–M320 or DP–M321), the System Setup >
Display Control > Brightness Setup must be set to the 5th from left (default), or
higher, in order to display properly.
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Error Codes
B–2

ScreenCreator Errors and Warnings
This section explains errors and warnings in ScreenCreator. Error messages begin with E, and warning
messages begin with W.

An Error occurs in ScreenCreator when an incorrect function or command is attempted.

A Warning message is issued to alert the user that the attempted command is invalid or that an
unpredictable result may occur. Follow any instructions to proceed.

ScreenCreator Errors
E000: Not enough memory.
<Cause> Memory space is not enough to operate ScreenCreator or an error exists in Windows.
<Action> Exit ScreenCreator and restart Windows. If no error occurs after restarting Windows, then

start ScreenCreator again.

E001: Windows system abnormality.
<Cause> An error may exist in Windows or a ScreenCreator file (*.EXE or *.DLL).
<Action> Exit ScreenCreator and restart Windows. If no error occurs after restarting Windows, then

start Screen Creator again. If an error does occur in Windows, re–install ScreenCreator.

E002: File cannot be opened.
<Cause> The file cannot be open because it is corrupt.
<Action> To investigate the cause, copy the file to a file folder. Then delete the original file and try using

the copy.

E003: File cannot be read.
<Cause> The file cannot be read since (1) a wrong file or path is specified, or (2) another application

has opened the file. 
<Action> 1.  Make sure the file and path are correct.

2.   Make sure that the file is not opened from another application.

E004: File cannot be written to.
<Cause> The file cannot be written to since (1) a wrong file or path is specified or (2) another 

application has opened the file. 
<Action> 1.   Make sure that the file and path are correct.

2.   Make sure that the file is not opened from another application.
3.   Make sure that the floppy disk is inserted in the drive.
4.   Make sure that the floppy disk is not write–protected.

E005: File cannot be closed.
<Cause> The file cannot be written since (1) a wrong file or drive name is specified or (2) another 

application has opened the file. 
<Action> 1.   Make sure that the file and path are correct.

2.   Make sure that the file is not opened from another application.
3.   Make sure that the floppy disk is inserted in the drive.
4.   Make sure that the floppy disk is not write–protected.
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E006: Contents of file invalid.
<Cause> Contents of the specified file are invalid.
<Action> 1.   Make sure that the file and path are correct.

2.   Make sure that the file is not opened from another application.
3.   Make sure that the floppy disk is inserted in the drive.
4.   Make sure that the floppy disk is not write–protected.

E007: Folder cannot be created.
<Cause> The folder cannot be created since: (1) the folder name contains an invalid character that

Windows cannot use, or (2) the drive capacity is too small. 
<Action> 1.   Check the drive capacity.

2.   Make sure that the parent folder exists.
3.   Make sure that the folder ScreenCreator uses has not been deleted.

E008: Saving file failed.
<Cause> Saving the file failed since (1) memory space is insufficient, (2) the file or folder name is 

invalid, or (3) free disk space is insufficient.
<Action> When this message appears, the file may remain on the disk. In this case, delete it.

E009: Saving data failed.
<Cause> Saving data in operation failed since (1) memory space is insufficient, or (2) the parent 

window no longer exists.
<Action> When this message appears, data (component and program) linked with the parent window

may remain. In this case, delete it.

E010: Function of video driver insufficient.
<Cause> The video driver in Windows cannot work correctly with ScreenCreator. (What is displayed

may not appear correctly.)
<Action> It is necessary to change the video driver (hardware or software) installed in your computer.

E011: Copying file failed.
<Cause> An invalid folder or file name was specified.
<Action> Make sure that the file and folder names on the source and destination are correct.

1.   The free disk space is sufficient.
2.   The destination file is not write–protected.

E012: Layout of toolbar invalid.
<Cause> The position information of the tool bar recorded in the initial file (INI file) is invalid.
<Action> When this message appears, the tool bar position is returned to the default position.

E013: Invalid internal data.
<Cause> An error exists in the Windows memory or control that ScreenCreator uses.
<Action> Exit ScreenCreator and restart Windows. If no error occurs after restarting Windows, then

start Screen Creator again.

E014: Constructing library failed.
<Cause> Configuring a library file failed during ScreenCreator installation.
<Action> Exit ScreenCreator and reinstall.

E015: Cannot read/write/copy file.
<Cause> The file cannot be open because it is corrupt.
<Action> To investigate the cause, copy the file to a file folder. Then delete the original file and try using

the copy.
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E100: Reading initial file (PA.INI) failed.
<Cause> The initial file (PA.INI) in the SC folder is invalid. It cannot be read.
<Action> Copy the PA.INI file to another folder for investigation and delete it. Then restart Screen 

Creator 5.

E101: Reading entry file (ENTRY.INI) failed.
<Cause> The entry file (ENTRY.INI) in the System folder is invalid. You cannot read it.
<Action> Copy the ENTRY.INI file to another folder for investigation and delete it. Then reinstall 

Screen Creator 5.

E102: Reading project file failed.
<Cause> The project file in the System folder is invalid. You cannot read it.
<Action> Copy the project file to another folder for investigation and delete it. Then select [Create]

in the menu and create the file.

E103: Panel model not selected.
<Cause> The panel model was not selected when the project was created.
<Action> Select a panel model to be used in the Project > Properties menu (Connect to tab).

E104: Icon initialization failed.
<Cause> The icon file (ICON***.BMP) in the System folder is invalid.
<Action> Copy all icon files to another folder. Then, reinstall (copy) them from the master disk.

E105: Project file invalid.
<Cause> The project file (*.PRO) in the System folder is invalid.
<Action> Copy the project file to another folder for investigation and delete it. Then select [Create]

in the menu and create the file.

E106: Registration file (*REG) invalid.
<Cause> The record file (*REG) in the project folder is invalid. 
<Action> Copy the record file to another folder for investigation and delete it. Then select [Record]

in the menu and record the file.

E107: Text file (*STR) invalid.
<Cause> Contents in the character string file (*.STR) in the project folder are invalid.
<Action> Copy the character string file to another folder for investigation and delete it. Then select

[Character string] in the menu to re–create it.
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E108: Library (*.PLB) file invalid.
<Cause> The library file (*.PLB) in the Lib folder is invalid.
<Action> You cannot continue processing if the library file is destroyed. Recover the library file by the

following procedure. 
<Recovery Procedure>

1. When the *.PLB file exists in the Lib folder
Use Memo Pad to open the file to verify that the file can be accessed normally.

[Accessible]: Copy the file to another place and delete the *.PLB file. After the deletion, restore it.
[Inaccessible]: Change the file attribute for accessing the file again. When being able to access the file, copy

the file to another place and delete the *.PLB file. If the file still is inaccessible, restart 
Windows and try the file access again. If it can be deleted, restore it. However, if it cannot
be deleted, initialize it.
2. When the *.PLB file does not exist in the Lib folder, perform the restore operation.

[Restore]: Change a name of the PL_ file in the LIB folder to *.PLB. After the name change, start 
ScreenCreator.

[Successful start]:   You may use it as it is, but part of the library is possibly destroyed. 
[Error occurrence]:   Delete the renamed *.PLB file and initialize the library.
[Initialization]: You cannot recover the library. Re–install ScreenCreator. When restarting ScreenCreator,

the library in the initial state is usable. Since added libraries are all lost, it is necessary for
repairing operation.

[Repair]: There are two ways for repairing a library.
1. You can repair the library on ScreenCreator. This method is safe in file integrity but it takes
long time for repairing. Select [Add a file from outside] in the library menu, and select a file
for adding it to the library in succession. In almost all cases, a file exists in the LIB folder and
a file name is equal to a library name. Thus the operation is not difficult and you can repeat
the file selection and addition.
2. You can access a file directly. This method is not safe in file integrity but it does not take
long time for repairing. Open the *.PLB, using Memo Pad. Then add library entries in 
accordance with the PLB file format. If you enter a wrong class number, file name, etc., an
error occurs again. In this case, you must start the operation again from scratch.

E109: Standard function file invalid.
<Cause> The standard function library file (GENERAL.FNC) in the Lib folder is invalid.
<Action> Copy the standard function file to another folder for investigation and reinstall 

ScreenCreator.

E110: User function file invalid.
<Cause> The user function library file (USER.FNC) in the Lib folder is invalid.
<Action> Copy the user function file to another folder for investigation and delete it for recreation of

functions.

E111: Bitmap Pad (BMP) file invalid. 
<Cause> The color–adjusting file for a bit map and screen is destroyed. 
<Action> Delete the color–adjusting file once and execute the [Bit map color adjusting] function again.

E200: Invalid input value.
<Cause> The entered value is invalid.
<Action> Reenter an appropriate value.

E201: Standard function cannot be saved.
<Cause> You cannot save the standard function again.
<Action> Re–name it as a user function, and then save.



A
pp

en
di

x 
C

E
rr

or
 C

od
es

A
pp

en
di

x 
B

E
rr

or
 C

od
es

Error Codes
B–6

E202: Text cannot be saved, exceeds the max.
<Cause> You cannot save the character string since the number of characters exceeds the limit.
<Action> Reduce the number of characters.

E203: Data or file of a part is invalid.
<Cause> Contents of a part are invalid.
<Action> Delete the selected part. If the part has already been arranged on the screen, delete it from

the screen.

E204: Saving data of part failed.
<Cause> Saving the component data cannot be performed.
<Action> This part data cannot be arranged on the screen. Delete it before placing the part on the 

screen.

E205: Program cannot be saved.
<Cause> Saving the program cannot be performed.
<Action> Write the program again.

E206: Cannot be created or saved, exceeds the max.
<Cause> Creating or saving cannot be performed since the number of input items exceeds the limit.
<Action> Reduce the number of input items.

E207: Compilation Error.
<Cause> A compile error exists in a screen or part program. 
<Action> Correct the screen or component program error. You can reference details of the error, using

the compile error in the reference bar.

E208: Clipboard cannot be used.
<Cause> The clipboard cannot be used due to an error in Windows.
<Action> Exit ScreenCreator and restart Windows. If the same error occurs after the restart, reinstall

Windows.

E209: Invalid data in Clipboard.
<Cause> Data in the clipboard is invalid due to an error in Windows.
<Action> Copy or paste data on the clipboard. If an error occurs again, restart Windows. If the same

error still occurs after restarting Windows, re–install Windows.

E210: Undo cannot be executed.
<Cause> The Undo function cannot be executed since previous operation caused an error.
<Action> Try another operation and execute the Undo function. If the error occurs still, restart 

Windows and ScreenCreator.

E211: Undo failed.
<Cause> Executing the Undo function failed since previous operation caused an error.
<Action> Try another operation and execute the Undo function. If the error occurs still, restart 

Windows and ScreenCreator.

E212: Redo cannot be executed.
<Cause> The Redo function cannot be executed since previous operation caused an error.
<Action> Try another operation and execute the Redo function. If the error occurs still, restart 

Windows and ScreenCreator.
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E213: Redo failed.
<Cause> Executing the Redo function failed since previous operation caused an error.
<Action> Try another operation and execute the Redo function. If the error occurs still, restart 

Windows and ScreenCreator.

E214: Creating or Editing failed.
<Cause> Executing the Create or Edit function.
<Action> Exit ScreenCreator and restart Windows. If this error still occurs, delete and recreate it.

E215: The object is too large for the area.
<Cause> The part, control, texture, or bit map is too large for the area it is being placed in. The 

maximum size for any object is 320 x 240 pixels.
<Action> Open the object from the [Open] command in the library menu, make the background 

smaller and reduce the area with the change property function for rearranging the object.
Note: Bitmaps cannot be resized within ScreenCreator. Use a Paint utility in Windows to 
resize bitmaps.

E216: Not every member of the group is selected.
<Cause> One or more of the grouped parts is not selected.
<Action> When you select a group, select all individual parts in the group.

E217: A member of the group is being edited.
<Cause> A group being edited cannot be cut or deleted.
<Action> When you want to cut or delete a group, deselect it or close the sub–window in editing. Then

cut or delete it.

E218: Cannot group–– exceeds the maximum.
<Cause> The number of grouped parts exceeds the limit.
<Action> If the grouping is required, delete another part from the screen.

E219: No component is selected.
<Cause> Editing cannot be done before selecting the component to edit.
<Action> Select a component before editing.

E220: Cannot group.
<Cause> One or more of the parts being grouped already belongs to a group.
<Action> Select only ungrouped parts for the new group.

E221: Grouping components failed.
<Cause> Grouping components failed.
<Action> Exit ScreenCreator and restart Windows. If the error still occurs after restarting Windows,

then reinstall Windows.

E222: No grouped component is selected.
<Cause> This editing function cannot be executed without a group being selected.
<Action> Select a group before trying this editing function.

E223: No Text was entered.
<Cause> A text object must contain text.
<Action> Enter a text in the dialog box. If the attribute dialog box is not displayed, click on the [Set 

Attribute] button on the drawing tool bar.

E224: Bitmap file invalid.
<Cause> The bit map file in the library is corrupt or its format is invalid.
<Action> Open the file in Paint, save it. If it cannot be opened with Paint, delete it.
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E225: No Bitmap name was entered.
<Cause> A bit map is about to be created on the screen before entering a bit map name in the attribute

dialog box.
<Action> Enter a bit map name in the dialog box. If the attribute dialog box is not displayed, click on

the [Current attribute] button on the drawing tool bar.

E226: Texture file invalid.
<Cause> The texture file in the library is corrupt or the file format is invalid.
<Action> Open the texture with the library menu. If the file can be opened, save it. If it cannot be 

opened, delete it.

E227: No Texture name was entered.
<Cause> A texture is about to be created on the screen before entering a texture name in the attribute

dialog box.
<Action> Enter a texture name in the dialog box. If the attribute dialog box is not displayed, click on

the [Set Attribute] button on the drawing tool bar.

E228: Pushbuttons/Switches overlap.
<Cause> Two pushbuttons/switches overlap on the screen.
<Action> No switch control can be overlap with another. Place on the screen so they do not overlap.

E229: Objects cannot be deleted while being editing.
<Cause> Deletion is being attempted on a component whose contents are being edited.
<Action> You cannot delete a component whose contents are being edited. Close the editing 

sub–window then delete it.

E230: Objects cannot be edited while contents are being edited.
<Cause> A component is about to be changed while its contents are being edited.
<Action> You cannot edit a component whose contents are being edited. Close the editing 

sub–window then make the change.

E231: No parent window.
<Cause> The parent window for the window in editing is closed because of its error.
<Action> Since the parent window is closed, the editing window is ineffective. Close the editing 

window.

E232: The specified item does not exist in the library.
<Cause> The specified object (texture or bit map) does not exist in the library.
<Action> The drawn object has been deleted from the library. Since the object on the screen is in 

effective, delete it.

E233: This standard function name has already been used.
<Cause> The name of the created user function is the same as that of the already existing standard

function. 
<Action> Re-name and save it.

E234: Function Syntax Error.
<Cause> A syntax error exists in the created function.
<Action> If saved as it is, the function cannot be used in a program. Correct the error of the function

before saving it.

E235: Component file invalid.
<Cause> The component file in the library is corrupt or the file format is invalid.
<Action> You cannot use the component. Delete it from the library.
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E236: Screen file invalid.
<Cause> The screen file is corrupt or the file format is invalid.
<Action> You cannot use the screen file. Delete it.

E237: Creating a documentation file failed.
<Cause> The documentation file cannot be created.
<Action> 1.   Check the specified name of a file or folder.

2.   Check the disk free space.
3.   Check the memory capacity.

E238: The timer cannot be used.
<Cause> The timer function Windows offers cannot be used.
<Action> Other applications use all timers, or an error exists in Windows. Terminate the other 

applications or restart Windows.

E239: The ScreenCreator application (PA.exe) file cannot be started.
<Cause> The execution file cannot be started because (1) memory space is insufficient, (2) the 

execution file (PA.EXE) is corrupt or does not exist, or (3) an error exists in Windows.
<Action> Restart Windows and start ScreenCreator. If an error still occurs, reinstall ScreenCreator.

E240: Saving to the library failed.
<Cause> Storing to the library cannot be performed since (1) memory space is insufficient or (2) an

error exists in Windows.
<Action> Restart Windows and try again.

E241: This has already been registered.
<Cause> No screen can be duplicated.
<Action> Use another registration number or name.

E242: Project copying failed.
<Cause> Copying the project cannot be performed since the destination folder is invalid or the disk

capacity is insufficient. 
<Action> 1.   Make sure that the destination folder is correct.

2.   Make sure that the disk capacity is sufficient.

E243: Fixed parts overlap.
<Cause> Parts with Normal access overlap.
<Action> Move the parts or make them Closed and Selectable.

E244: Pushbutton/Switch controls overlap.
<Cause> Pushbutton/Switch controls overlap.
<Action> Arrange the parts so they do not overlap.

E245: Cannot find file in the library.
<Cause> The library has the specified name but the corresponding file is not found. This may occur

when a file is deleted or re–named after being saved in the library.
<Action> Delete the file from the library since it cannot be used.

E246: The Initial Screen (Reg. No. 1) is not registered.
<Cause> No screen has been registered as the initial screen of the project.
<Action> A screen must be registered as the initial screen of the project.

E247: Cannot read Address list file.
<Cause> Screen data must have been Built (using Download/Build > Build) before editing Addresses.
<Action> Build Screen data (using Download/Build > Build). Note that the number of items to be edited

is up to 8000.
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E248: Editing Address failed.
<Cause> During execution of address editing, an error occurred.
<Action> Refer to the actual error.

E249: No project has been Uploaded.
<Cause> A project must be uploaded first before it can be restored.
<Action> Upload a project from the panel with the project [Upload] function.

E250: Upload Edit was not Enabled.
<Cause> The project file has not been transferred to the panel.
<Action> You must transfer the project file (by selecting Upload Edit Enable) before downloading.

E251: The uploaded project is destroyed.
<Cause> The Uploaded Project is corrupt
<Action> Make sure the disk system is working correctly and that there is enough space. Then upload

again. If the same error occurs again, the project cannot be uploaded.

ScreenCreator Warnings

W000: Editing already.
<Cause> You have selected a component which is already being edited.
<Action> The editing window will appear allowing further editing.

W001: The number of colors is invalid.
<Cause> The number of colors specified for a screen, component, or texture to be open does not 

agree with that of the current project.
<Action> When the item is opened, its color setting is changed to that of the project. If you do not like

the resulting color, change it.

W002: Select the Class to be saved in.
<Cause> The class to which the item will belong has not been selected when being saved to a library.
<Action> Select a class in the dialog for saving the item.

W003: Cannot Undo.
<Cause> The Undo function cannot be executed since a component being edited in the sub–window

is affected by the function.
<Action> Close the editing contents window and try again.

W004: Background cannot be saved.
<Cause> No background can be saved on the global screen.
<Action> Only parts may be placed on the global screen.

W005: Nothing is selected.
<Cause> Nothing is selected for the command or function.
<Action> Select an item first, then try again.

W006: Cannot edit grouped part(s).
<Cause> Grouped parts cannot be edited alone.
<Action> Arrange them on the screen. Then edit them on the screen individually.

W007: Global Screen parts warning.
<Cause> A part with Normal access is arranged on the global screen.
<Action> The access of any part on the global screen must be Selectable.
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W008: Select only one component.
<Cause> More than one component is selected for the operation.
<Action> Select only one component.

W009: Part(s) out of Area.
<Cause> One or more component of the arranged part is outside the area.
<Action> Any component outside the area will not be saved. Place it within the area before saving.

W010: Control(s) out of Area.
<Cause> A control of the created part is outside the area.
<Action> Any control outside the area will not be saved. Place it within the area before saving.

W011: Fixed parts cannot overlap.
<Cause> Parts with Normal access are overlapping.
<Action> Place them on the screen so they do not overlap.

W012: Pushbutton/Switch controls cannot overlap.
<Cause> Switch controls are overlapping.
<Action> Place them on the screen so they do not overlap.

W013: Selected class cannot be deleted.
<Cause> The higher class (having sub-classes) cannot be deleted.
<Action> Delete the sub-class(es) first. Then delete the higher one.

W014: No library being used.
<Cause> No list file exists for the library in use.
<Action> This file is automatically created after downloading.

W015: Grouped parts must stay in grouped area.
<Cause> One or more member of the group is outside the area.
<Action> Rearrange the parts in group area then save.

W016: Address editing cannot be started.
<Cause> You cannot edit addresses while any screen is open.
<Action> All screens must be closed before editing addresses. If any Addresses have been added,

run Project/Download/Build to re–compile the screens.

W017: The Global screen cannot be registered.
<Cause> A global screen has been registered.
<Action> Do not register the global screen.

W018: The control area cannot be reduced since the control will be outside the control area.
<Cause> When a numeric indicator, character indicator, or clock indicator control exists in a part, the

part area cannot be smaller than the control size.
<Action> Adjust the control length for a numeric indicator, character indicator, or clock indicator before

reducing the part size.
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ScreenCreator Errors in Compiling and Building Screen Data
This section describes error and warning messages that appear during data creation in ScreenCreator.

ScreenCreator data is created in one of two ways. The first way is when an operation program (written in
K–Basic for a screen part) is saved. When Compile when saving screen is set under Options, the program
is compiled when the screen is saved. (Compiling involves checking the program syntax and translating
it into code that the panel can execute.) An error detected during compilation is explained in Errors in
Compilation.

The second way is when screen data is generated and operation programs are processed (during the Build
process). At this point, operation programs, that have not yet been compiled, are compiled. The error and
warning messages involve Errors in Creating Downloading Data, Warnings in Creating Downloading Data,
as well as Errors in Compilation.

The above errors and warnings appear on the Reference Bar in ScreenCreator.

When you want to see the details of an error or warning, select Compilation Error on the right of the
Reference Bar and click the Update button.

An error or warning message includes the name of a screen or part where it occurred. If the error is detected
in an operation program, its message also includes line number where it occurred. Notice that the error is
detected in the line, but its cause does not always exist on that line.

Compiling Errors

EC000: Memory space is insufficient.
<Cause> Memory space is not enough to compile a program or an error exists in Windows.
<Action> Exit ScreenCreator and restart Windows. If no error occurs after restarting Windows, then

start ScreenCreator again.

EC001: Special Error. Contact Technical Support.
<Cause> An error is detected, which does not belong to any errors described in this section.
<Action> Contact technical support at Automationdirect (1–770–844–4200).

EC002: The character string is too long.
<Cause> The character string is too long.
<Action> Make sure the character string is no longer than 80 bytes. One alphanumeric character is

one byte. But one two–byte character consists of two bytes.

EC003: Error in character string constant (in double quotes).
<Cause> An error exists in character string constant.
<Action> Eliminate the error. A character string constant is enclosed with double quotes (”).

EC004: Unable to allocate memory. Contact Technical Support.
<Cause> Memory space cannot be allocated.
<Action> Contact technical support at Automationdirect (1–770–844–4200).

EC005: Unable to allocate memory in heap. Contact Tech. Support.
<Cause> Memory space cannot be allocated in the heap area.
<Action> Contact technical support at Automationdirect (1–770–844–4200).
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EC006: K–BASIC syntax error.
<Cause> An error exists in K–Basic code.
<Action> The error violates the K–Basic syntax. Check several lines around the line where the error

was detected.

EC007: K–BASIC syntax error.
<Cause> An error exists in K–Basic code.
<Action> The error violates the K–Basic syntax. Check several lines around the line where the error

was detected.

EC008: Name too long. Limit is 20 bytes.
<Cause> The name is too long.
<Action> A variable or function name must be specified within 20 bytes.

EC009: An error exists in a screen, component or control name.
<Cause> An error exists in screen, component or control name.
<Action> Specify a correct screen, component, or control name. The screen, component, and control

are separated by a period (.).

EC010: Undeclared local variable. Declare with LOCAL.
<Cause> The local variable is not declared.
<Action> Before using a local variable, be sure to declare it with LOCAL.

EC011: Already declared as a global variable.
<Cause> The global variable has already been declared in the program.
<Action> Declaration of a global variable must be only once in a program.

EC012: Already declared as a backup variable.
<Cause> The variable name has already been used as a backup variable.
<Action> Change the variable name.

EC013: Already declared as a static variable.
<Cause> The variable declared as a static variable is about to be declared as another type.
<Action> Change the variable name.

EC014: Sign conversion, + or –, only applies to numbers.
<Cause> Sign conversion (+ or –) is being applied to an item other than a numeric constant or numeric

variable.
<Action> Apply the sign conversion to only a numeric constant or numeric variable.

EC015: Operation can not be done for operands of different type.
<Cause> Operation with different types is not allowed.
<Action> Correct the operation with the same type (addition, subtraction, substitution, etc.).

EC016: Constant used before CONST declaration.
<Cause> Constant declaration is used before CONST declaration.
<Action> Perform CONST declaration first, then use the constant declared.

EC017: The CONST declaration has already be made.
<Cause> The same CONST declaration appears more than once.
<Action> Delete any duplicate CONST declarations.

EC018: Divide by zero occurred.
<Cause> Divide by zero occurred.
<Action> Delete the zero divisor.



A
pp

en
di

x 
C

E
rr

or
 C

od
es

A
pp

en
di

x 
B

E
rr

or
 C

od
es

Error Codes
B–14

EC019: The dimensions are different from declaration.
<Cause> The number of variable dimensions in K–Basic is not equal to that of the declaration.
<Action> Change the variable declaration.

EC020: Invalid array declaration.
<Cause> The number of dimensions is not a numeric for declaring an array variable.
<Action> Declare the number of dimensions for an array variable with a numeric value.

EC021: Invalid size definition of character string type variable.
<Cause> The character string length is not numeric or the type specifier of the variable is not $.
<Action> Specify a correct character string length and type specifier.

EC022: Invalid variable initialization.
<Cause> An error exists in initializing the variable 
<Action> Set initializing data as many as elements for array variables.

EC023: Initialized character string too long.
<Cause> The initializing character string is too long.
<Action> Specify initializing data within the length of the character string in the character string 

variable.

EC024: Invalid FIELD declaration.
<Cause> The description of field declaration violates the FIELD statement syntax.
<Action> Declare it correctly.

EC025: A local variable with the same name has already been declared.
<Cause> The same local variable name has already been declared. 
<Action> Change the local variable name.

EC026: A different type local variable with the same name has already been declared.
<Cause> Another type variable is declared with the same name.
<Action> Change the variable name.

EC027: AUTO variable can only be declared in FUNCTION.
<Cause> An AUTO variable can be declared only in the FUNCTION statement.
<Action> Use the LOCAL declaration instead of the AUTO variable declaration.

EC028: LOCAL and AUTO variables can not be declared in FIELD.
<Cause> A local or AUTO variable cannot be declared in the FIELD statement.
<Action> Use a GLOBAL, STATIC, or BACKUP variable in the FIELD declaration.

EC029: Variable initialization cannot be declared in a FUNCTION or subroutine.  
<Cause> Variable initialization cannot be declared in the FUNCTION statement or a subroutine.  
<Action> Remove initializing variables other than an AUTO variable from the FUNCTION statement

or a subroutine.

EC030: Local variables cannot be declared in a global screen or library function. 
<Cause> A local variable cannot be declared in a global screen or library function. 
<Action> Cancel the local variable declaration. In a global screen, use a GLOBAL, STATIC, or 

BACKUP variable. In the library function, use the AUTO variable.

EC031: Argument violates LOCAL CHECK syntax.
<Cause> The description of the argument violates the LOCAL CHECK statement syntax.
<Action> Check the argument type.
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EC032: Invalid array–element declaration.
<Cause> A nonnumerical value is specified for a subscript when the array variable element is 

designated. 
<Action> Specify a numeric value to a subscript to access an array variable.

EC033: ID type variable cannot be initialized.
<Cause> A variable of ID type cannot be initialized.
<Action> Do not initialize a variable of ID type.

EC034: Invalid Address.
<Cause> The address is invalid for the type of PLC used.
<Action> Specify a correct address for the PLC.

EC035: Invalid Address declaration.
<Cause> An error exists in the address declaration.
<Action> Specify a correct address for the PLC.

EC036: Address is too long.
<Cause> The address name is too long
<Action> Specify a correct address.

EC037: This Address is write–protected.
<Cause> This address is write–protected.
<Action> Do not apply write operation to a write–protected address.

EC038: Address cannot be used because no PLC has been specified.
<Cause> Address cannot be used because no PLC has been specified.
<Action> Select the PLC by Project > Properties > Connect to.

EC039: The Address cannot be declared by CYCLIC2 declaration.
<Cause> CYCLIC2 declaration cannot be applied to the address.
<Action> Do not apply the CYCLIC2 declaration to the address.

EC040: Address out of range.
<Cause> The address is outside of the permitted range.
<Action> Specify a correct address.

EC041: PLC Address cannot be used in a library function.
<Cause> The PLC address cannot be used in a library function 
<Action> Do not use the address.

EC042: Memory table cannot be used because host has not been specified.
<Cause> No memory table can be used since no host is specified in the Project Properties Connect

to Tab.
<Action> Add the host in the Connect to Tab.

EC043: Memory table number in CYCLIC declaration exceeds 2048.
<Cause> The memory table number exceeds 2048 in the CYCLIC declaration.
<Action> Memory tables that you can use are from 0 to 2047.

EC044: Memory table number in CYCLIC declaration must be a constant integer.
<Cause> The memory table number must be a numeric constant in the memory table CYCLIC 

declaration.
<Action> Specify the memory table number as a constant integer.
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EC045: Memory table number must be an integer.
<Cause> The memory table number must be an integer.
<Action> Specify the memory table number with an integer.

EC046: Memory table continuous declaration must be done by a constant integer.
<Cause> The memory table continuous declaration must be made with an integer constant.
<Action> Specify the continuous declaration with an integer constant.

EC047: Memory table number must be constant in memory table ID comparison.
<Cause> The memory table number must be a constant in memory table ID comparison.
<Action> Specify a memory table number with an integer constant.

EC048: Syntax error in memory table declaration.
<Cause> An error exists in the memory table declaration.
<Action> Specify a correct memory table.

EC049: No Peripheral (Connect to) equipment has been specified.
<Cause> No peripheral equipment has been specified in the Project Properties Connect to Tab.
<Action> Specify the correct peripheral device in the Project Properties Connect to Tab.

EC050: Source of the library function does not exist.
<Cause> The library function source does not exist.
<Action> The library function you want to use cannot be found. Make sure that the library function 

exists.

EC051: Only one function block can be declared at a time.
<Cause> Two or more functions are being created at the same time.
<Action> Create one library function at a time.

EC052: The specified library function does not exist.
<Cause> The specified library function does not exist.
<Action> The library function you want to use cannot be found. Check that the library function exists.

EC053: Subroutines cannot be declared within a function block.
<Cause> No subroutine can be specified in a user–defined function block.
<Action> Delete the subroutine.

EC054: The INIT block has already been declared.
<Cause> Two or more INIT blocks are declared.
<Action> Declare only one INIT block.

EC055: The CONF block has already been declared.
<Cause> Two or more CONF blocks are declared.
<Action> Declare only one CONF block.

EC056: The EVNT block has already been declared.
<Cause> Two or more EVNT blocks are declared.
<Action> Declare only one EVNT block.

EC057: EVNT block cannot be specified in a global screen.
<Cause> An event block is specified in a global screen.
<Action> Delete the event block.

EC058: Invalid start and finish block declaration.
<Cause> The start block declaration does not correspond to the end block declaration.
<Action> Declare the start and end blocks correctly.
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EC059: A function with the same name has already been declared.
<Cause> The function declaration is duplicated.
<Action> Remove or change one of the function declarations.

EC060: The function has not been declared by DECLARE.
<Cause> The specified function is not declared.
<Action> Declare the function using DECLARE.

EC061: The function argument is different from what is declared. 
<Cause> The function argument is not the same as the one declared.
<Action> Declare the function correctly.

EC062: Function argument must be constant or variable.
<Cause> Only a constant or variable can be specified as an argument for a function.
<Action> Specify the function argument correctly.

EC063: The number of function arguments cannot exceed 20.
<Cause> The number of function arguments exceeds 20.
<Action> Reduce the number of arguments to 20 or less.

EC064: EXIT FUNCTION must be declared in a function block.
<Cause> EXIT FUNCTION is declared in another way.
<Action> Do not use EXIT FUNCTION outside of the function block.

EC065: A name declared as a function is being used as a variable.
<Cause> A function cannot be used as a variable.
<Action> Change the variable or function name.

EC066: Function cannot be declared with this name.
<Cause> An error exists in the function name in the DECLARE declaration.
<Action> Specify the function name correctly.

EC067: A function with the same name already exists in the library.
<Cause> The created function exists already in the library.
<Action> Change the function name.

EC068: A subroutine or label with the same name already exists.
<Cause> The same name for the subroutine or label already exists.
<Action> Do not duplicate a subroutine or label name.

EC069: A logical Address must be an argument of OPENCOM.
<Cause> A logical address must be specified as an argument in the OPENCOM function.
<Action> Specify a logical address in an OPENCOM argument.

EC070: The argument of OPENCOM can only be HST, TKY or BCR.
<Cause> The OPENCOM argument is invalid.
<Action> Specify only TKY, BCR, or HST in the OPENCOM argument.

EC071: Invalid argument of function or command.
<Cause> An error exists in a function or command argument.
<Action> Specify the correct argument.

EC072: This PIO has already been declared.
<Cause> The same PIO is declared two or more times.
<Action> Declare the PIO only once.



A
pp

en
di

x 
C

E
rr

or
 C

od
es

A
pp

en
di

x 
B

E
rr

or
 C

od
es

Error Codes
B–18

EC073: Invalid number of arguments.
<Cause> The number of function arguments is incorrect.
<Action> Specify correct arguments.

EC074: Argument cannot be Address.
<Cause> No address can be used for a function argument.
<Action> Specify a correct argument.

EC075: Argument is not a variable.
<Cause> A variable cannot be specified as a function argument.
<Action> Specify a correct argument.

EC076: Invalid argument type.
<Cause> The type of the function argument is incorrect.
<Action> Specify a correct argument.

EC077: Different type comparison in SELECT CASE statement.
<Cause> The comparison type of the SELECT statement does not agree with that of the CASE 

statement.
<Action> Specify a correct type in the CASE statement.

EC078: Error in FOR NEXT statement.
<Cause> The comparison type of the FOR statement does not agree with that of the NEXT statement.
<Action> Correct the error in the FOR...NEXT... statements.

EC079: No Address is specified in the control.
<Cause> An address must be specified in the control when a ADDCYC, ADDCYC2, or ADDCYCID

statement is used.
<Action> Check the program for an address specified when the statements above are used.

EC081: The character string type argument of a function must be a variable or constant.
<Cause> The character string type argument of a function must be a variable or constant. 
<Action> Make sure the argument is a variable or constant.

EC082: The target label of GOTO statement does not exist.
<Cause> The label for the program to “GOTO” does not exist. 
<Action> Add the label to the program.

A. Errors in Building Downloading Data (EL–––)

EL000: Component area exceeds the screen.
<Cause> A component is arranged outside the usable screen area.
<Action> Change the arranging position of the component.

EL001: An invalid control exists in Screen [–––] or Part [–––].
<Cause> The compiler cannot recognize a control. 

Screen or part data may be corrupt.
<Action> Delete the control used in the part and place a new control in the part.
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EL002: The code for data operation is invalid.
<Cause> An error exists in control data operation description.
<Action> Correct the control data operation description.

EL003: Creating was canceled due to an invalid drawing element.
<Cause> 1.   The compiler cannot recognize the drawn object.

2.   Screen or part data may be corrupt.
<Action> Delete the object and replace it with another.

EL004: Save Screen [–––] again.
<Cause> This error may be caused when a pattern is drawn on the global screen or a part with Normal

access is arranged on the global screen.
<Action> Save the global screen once more and run Build (Project>Download>Build).

EL005: Global Screen [–––] does not exist.
<Cause> The global screen does not exist.
<Action> Create the global screen specified with Project > Properties.

EL006: Screen [–––] does not exist.
<Cause> Registered screen data does not exist.
<Action> Correct data of the registered screen or Build a screen using Project>Download>Build.

EL007: Cannot open Screen [–––].
<Cause> 1.   An error occurred in your computer.

2.   Screen data may be corrupt.
<Action> 1.   Exit ScreenCreator and start it again.

2.   Make sure that the computer file system is healthy.

EL008: Failed to read Screen [–––].
<Cause> 1.   An error occurred in your computer.

2.   Screen data may be corrupt.
<Action> 1.   Exit ScreenCreator and start it again.

2.   Make sure that the computer file system is healthy.

EL009: Creating data for Screen [–––] failed.
<Cause> 1.   Free space in the project folder is too small.

2.   An error may have occurred in your computer.
<Action> Check the free disk space.

EL010: Control [–––] does not exist.
<Cause> The control referred to in the program does not exist.
<Action> Check the program and correct it on an as–needed basis.

EL020: The variable types are different between Screen [–––], Component [–––] and Screen
[–––], Component [–––].

<Cause> The declaration types of the global/backup variables are mismatching, which are used with
two or more positions.

<Action> Correct the program.

EL021: The variable types are different between Screen [–––], Component [–––] and the 
system function.

<Cause> The declaration types of the global/backup variables are mismatched, which are used in two
or more places.

<Action> Correct the program.
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EL022: Variables initialized twice. (Screen [–––], Component [–––] and Screen [–––], 
Component [–––])

<Cause> Initialization for the global/backup variables, shared by two or more programs, at the time
of declaration is performed in two or more places.

<Action> Correct the programs.

EL023: Function [–––] does not exist.
<Cause> This error may occur if a function is deleted or if a function name is changed after a screen

is created.
<Action> Create a function or delete the reference to the non–existing function.

EL024: Subroutine [–––] does not exist.
<Cause> The substance of the called subroutine does not exist.
<Action> Create a subroutine or delete the reference to the non–existing subroutine.

EL030: Texture [–––.TEX] does not exist.
<Cause> The texture used in the program or control does not exist.
<Action> 1.   Create the texture.

2.   Copy a texture and register it.

EL031: Texture [–––.TEX] is corrupt.
<Cause> The texture may be corrupt or unreadable.
<Action> Re–create the texture.

EL040: Bit map [–––.BMP] does not exist.
<Cause> The bit map used in the screen or texture does not exist.
<Action> 1.   Create a bit map.

2.   Copy a bit map and register it.

EL041: Bit map [–––.BMP] is corrupt.
<Cause> The bit map may be corrupt or unreadable.
<Action> Re–create the bit map.

EL050: The registered Text [–––] does not exist.
<Cause> The registered text used in the program does not exist.
<Action> 1.   Create the registered text.

2.   Copy the Text and register it.

EL060: Equipment (PLC) error : this PLC model is not supported.
<Cause> This compiler cannot generate data for the selected PLC.
<Action> Check the version of ScreenCreator.

EL061: Total addresses exceeds limit (16000/screen).
<Cause> A screen exists, which uses more than 16000 PLC addresses.
<Action> Lower the number of addresses used to 16000.

EL062: The number of continuous addresses exceeds the limit.
<Cause> The number of continuous addresses specified by the BREAD/BWRITE statement exceeds

the limit. The range depends on PLC type. 
<Action> Reduce the number of continuous addresses specified.

EL063: The number of addresses on the global screen exceeds the limit.
<Cause> The number of global screen addresses plus the sum of sampling devices exceeds 16383

(upper limit).
<Action> Reduce the number of addresses.
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EL064: Total addresses in communication [–––] exceeds limit.
<Cause> The sum of communication (read/write) addresses in local/global screens exceeds 49151

(upper limit).
<Action> Reduce the total number of addresses.

EL065: Total protocol number in transmission [–––] exceeds limit.
<Cause> The sum of communication (cyclic/event) protocols in local/global screens exceeds 64 KB.
<Action> Reduce the number of addresses used in screens.

EL070: User–defined file [–––] does not exist.
<Cause> The user–defined file created by ScreenCreator does not exist.
<Action> Restore original data created by ScreenCreator again.

EL071: The Peripheral Equipment information file does not exist.
<Cause> The connection equipment information file is not found.
<Action> Install ScreenCreator again.

EL080: The backup memory capacity exceeds 63 KB.
<Cause> The capacity of the backup memory exceeds that of the panel memory.
<Action> Change the operation program to reduce the amount of the backup memory. The amount

of  backup memory includes the allocated memory file capacity set by the panel and the 
upper limit is 63 KB. So, this error may still occur during downloading.

Warnings in Building Downloading Data (WL–––)

WL000: Screen [–––] is not recorded.
<Cause> The screen used in the program is not recorded.
<Action> Record the screen.

WL001: Component [–––] does not exist.
<Cause> The component used in the program is not found.
<Action> Arrange the component.

WL002: Texture [–––.TEX] has been changed.
<Cause> The size of the texture used in the Slider control was changed after screen data creation.
<Action> Go into [Edit contents] of the component using [Slider] and check the texture.

WL010: Function [–––] is used by a global function.
<Cause> The declared function is the same as that used in the screen program in a global screen.
<Action> Change the function name.

WL011: Subroutine [–––] is used by a global subroutine.
<Cause> The declared subroutine is the same as that used in the screen program in a global screen.
<Action> Change the subroutine name.

WL020: The system memory exceeds 512 KB. A system–RAM–insufficient error may occur.
<Cause> Used amount of the system memory approaches the limit of he panel memory. 
<Action> Download all screens. If the system RAM insufficient error does not occur, ignore the 

warning. If the error occurs, change the screen data or operation program to reduce the 
memory used.

WL021: The backup variable is handled as a global variable in this panel.
<Cause> No backup battery exists in a DP–320 panel. Thus a specified backup variable is interpreted

as a global variable.
<Action> Since the backup variable is handled as a global variable, the backup function is ignored.

The other functions are not affected.
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DirectTouch Panel Operation Errors
This section describes errors that may occur while using the panel.
If an error occurs during panel operation, its message appears on the panel screen through the ERRPTS
part, created automatically on the Global Screen. You can select one of two ways to display the error
message: one is on the full global screen and the other is at the bottom of the global screen. You specify
the error display setup on the panel by System Mode Main Menu > System Setup > Error Disp. Setup.

Errors displayed on the full screen display:

On the error indicator, the [Various error information] window displays such error information as an error
type, a four–character error code, screen number and part number. There is a brief explanation of the error
in the middle of the display.

Errors displayed at the bottom of the screen:

At the bottom of the screen, the panel displays the error type, a four–character error code, screen
registration number and component number. In some cases, there is a brief explanation of the error in the
middle of the display.

NOTE: Panel Operation Errors are shown at the bottom of the DirectTouch display
in this form:  “Message execution error:  4300
                             SID (  0)   PID (  2)”
The execution error is the error code, SID is the screen ID number (or registration
number), and PID is the part number (2 would be B002).

Errors that may occur are classified into the types listed in the following table. The error codes and their
explanations are presented in the next and following pages in the order of the codes.

DirectTouch Panel Operation Errors

ErrorError Type Description Message Error
Code

System Error This error is detected if an error oc-
curs in the main CPU operation.

Main CPU Error       1000

Serial Communication Error This error is detected during serial
communication.

Serial Commu-
nication Error

      2000

Downloading/Uploading Er-
ror

This error is detected during down-
loading/uploading operation.

Downloading/
Uploading Error

      3000

User Application Error This error is detected when process-
ing a message.

Message Exe-
cution Error

      4000

User Application Error This error is detected when execut-
ing an operation program.

Program Exe-
cution Error

      5000

User Application Error This error is detected when issuing a
large message.

Message Full       6000

User Application Error This error is detected when trouble
occurs in a peripheral device.

Warning       8000

System Error This error is detected if an error oc-
curs in the panel.

System Error       7000
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Other Panel Operation Errors:

DirectTouch Panel Operation Errors Cont...

Error
Code

Error Description & Action

7 Insufficient system RAM capacity The RAM used exceeds the system limit.
Check the used system memory capacity.

12 Invalid Clock Operation The clock IC (chip) is unstable. The backup
battery voltage may be low. If you are not us-
ing the internal clock, set the “clock operation
error mask” to 1 in the ERRPTS error display
on the Global Screen.

15 Battery voltage drop The panel backup voltage is low and must be
replaced. If you do not want to detect this er-
ror, set the “battery voltage drop error mask”
to 1 in the ERRPTS error display on the Glob-
al Screen.

Main CPU Errors

Error
Code

Error Description & Action

1001 Program execution at address 0 Check the versions of both ScreenCreator

1002 Bus error and the panel, and contact Technical Support

1003 Address error
at Automationdirect (1–770–844–4200).

1004 Illegal statement

1005 Zero divisor

1006 CHK statement

1007 TRAPV statement

1008 Illegal privilege

1009 Trace

1010 Line 1010 emulator

1011 Line 1111 emulator

1012 to
1063

Interrupt at main CPU
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Serial Communication Errors

Error
Code

Error Action

2000 to
2255

(CH1) Errors at the destination, in-
dicated by the last three digits of

the error code.

If the PLC is not connected, look for devices...

2300 to
2555

(CH2) Errors at the destination, in-
dicated by 300 plus the last three

digits of the error code.

2600 to
2855

(CH3) Errors at the destination, in-
dicated by 600 plus the last three

digits of the error code.

2901 (CH1) Parity Error Make sure the communication setup of the

2902 (CH1) Overrun Error panel is equal to that of the PLC (or other

2903 (CH1) Framing Error
equipment connected).

2904 (CH1) Receive data error Check the receiving data format, especially
for checksum.

2905 (CH1) Timeout error Check the following items:

Communication cables

PLC station number

Setting of timeout interval

Destination condition

Multi-link unit settings

2931 (CH2) Parity Error Same as CH1

2932 (CH2) Overrun Error

2933 (CH2) Framing Error

2934 (CH2) Receive data error

2935 (CH2) Timeout error

2961 (CH3) Parity Error Same as CH1

2962 (CH3) Overrun Error

2963 (CH3) Framing Error

2964 (CH3) Receive data error

2965 (CH3) Timeout error
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Downloading/Uploading Errors

Error
Code

Error Action

3361 Flush ROM erasing error (ROM1) Download again. If the error occurs again,

3362 Flush ROM erasing error (ROM2) contact Technical Support at Automation-

3364 Flush ROM erasing error (ROM3)
direct (1–770–844–4200).

6638 Flush ROM erasing error (ROM4)

6420 Downloading to EPROM–– Unavailable The panel cannot perform downloading.

6430 User area insufficient–– Unavailable Reduce the amount of data downloaded.

6431 No downloading data–– Unavailable No data to download.

3461 Flush ROM erasing error (0–15 blocks) Download again. If the error occurs again,

3462 Flush ROM erasing error (0–15 blocks) contact Technical Support at Automation-

3464 VPP drop error
direct (1–770–844–4200).

3468 Other flush ROM error

3481 The specified transfer rate is invalid. Check the versions of both ScreenCreator

3482 The specified number of transfer blocks is invalid. and the panel, and contact Technical Sup-

3483 The specified last data length is invalid.
port at Automationdirect
(1–770–844–4200).

3491 The specified transfer rate is invalid.

3671 Flush ROM write error (ROM1) Download again. If the error occurs again,

3672 Flush ROM write error (ROM2) contact Technical Support at Automation-

3674 Flush ROM write error (ROM3)
direct (1–770–844–4200).

3678 Flush ROM write error (ROM4)

3684 Invalid BID Check the versions of both ScreenCreator
and the panel, and contact Technical Sup-
port at Automationdirect
(1–770–844–4200).

3871 Flush ROM write error (ROM1) Download again. If the error occurs again,

3872 Flush ROM write error (ROM2) contact Technical Support at Automation-

3874 Flush ROM write error (ROM3)
direct (1–770–844–4200).

3878 Flush ROM write error (ROM4)
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Message Processing Errors

Error
Code

Error Action

4110 Message buffer file for serial transmission Check the screen or operation pro-

4200 A not–recorded screen was specified. gram that caused the error and

4201 A non–existing part was specified.
correct it.

4202 A non–existing indicator (switch) was specified.

4300 In the K–Basic JUMP statement, a screen that has
not been recorded is specified.

4310 In the K–Basic OPEN statement:
a non–existing component is specified.
a member in group components is specified.
an internal data error in the module occurs.

4500 A not–supported message was received. Check the versions of both

4510 Received message size error.
ScreenCreator and the panel, and
contact Technical Support at Au-

4520 Received message buffer overflow.
tomationdirect.com
(1–770–844–4200).

Errors caused by too many messages issued

Error
Code

Error Action

6001 K–Basic execution (RUN, JUMP, OPEN, SEND) The error code at the time an error

6002 Serial reception (CH1) is detected is not always associat-

6003 Serial reception (CH2)
ed with too many messages. The
error code of the last message is

6004 Serial reception (CH3) displayed. So check the current

6005 Parallel input
screen and operation program as
well as any address that frequently

6006 Switch input, K–Basic execution (SWWRITE)
well as any address that frequently
causes an error.

6007 System timer operation

6008 Alarm operation
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A
A–B, See Allen–Bradley

Access of a Part, 3–2

Alarm Displays, 6–30 through 6–35

Allen–Bradley (A–B) PLCs
Addressing, A–9
Connecting to, A–6
Data Files, A–9

Arc, 4–7

ASCII Text, 5–11
Displays for, 6–6

Attributes/Properties, 4–13

B
Background, Color, 3–14

Backlight, 6–38

Band, 5–30

Bar Graphs, 5–24

Bitmaps, 3–22, 4–9

Brightness, 6–37, A–17

Browse List, 3–12, 4–21

Building, 4–25

C
Cables, A–5

Programming, 2–2, A–15
RS–422 pig–tail, A–4

Chapters, 1–3

Circle, 4–8

Circle Control, 5–32

Clock Display Control, 5–15

Clock Parts, 6–27 through 6–29

Closed, 3–2

Color, 3–11, 3–14
ON/OFF, 3–14

Communication
with Allen–Bradley PLCs, A–6
with PLCDirect PLCs, A–2
with WinPLCs, A–11

Connecting, A–2

Control, 3–10
Definition, 5–2
Toolbar, 3–22, 3–23

Controls, 4–10
List of, 5–2

Copy, 4–12

Corner, 4–13

Custom Parts (see User Parts also), 3–5 to 3–11

Cut, 4–12

D
Debugging

Reference Bar, 3–21
Status Bar, 3–21

Decimal Place, 5–8

Deleting, 4–13
Screens, 4–4

Dimensions and Installation, A–17

DirectTouch Panel
Brightness Setting, A–17
Cables, A–5, A–15
Concept and Description, 1–4
Connecting to a PLC, A–2
Dimensions and Installation, A–17
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Error Codes, B–22
Specifications, A–9

Display
Backlight, 6–38
Brightness, 6–37, A–17
Tool, 4–20

Dots, 1–5

Downloading, 2–10, 4–25

Downloading/Uploading, Errors, B–25

Drawing, Toolbar, 3–22, 3–23

Drawing Objects, 3–23
Copying (Duplicating), 4–12

E
Editing Tools, 4–12

Ellipse, 4–8

Error Codes, B–2
Compiling and Building, B–12
Panel Error Codes, B–22

Error Displays, 6–30 through 6–35

Exit ScreenCreator, 4–5

F
Fault Screen Parts, 6–30 through 6–35

Figure (Texture) Display, 5–17

Figures, 3–23
Duplicating (Copying), 4–12

Fill, 4–8

Fill Color, 3–23, 4–8

Fixed/Fixed 2, 5–8

Float, 5–8

Free Control, 5–34

Frozen, 3–2

G
Global Screen, 2–11, 2–16, 3–2, 6–30

Graphics, 3–22

Grid Lines, 1–5, 4–20

Grid Options, 4–20

H
Help

Index, 4–27
Menu, 4–27

I
Images, 3–22

Installing, 1–6

Interlock Controls, 6–39

ISO 7000, 3–15

K
K–Basic, 3–10 to 3–11

Key Pads, 2–14, 6–18
Cannot Arrange on screen, 2–15

Keyboards, 2–14, 6–19
Cannot Arrange on screen, 2–15

L
Layout, 1–3

LCD, Backlight, 6–38

Library
External files (Parts, Textures, and Bitmaps), 4–18
Maintenance (Delete, Rename, etc.), 4–19
Menu, 4–15

Library Parts, 3–4
Adding to Library from Screen, 4–18
Creating New, 3–5, 3–7
New, 4–15
Open, 4–16

Library Textures
New, 4–15
Open, 4–16

Light Control, 5–42

Lights, 6–14
Changing ON/OFF Colors, 3–14

Line, 4–6
Continuous, 4–7

Selecting the Corner, 4–13

Line Graphs, 5–27

List, Components, 3–12
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Local Screens, 2–11, 2–16, 3–2

M
Menus, 4–2

Meter, Scale, 4–9

Meter Control, 5–39

Meters, Creating New, 3–7, 3–9

Micrologix, A–6

Mirror, 4–13, 4–14

Modbus, A–10, A–11

Move to Back/Front, 4–13

N
Normal, 3–2

Numbers
formatting and displaying, 5–8

Numerical Displays, 4–11, 5–7
Input Displays (Double Word), 6–4
Input Displays (Word), 6–2

Numerical Input, 2–12, 6–18

O
ON/OFF Colors, 3–14

Operation Parameter, 3–10, 3–11

Organization of this Manual, 1–3

P
Parallelogram, 4–8

Part
Background, 3–11
Controlling Access from another part, 6–36
Inside a Part, 3–10, 3–13
Program, 3–11
Toolbar, 3–22, 3–23

Parts
Access, 3–2
Class List, 2–5
Closing an Edited Part, 4–4
Control, 6–36
Components of, 3–10, 3–13
Creating New, 2–5, 4–11

Editing, 3–12, 4–4
Editing Contents of, 4–13
Library, 3–3, 3–4
Placing on Screen, 2–7
Properties, 2–6
Reference, 6–2
Saving, 4–4
Screen, 3–3
Selecting, 2–5
User, 3–3
Viewing, 3–12

Password Protection (by Screen Select), 6–22, 6–23

Paste, 4–12

PID, 6–40

Pie Charts, 5–32

Pipe Control, 5–45

PLC
Clocks and Calendars, 6–27 through 6–29
Connecting to, A–2

PLC Addresses, Edit Address, 4–26

Plot Control, 5–21

Polygons, 3–23, 4–10

Printing
Edited Part, 4–5
Project Files, 4–24
Screnn, 4–5

Program, 3–11
Screen, 4–14

Project
Backup/Restore, 4–26
Closing, 4–24
Copying, 4–26
Creating New, 2–3, 4–23
Definition, 3–2
Deleting, 4–27
Downloading, 2–10
Menu, 4–22
Opening, 4–23
Opening Multiple, 4–23
Properties, 4–23
Register, 3–15, 4–25
Tutorial, 2–2

Pushbutton/Switch
Adding the Part to a Screen, 2–5
Control Reference, 5–3
Creating a Control, 4–10
Settings, 2–6

Pushbuttons, Labeled (with Text), 3–5
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Q
Quick Start (Project Tutorial), 2–2

Quit ScreenCreator, 4–5

R
Rectangle, 4–7

Redo, 4–12

Reference Bar, 3–21

Refreshing the Screen, 4–13

Register, 3–15, 4–25

Registered Text, 3–16, 6–9

Registered Text Displays, 6–9

Rotate, 4–13

RS–232C, A–2

RS–422, A–2, A–4

RTU (Modbus), A–10

Ruler, 4–20

S
Scale, 4–9, 5–10, C–3

Create, Menu, 4–6

Edit, Menu, 4–11

Screen
Colors, 4–5
Menu, 4–2
Objects, 3–2
Parts, 3–2, 3–3
Properties, 4–5
Refresh, 4–13
Register, 3–15, 4–25

ScreenCreator
Error Codes and Warnings, B–2, B–12
Installing, 1–6
Quitting, 4–5
Requirements, 1–6
Starting, 2–3
Version Information, 4–27
Warnings, B–10

Screens
Closing, 4–3
Creating New, 2–4, 4–2
Deleting, 4–4
Global, 2–11, 2–16, 3–2

Local, 2–11, 2–16, 3–2
Opening, 4–2
Preview, 4–3
Register, 3–15, 4–25
Save As, 4–4
Saving, 4–3
Saving/Naming, 2–7
Screen Select Parts, 2–8, 6–22, 6–23
Sizing, 2–5
Zoom, 2–4

Select All, 4–13

Selectable, 3–2

Selector Switch, 5–7, 6–16, 6–17

Serial Communications, A–2

Serial Communications, Error Codes, B–24

Shaded, 3–2

SLC 500 PLCs, A–6

Slider Control, 5–36

Snap to Grid, 4–20

Special Parts, 6–36

Specifications, A–16

Spline, 4–7

Square, 4–7

Standard Toolbar, 3–22

Status Bar, 3–21

Switches (see also Pushbuttons), 6–15

Synchronize, 2–6, 5–6

T
Tank Indicator, 5–34

Technical Support, 1–2

Ten–Key Pads, 2–14, 6–18
Cannot Arrange on screen, 2–15

Text
Creating on Screen, 4–8
Registered Text, 3–21, 6–9

Text Displays, 5–11
ASCII, 6–6
Input Displays, 6–7
Registered Text, 6–9 (See also Registered Text)

Text Input, 6–19

Texture, 3–11, 4–9
Expansion (Ungrouping), 4–14



Index–5

Texture Display, 5–17

Textures, 3–15
Screen and Library, 3–15

Think & Do Software, A–11

Tile, 3–14, 3–23

Toggle Switches, 6–15

Toolbars, 3–21, 3–22
Part, 3–2
Selecting, 4–20

Tools
Menu, 4–20
Options, 4–20

Touch cells, 5–3

Touch panels, 1–4

Touchscreens, 1–4

Trend Graphs, 5–27
Data Storing, 6–25

Tutorial, 2–2 to 2–16
Review, 2–16

U
Undo, 4–12

Ungrouping Texture components, 4–14

Uploading, 2–10, 4–25, 4–26

User Parts, 3–3, 3–6

V
Version Information, 4–27

Viewing
Actual Screen, 4–21
Parts and Controls, 4–20

Volume Part, 6–21

W
Warning Displays, 6–30 through 6–35

Windows, 1–6
Menu, 4–22

WinPLC, A–11

Wiring, A–4

Z
Zoom, 2–4

Options, 4–20


