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4
LookoutDirect Basics: Windows, 
Tools, Files, and Path Names

This chapter explains how to start and get around within LookoutDirect. It 
describes the LookoutDirect screen and introduces some important mouse 
and keyboard shortcuts.

Starting LookoutDirect

Logging on to LookoutDirect

Note If you are using LookoutDirect outside of the United States, you may be required to 
use a hardware key. Be sure to plug the key into the parallel port on your computer before 
activating LookoutDirect. If you do not, the program will not run.

Launch LookoutDirect by selecting Start»Programs»National Instruments 
LookoutDirect»LookoutDirect.

When you first install LookoutDirect, the built-in Administrator account has 
no password. When the Administrator account has no password, 
LookoutDirect opens without requiring any log-in. The Administrator is 
logged in automatically.

Note Server and Client run-time versions of LookoutDirect open with the (nobody) user 
account logged in, no matter what the password setting for the Administrator account.

Once you provide an Administrator password, LookoutDirect requests a 
log-in before opening with the following dialog box.
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Enter the appropriate password in the Password field and click on OK. 
LookoutDirect is not case sensitive in this instance.

Note You set passwords with the LookoutDirect User Manager. As long as the administrator 
password is empty (that is, if you do not insert one of your own), LookoutDirect will always 
log on with the administrator as the user, and will not require anyone opening LookoutDirect 
to log on. This can be a great convenience to you as a developer of LookoutDirect processes, 
but be sure to set and administrator password before allowing others access to your 
development copy. See Chapter 6, Security, of the LookoutDirect Developer’s Manual for 
more information about the LookoutDirect User Manger, passwords, and LookoutDirect 
security in general.

The Idle time field determines how long a period of inactivity LookoutDirect 
will wait before logging off the current user. When set to 0, LookoutDirect 
leaves the current user logged in until that user logs off, a new user logs on, 
or LookoutDirect is shut down.

You can alter passwords and create or edit user accounts and groups with the 
user manager, accessed by selecting Options»User Manager. See Chapter 6, 
Security, in the LookoutDirect Developer’s Manual for more detailed 
information on the user manager and other security considerations.

Opening a Process File
1. If you have a LookoutDirect process file available, select the File»Open 

menu item from the LookoutDirect menu bar. You can look in the 
Examples folder for sample processes to start with.

2. In the File name data field, enter the name of a LookoutDirect process 
file (they have a .l4p file extension), or choose a process file from the 
list and select OK.

If you select a valid process file, LookoutDirect opens the file and 
immediately begins executing the process.

When a process file opens, LookoutDirect makes additional menu selections 
available and displays control panels and the alarm window.
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You can open and run as many process files at one time as you want in 
LookoutDirect, and close them individually or all together. While there is no 
theoretical upper limit to how many process files you can run on one 
computer, in practical terms you may begin to see degraded performance with 
a very large number of processes, depending on your computer’s hardware 
resources and other variables. Running multiple instances of LookoutDirect 
on one computer, or distributing LookoutDirect processes on networked 
computers can increase performance. 

The LookoutDirect Screen
LookoutDirect first appears on your screen maximized, taking up the entire 
screen.

LookoutDirect has both edit and run modes. You can toggle between them by 
pressing <Ctrl-Space> on your keyboard, or by selecting or deselecting Edit 
Mode in the Edit menu. The following illustration shows a LookoutDirect 
screen in edit mode.
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Figure 4-1.  The LookoutDirect Screen

Title Bar
The title bar at the top of the LookoutDirect window displays the program 
name and the name of the currently active process. If a control panel is 
maximized, the control panel name appears in the title bar.

Menu Bar
The menu bar displays the currently available menu commands, which 
change depending on whether LookoutDirect is in run mode, edit mode, or is 
open without any processes running. These commands may or may not be 
available to the operator, depending on his or her security level.

Status Bar
The status bar is at the bottom of the LookoutDirect window, as shown in 
Figure 4-1. It changes when toggled into and out of edit mode. When not in 
edit mode, the status bar is gray and the time and date are displayed on the left 
end of the bar. The account name of the currently logged on operator comes 
next. The company name as entered during registration appears in the middle, 
and the alarm status is on the right end of the status bar. The control panel 
navigation arrows may or may not be visible, depending on your system 
options settings.

When in edit mode the status bar turns yellow. The X and Y coordinates of 
the currently selected item (if any) appear on the left end of the bar. The width 
and height of the currently selected item come next. The name, filename, or 
expression of the selected item appears in the middle, and the alarm status 
appears on the right end of the status bar.

To toggle in and out of edit mode, select Edit»Edit Mode, or press 
<CTRL-Space>.

1 Menu Bar
2 Root Selection Box
3 LookoutDirect Object 

Explorer

4 Alarm Window 
(appearance depends 
on Alarms»Display 
Options setting) 

5 Status Bar
6 Object Location
7 Object Size
8 Object Name

9 LookoutDirect 
Workspace

10 Selected Display 
Element

11 Process Control Panel
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LookoutDirect Workspace
The LookoutDirect workspace is the area between the menu bar and the status 
bar. The workspace is the area in which you view and operate control panels. 
The alarm window also appears within the workspace. You organize and 
arrange control panels in this workspace area.

In Figure 4-1 the LookoutDirect workspace contains the LookoutDirect 
Object Explorer (visible only when you are in edit mode) and the Reader 
process control panel.

The visible workspace on your screen is only a window into the 
LookoutDirect virtual workspace. If control panels or their associated icons 
are partially or completely outside the visible workspace, LookoutDirect 
automatically displays horizontal and vertical scroll bars along the right side 
and bottom of the visible workspace. If scroll bars are visible, you can scroll 
around in the virtual workspace to see all of your control panels.

Object Explorer
The LookoutDirect Object Explorer is a useful tool for creating and editing 
your LookoutDirect processes. You can access the LookoutDirect editing 
functions from this window by right-clicking on objects displayed there 
(options change depending on what item you click on). You can also create 
processes, objects, folders within processes, and then organize objects by 
moving them from one location to another within a process, create objects, 
drag displayable objects and display expressions to different panels, and 
more.

To use the LookoutDirect object browser, make sure LookoutDirect has a 
process running and is in edit mode, then select Object»Object Explorer. 
The initial window along with a somewhat expanded Object Explorer are 
shown in the following illustration.
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Right-clicking inside the explorer displays some variation of the following 
menu.

 

As you can see, depending on what you selected in the explorer before 
right-clicking, you can:

• create an object

• create a folder

• create a symbolic link

• change the root computer or process.

• modify an object or process by selecting Properties

• rename an object or process by selecting Properties

• delete an object or a folder

• edit object connections or an object database

• configure security permissions for a computer, process, object or 
collection of objects

When you create a displayable object in the Object Explorer, it appears in the 
explorer window but not on a control panel. To place the displayable part of 
an object on a control panel, you can drag and drop it. If there is no 
displayable component to the object, LookoutDirect creates an expression 
(if possible).
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If you drag and drop an object or data member from one process to a control 
panel in another process, LookoutDirect inserts an expression to display the 
value represented. You cannot place the displayable part of an object on a 
control panel in a process other than the one in which the object was created.

When you leave edit mode, the LookoutDirect Object Explorer window 
closes. Switching into edit mode restores the explorer window in the same 
location and at the same size it was when you left edit mode.

You can rename folders and relocate objects with the LookoutDirect Object 
Explorer as well.

LookoutDirect also has a complimentary tool called the Connection Browser, 
not shown above, that you can use to trace the connections you make between 
objects. See the Connection Browser section later in this chapter for more 
information on the Connection Browser.

Control Panels
Control panels provide the display area for any collection of switches, knobs, 
bar graphs, digital displays, trend graphs, and other components that you want 
to use to visually monitor and control your operations. Panels can be 
full-screen, minimized, or any size in between. You can move the panels 
around the screen by grabbing the title bar of a panel with the mouse cursor 
and dragging it to a new location. Control panels can also “pop up” when an 
event occurs such as when a pushbutton is pressed or when an alarm is 
activated. There is no limit on the number of control panels you can create or 
the number of objects displayed on any one panel.

When in edit mode you can access some of the LookoutDirect editing 
functions by right-clicking on an object or expression in the panel, or on the 
panel itself.

There are three types of control panels: normal, pop-up, and pop-up with no 
icon. A normal control panel can be maximized, normal size, or minimized 
within the LookoutDirect workspace. A pop-up control panel in either a 
pop-up state or minimized. When a pop-up control panel is displayed, it 
remains on top of all other panels until you minimize it.

Control panels do not have a standard appearance. You can customize 
each control panel for your particular control strategy with switches, 
potentiometers, and other graphical objects. Some control panels may only 
display information, while others combine control and display information. 
The information displayed always represents the most current values 
available to LookoutDirect through its communications with your I/O 
devices.
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With LookoutDirect you have considerable latitude in how you make control 
panels look and operate. For example, you can draw your own switches and 
substitute them in place of the standard switches. You can easily make a 
pushbutton or switch work backwards from the way one might ordinarily 
expect. You might insert time delays and conditions behind the panel that may 
not be obvious just from viewing the panel.

Control panels are windows into your process you use to control equipment 
by flipping switches, pressing buttons and turning knobs. Unlike real 
switches and knobs, you can assign security levels to individual controls, 
as well as entire control panels within LookoutDirect. You can use this 
feature to lock out operators that do not have high enough security levels for 
specific devices. See Chapter 6, Security, of the LookoutDirect Developer’s 
Manual for more information on security.

Unlike physical switches and knobs, you can display the same control object 
multiple times in a given process by using multiple displays, both on the same 
control panel and on different control panels. For example, when you turn a 
knob in one location, all copies of that knob turn at the same time, in each 
location of that control. The same control object may appear differently in 
each location. You might display a potentiometer as a horizontal slide on one 
panel, a pair of increment/decrement buttons on another panel, and a knob on 
yet another panel.

You can have the same sort of synchronous operation between controls in 
different processes running on your computer, or between controls running in 
processes on different computers in your network. LookoutDirect networking 
makes this possible, using remote position sources and objects such as the 
Symbolic Link. 

Alarm Window
Below the LookoutDirect Object Explorer and the Reader Control Panel in 
Figure 4-1 is the alarm window. You can choose how the alarm window is 
displayed by selecting Alarms»Display Options. In Figure 4-1 the alarm 
window is set to display at the bottom of the workspace.
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Operator Input and Navigation
There are numerous methods for plant operators to make setpoint adjustments 
or switch from one control panel to another. These include mouse, trackball, 
touchscreen, and keyboard activated commands.

When the cursor moves over a controllable object, the cursor turns into a 
hand, indicating you now have control of the object. Controllable objects 
include such things as switches, Pots, and pushbuttons.

When using a keyboard, the arrow keys move the cursor around the screen. 
The <Tab> key jumps the cursor from one controllable object to another, and 
the <Space> bar acts as the left mouse button, so you can click on a 
controllable object without actually using a mouse.

You can also tie keyboard function keys to control panels and other objects, 
so you can switch between control panels or issue control commands just by 
pressing a function key.

Virtual Keypad
When you are in operating mode, you can click on a digital Pot control and 
bring up a virtual numeric keypad to enter numeric values, either with a 
mouse or a touch-sensitive screen.

Virtual Keyboard
LookoutDirect also has a virtual keyboard you can use with a touch-sensitive 
screen or a mouse.

To enable the virtual keyboard, select Options»System and then check Left 
Mouse Click or Right Mouse Click in the Virtual Keyboard Pops Up 
section of the dialog box.
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When this feature is enabled, clicking in a data entry field or touching the 
field on a touch-sensitive screen displays the virtual keyboard, as shown in 
the following illustration.

Connection Browser
Use the Connection Browser to register network computers, navigate quickly 
between objects, follow connections, identify orphans (unused objects), and 
organize the objects in a process.

To access the Connection Browser, select Object»Connection Browser. The 
following dialog box appears.

 

See the Registering Computers section in Chapter 4, Networking, in the 
LookoutDirect Developer’s Manual for information on using the Connection 
Browser to register networked computers in LookoutDirect.

To create and modify objects as well as edit connections and the object 
database in the Connection Browser, right-click on the object you want to 
modify.

You can also create folders and move objects into and out of folders.
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Some planning on how you want to arrange the objects in each process, 
combined with an awareness of how path relativity in LookoutDirect works, 
can protect you from most inconveniences in this respect. See Chapter 5, 
Using LookoutDirect, for more information on how a change in location can 
affect object connections.

To browse the connections in your LookoutDirect processes, LookoutDirect 
must be in edit mode. After opening the browser, click on your local computer 
name, and select the process you want to browse. You will then be presented 
with a list of objects in that process.

You can use the Connection Browser to create or rename folders inside your 
process, and you can move objects from one location into another inside a 
given process, using the typical Windows drag-and-drop technique.

You can also create new objects or edit existing objects, connections, or the 
database through the Connection Browser. Right click in the Connection 
Browser to get the menu to choose one of these operations.
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When you select an individual object to show connections, your browser 
screen looks something like the following illustration.

In this example, the Pot object named Client_Pot1 has been selected. All 
the various display sites and connections are shown, including the way this 
Pot is remote connected to a data member in another process.

The $Alarm and Timer1 object icons are faded in appearance. This indicates 
that this object is an orphan, meaning that its output is not being used by any 
other object.

By clicking on input or output objects you can trace chains of connections in 
your processes. By right clicking on an object or parameter, you can edit the 
object or parameter from the Connection Browser.

While you can browse from one process to another when both processes are 
open on one computer, you cannot browse across the network to a process 
running on another computer. The Connection Browser will show a network 
object on the screen, but cannot browse that object.

LookoutDirect also has a complimentary tool called the Object Explorer that 
you can use to trace the connections you make between objects. See the 
Object Explorer section earlier in this chapter for more information on the 
Object Explorer.
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Connection Browser Options
You can simplify the Connection Browser view by selecting what elements 
of an object are displayed. The LookoutDirect default is for all settings to be 
enabled.

Click on the Options button to activate the Connection Browser Options 
dialog box, shown in the following illustration.

 

If you want to eliminate object parameters (in order to focus on data member 
connections) disable the Show parameters option.

Disabling the Show display objects removes all display components from 
the Connection Browser view of a control panel.

Disabling the Show constant connections removes all static values 
connected to an object parameter or data member. Disabling this option can 
help you focus on variables and connections to changing values originating 
in other objects.

Select Save settings on exit to keep your configured options for the 
Connection Browser the next time you open the browser in a LookoutDirect 
session.

Selecting Play sound effects enables your Windows system alarm sound 
when you attempt an illegal operation in the Connection Browser.
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LookoutDirect Application Files
Using LookoutDirect you can quickly develop a complete process file. All 
development is interactive. You do not have to program or compile. Just 
create objects and connect them as needed. The development cycle creates 
four unique files for every application: a process file, a source code file, a 
state file, and a security file.

If you develop a LookoutDirect process on one computer and want to run it 
on another computer, you must copy the process (.l4p) and security (.lka) 
files to the new computer for your process to run properly.

You can also copy the source and state files, if you want, but LookoutDirect 
can recreate these files in the new location if necessary.

Process File
A process file is a compiled file that contains the LookoutDirect process you 
want to run. It is updated every time you select the File»Save command. 
Process files are binary files with an .l4p (LookoutDirect Process) file name 
extension. You do not directly edit or modify process files with a text editor. 
Rather, LookoutDirect compiles the .l4p file on an object-by-object basis as 
you create each object. With this approach you can stay online while creating, 
updating, or editing your application. There is no need to shut down your 
process. LookoutDirect does not cease operation while you add or delete 
controllers, I/O, graphics, or modify your logic. It is recommended that you 
save your process often while editing, so that you do not lose changes in the 
event of a power failure.
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Source Code File
LookoutDirect also automatically updates a corresponding source code file 
when you invoke the File»Save command, LookoutDirect can compile this 
file to create an .l4p file, so it includes object definitions, names, I/O 
configuration, communications, control logic, control panel layout and other 
object parameters.

Source code files have an .lks (LookoutDirect Source) file name extension. 
These are standard ASCII text files that you can print or view with any word 
processor or text editor. You can use this information for debugging and 
documentation purposes.

Note Because the binary format of LookoutDirect process files both past and future is 
subject to change for efficiency reasons, you should always keep your .lks source files 
backed up. This is the file you will recompile to open a process created in an older version of 
LookoutDirect with any new version of LookoutDirect released in the future.

You can recompile LookoutDirect source files through the Open command, 
or manually, using a DOS window.

To open and compile a source file inside LookoutDirect, select File»Open. 
The following dialog box opens.

Set the Files of type to LookoutDirect Source Files (*.lks) and 
select the source file you want to compile.

To compile a LookoutDirect source file manually, consult the instructions in 
Appendix B, The CBL Compiler, in the LookoutDirect Developer’s Manual.



Chapter 4 LookoutDirect Basics: Windows, Tools, Files, and Path Names

© Automationdirect.com 4-17 Getting Started Guide

State File
The state file contains the actual values of object data members. These values 
include setpoints and other important data held within and used by objects. 
You might think of the state file as permanent memory for LookoutDirect 
setpoints and real-time trends. LookoutDirect uses the state file to store the 
position of switches, potentiometers, and trend lines. When LookoutDirect 
first loads an application, it reads the appropriate state file to determine what 
state the Pots, switches, trend lines, and so on should be in upon startup.

The state file updates any time you save, close or exit the LookoutDirect 
application file. It can also update on a periodic basis as defined in the process 
properties dialog box or the Loader object. You invoke this dialog box by 
selecting the File»Modify Process menu command. State files have an .l4t 
(LookoutDirect State) file name extension.

Security File
Every LookoutDirect process has an attached security file, identified by the 
.lka extension. All the security information for a LookoutDirect process is 
kept in the .lka file for that process. You must keep the .lka file in the same 
directory as the .l4p file for your security settings to work. If you misplace 
the .lka file, all users will have complete access to all parts of the process. 
To reconstruct the file, you would have to reset all your security permissions.

See Chapter 6, Security, of the LookoutDirect Developer’s Manual for more 
detailed information on LookoutDirect security.



Chapter 4 LookoutDirect Basics: Windows, Tools, Files, and Path Names

Getting Started Guide 4-18 www.Automationdirect.com

Configuration Shortcuts

Mouse Shortcuts
This manual references a number of mouse-implemented shortcuts. 
Becoming familiar with mouse commands is easy and pays significant 
dividends during application development.

Note You can select multiple items on a display panel by clicking in a panel and dragging 
the box outline around the objects you want to work with. Subsequent commands affect the 
entire group at once or toggle from one item to the next, prompting you for new instructions. 
You can stop this process at any time by holding the <Shift> key down and selecting either 
the OK or Cancel buttons in the current dialog box.

Function Mouse Action

select object display, graphic, text, 
expression, or any item on a 
display panel

Click: Select the item by pointing 
the cursor at the item and clicking 
the left mouse button. (See Note.)

create a new object from an 
existing object

CTRL-drag: Select the item(s) 
you want more of. Hold the CTRL 
key down and drag the selected 
item(s). This makes a completely 
new instance of the control: 
<CTRL>-dragging Pot1 will 
produce a new object named Pot2.

copy object display, graphic, text, 
expression, or any item on a 
display panel

Shift-drag: Select the item(s) to 
be copied. Hold the <Shift> key 
down and click the left mouse 
button while dragging the item(s). 
This makes a duplicate of the 
selected object that is linked to the 
original. Both the original and the 
duplicate have the same name.

modify display or object 
parameters of an object, graphic, 
text, expression, or any item on a 
display panel

Right-click: Select the item(s) to 
modify. Position the cursor over 
the item(s) and click the right 
mouse button.
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Remembering Object Names
Many dialog boxes contain expression fields. Expression fields are yellow to 
indicate that you can get help identifying or remembering an object name and 
associated data members by pressing the right mouse button (right-clicking 
on the selected expression field).

Assume, for example, that you want to average some value. You start to create 
an expression for this value, but you cannot remember the name of the object 
or data member you want to have an average value for. Right-click on the 
expression field (the field in which you normally type the a data member you 
want to connect or display).

When you right-click any expression field, LookoutDirect presents the 
Revise expression dialog box, as shown in the following diagram.

  

Figure 4-2.  Expression Editor Activated by Right-Clicking on a Yellow Data Field
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Using the expression editor, you can easily paste object names and their data 
members directly into the expression field. Navigate through processes and 
objects until you have selected the object and data member you want. Paste 
them into the expression editor data field, either by clicking on the Paste 
button or double-clicking on the data member. Click on OK, and 
LookoutDirect writes your expression into the expression data field of the 
object, such as the Data field in the Create Average Object dialog box 
shown in the following illustration.

 

Path Names in LookoutDirect
In versions of LookoutDirect prior to LookoutDirect 4.0, you could only have 
one process running in any instance of LookoutDirect, and there were no 
folders in a process to organize objects. Networking was done through DDE, 
which used specific paths.

In LookoutDirect 4 and greater, the relationship between objects running in 
different processes on different computers is far more flexible and potentially 
complicated. When you insert an expression on a LookoutDirect panel or 
make a connection to or between data members, you might be displaying a 
value that comes from the process containing that panel. You might also need 
to display a value that comes from another process running on the same 
computer or from a process running on some other computer in your network.

A path can be absolute, starting with a computer’s fully qualified network 
name and leading through nested directories and subdirectories to a single 
object; or relative, instructing the computer to search for an object in some 
directory defined not from the computer down, but relative to the currently 
active folder.

In order to provide maximum programming flexibility, you can use a number 
of different levels of relativity, or path relativity modes, in setting the path to 
the data when you create an expression. These modes operate very much like 
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other relative paths used in DOS operations, spreadsheet cells, and Web page 
addressing.

You can set a path for each individual object or connection, using a different 
level of relativity. These path relativity modes include:

• Relative (the LookoutDirect default)

• Process Relative

• Computer Relative

• Absolute

The level of path relativity you choose makes a difference in how your 
process operates when copied or moved to another computer. For instance, 
suppose you have a client process running on computer Alfred that refers to 
objects in a server process also running on computer Alfred. If you run that 
client process on computer Bert, will it refer to objects on computer Alfred or 
computer Bert?

Setting the level of path relativity is how you can control which objects your 
processes refer to. The key point to remember about path relativity modes in 
LookoutDirect is that the modes are distinguished by the path prefix.

In Relative mode, the form of the path is:

object

or

folder\object

without prefix.

Relative mode is the default mode in LookoutDirect 4. All paths are relative 
to the folder or process that contains the expression you are creating or the 
object you are connecting to. Use Relative mode when connecting objects 
that should be grouped together and that should be copied or moved as a 
group.

Connections between objects in a folder should use Relative mode so that 
they can be copied and moved elsewhere while maintaining the same 
relationship with each other.

Process Relative mode is indicated by a single prefixed backslash (\) 
followed by a folder or object name, as in:

\folder\...folder\object

or

\object



Use Process Relative mode when you want to make a connection between 
two objects in different folders in the same process.

Computer Relative mode in indicated by a prefix consisting of two 
backslashes, a period, and a backslash (\\.\) followed by a process name, 
as in

\\.\process\folder\...folder\object

Use Computer Relative mode when you want to reference other processes 
running on the same computer.

For instance, if you had a process called Station_Control that called a 
number of other processes by name on computer Alfred, you could use that 
same Station_Control process on computer Bert, to refer to the 
identically named processes running on computer Bert.

Absolute mode is indicated by two backslashes (\\) followed by a 
complete network path, as in:

\\computer.place.com\process\folder\...folder\object

Absolute mode is, in effect, a URL. Use Absolute mode when you want to 
refer to a particular process on a particular computer. Any references to a 
PLC, for instance, should be in Absolute mode so as to always refer to the 
computer physically connected to that PLC—no matter where the process 
making the reference is running.

Note Though Relative mode is the LookoutDirect default, when you use an object outside 
the immediate location of your expression, the path becomes more specific. The addition 
of two periods (..) at the beginning of a path, for instance, can be used to specify the parent 
of the first folder listed.

The reason for manually changing a path mode to a level beyond that strictly necessary 
under your current circumstances is to ensure that your process will still work properly if 
you relocate it, completely or partially.


